Is this the perfect standalone tablet for HA?

Yeah, it’s local for me, but I’m happy to adopt any method of that allows the screen to fully turn off when no one is in the room. I guess I’m curious why your screen turns off due to ‘lack of activity’ and mine does not. Perhaps it works with Fully but not the HA app?

Mine turn off deliberately via HA, not from the device itself.

I did try that and it has worked better so far thanks. My dash originally had 3 super small feeds using webrtc/go2rtc. Mainly so I can ernlarge when needed. Guess maybe ill just make some buttons to go to a sub view or another dash or something instead of the feeds. This unit is only 8" instead of 10" of my lenovo display in the kitchen so still getting used to everything being smaller anyway and such small feeds provide no real value :slight_smile:

How do you turn it off via HA? Do you mean using Fully integration?

Yes fully kiosk via the fully integration in HA

Hi All, Update on Yakk. I’m see some instability issues, not sure if it is because I still have Fully Kiosk installed (camera motion detection is turned off, and permission denied) or it is related to app switching (going from Fully Kiosk to my Music App Tempo). I’m going to do some more experimenting. I’ve also reached out to the developer of Yakk and gave some background on the Lenovo to see if there might be interest in working on the app w/ the lenovo.

So anythoughts on running Google home voice on this device? I do like how on my Lenovo smart display 10 when I ‘cast’ HA to iti get Google voice (hey Google) with it. Anyway to do this. Thanks

Did you manage to fix this? I keep getting stuck on this error message no matter how I try. Thanks!

No, unfortunately I couldn’t solve this problem. Just ordered a new one ThinkSmart :pensive:

Heya, i have the same issue - did you figure out a solution?
It was a previous 8.1 build that I just used QFIL to flash the A11 image - is there a different process or is this the WiFi issue?

No, I put n a load of time and just couldn’t get it to boot with A11. I gave up in the end. I think I might have more luck with one of my other units but don’t want to take them out of action. From what people are saying anyway, A11 isn’t stable enough or has other issues. 8.1 works with the few limitations it has.

PMOS was interesting and the hardware generally works but there are still quite a few issues and no fully kiosk is a pain for me as I use the integrated functionality via HA a lot.

So this is super weird, and I’ve not looked at any logs but I can 100% confirm that if I leave the device to boot on A11 it will hit the boot loop issue.

But, if I intervene and launch fully kiosk browser (which has to be quick, as you don’t get much time before it crashes) it doesn’t crash.

I do t get that far. :frowning:

ok, super weird. After going to A11 and coming back to A8 (Kingston-ha-rom) i’m stuck on the HA boot screen, and I’m not able to adb to the device.
Tried using the vol+ & vol- boot menu to allow updates via adb, BUT, I get permission denied.
Using the latest pull of the kingston-ha-rom.7z in OP

EDIT: Flashed 2 devices (both in the same state after A11) - one from Windows and one from Linux. Both stuck on HA bootscreen

not sure if useful, but on the device logs i see:
failed to open /sys/class/android_usb/android0/state: permission denied

SOLVED: based on a comment above, the devices were stuck in the boot screen due to differing sizes of partitions.
I downloaded this lenovo device teams image via the Windows QFIL (using the default Qualcomm driver).
The key is to make sure you run the QFIL program as an admin, and Download the image to the device soon after putting it in edl mode.
Then factory reset
Then reflashed with the A8 image

1 Like

So with the release of Music Assistant 2.0 (which allows you to add Fully Kiosk as a player) I can now get music playing through Fully Kiosk Browser on the 8.1 ROM. Still experimenting but seems to work well.


I saw that release and will have a play today although I’m currently reserving the thinksmarts as announcement players and any music goes through my Sonos speakers. Gives another option but wonder what happens with announcement TTS when playing music.

Just been playing with it - it’s FABULOUS! Generally works pretty well. It’s currently scanning my music library of over 50,000 tracks! Will take some time and a good test to see how it handles large databases.

A few bugs or oddities but very nice indeed. I see some settings for announcements. Didn’t resume playing after the announcement but need to play a bit more.

seem to be stuck in 900e mode.


Yeah, this is EXACTLY what I wanted. And it works great on the ThinkSmart.

Now just to find some ways to integrate it into a dahboard better…

1 Like