Is this the perfect standalone tablet for HA?

Hey rockstar,
for me, the key was getting the updated bromite webview installed. I’ve posted previously about my process using the deadman thread from XDA, and then disabling some of the built in apps. I’ve now got three units running the way I want using the process, but not guarantees, from the PMOS thread, it seems like there may be a couple of different varients.
Jeff

1 Like

On 8.1 I tried various web views and nothing helped with playing audio through a browser. YouTube App kind of worked but would buffet continuously after several seconds. I don’t use that though so didn’t go any further.

The audio does play through Fully Kiosk (TTS and Music Assistant etc)

So are you saying you have 8.1 with bromite and it plays audio through a browser?

Yes, the bromite browser, the Webview Browser Tester, and Fully Kiosk browser all play audio for me. Youtube plays video & audio in bromite and the webview browser tester. Fully Kiosk does Music Assistant in its browser, haven’t tested youtube in it.
Jeffrey

OK, after not understanding your advice, I just realized you thought I’m looking for proximity based wakeup, and hence need to open my camera.
However, I can’t get wake up to work at all. I was expecting that a tap on the screen should do it. What am I missing?

I got it today and it seems like the display is not that bright compared to a smartphone. Can anyone confirm this is normal?

All three of mine are plenty bright, do the point I had to make a custom dimmer on my kitchen one as it was not kind to the family at night.

Mine is bright too, I assume you’ve check the Android Display settings…

You probably have the auto brightness setting turned on - it’s on by default. I ramped mine up to max and turned that off and it’s plenty bright enough.

Mine is still on the factory software. On highest brightness it is to bright at night for comfort, but I think at lowest brightness it should be okay. Is yours to bright even on the lowest setting?

Does anyone have any idea how bright it should be in nits?

Hey folks on A8, are you able to setup Google assistant? I’m trying to replace my Lenovo clock on the bedside with the Lenovo, but my wife uses Google assistant on the clock.
The A11 image had the assistant built in. I’m not familiar with what MicroG services successfully emulates and what else might be needed?

Until I can get a local HA assist pipeline working, I’d like to put Google assistant on one of these. Any thoughts?

Hi All, adventures continue. Anyone had any success with a bluetooth speaker? I’m playing with Music Assistant (really cool, but I really want the ability to associated a Lenovo with a player in HA so I don’t have to go into MA and select the right one) and I want use an external bluetooth speaker. I can pair a speaker, but I don’t get any sound. Again, I’m on 8.1.
Thanks!

It is currently not clear to me which operating system is recommended: The one offered here or the one offered under this link

That’s because each has its pros/cons. For me, 8.1 is still the most reliable and usable with one caveat that audio doesn’t play through the browser with HA running on the browser. There are some other issues but I’ve circumvented those with how I use the device.

The link you shared can be a bit confusing as it started out with looking at various options but fairly quickly became a topic for PMOS (Postmarket OS) which is Linux based. I did get that running and was working but there are (as of a couple of weeks ago), quite a few issues with the user experience. The people developing that were mostly concerned with getting hardware working and drivers written etc. I would expect that to improve over time as they are quite busy working on it. The biggest issue with Linux for me and using HA is that there’s no Fully Kiosk support. I use FK extensively and love the extra features and control it gives, so losing that is a big issue that would require a lot of extra coding/config/setup.

There’s also A11 (Android v11) but I only ever got that working once on my test device and could never get it booting again. Different issues with that one - some people seem to report instabilities and occasional boot issues but have had better success with audio and using it as a voice assistant. A bit of discussion here https://github.com/dinki/View-Assist/wiki/Lenovo-ThinkSmart and some recent work on creating an install guide (still doesn’t resolve my problems though with getting A11 running again).

So overall, there are people trying different software but IMO, 8.1 is still the most usable with those caveats. No one route is perfect.

5 Likes

Excellent recap of the current state of things.

Thanks :blush:

1 Like

I can confirm that it does seem to depend on the character length. I have no clue how to begin to fix this, but to reproduce the behavior:

Set volume to 20%

service: media_player.volume_set
target:
  entity_id: media_player.lenovo_cd_18781y
data:
  volume_level: 0.2

Play a short message

service: tts.cloud_say
data:
  entity_id: media_player.lenovo_cd_18781y
  message: This message is 35 characters long

Set volume to 20% again for consistency

service: media_player.volume_set
target:
  entity_id: media_player.lenovo_cd_18781y
data:
  volume_level: 0.2

Play a long message

service: tts.cloud_say
data:
  entity_id: media_player.lenovo_cd_18781y
  message: This is a longer message. It is 75 characters long which is longer than 60.

Long message will play at full volume. The media_player volume level is not changed. Playing the short message again without touching the volume will again play the short message at 20% volume.

Edit: The media_player in this case is a Fully Kiosk Browser

2nd Edit: I did some more testing and found that it’s not the character length that’s the issue but the length of audio. Those two are closely correlated but I was able to create a 54 character string that is 12 seconds long which plays at max volume and a 67 character string that is 4 seconds long and plays at the set media volume.

I also cached the TTS files and played them back on my computer as well as another device running Fully Kiosk and in both cases the files played at the same volume. I stripped all meta data, normalized the volume between the two files, and uploaded the new files to home assistant for playback on the Lenovo and the longer file still plays louder. What is very odd to me is that a much longer audio file, such as a full song mp3, plays at the typical media volume.

1 Like

I was able to flash it, but it didn’t end on lockscreen but on startscreen. Is this normal behavior?

i am experiencing the same flickering. It is not the HA dashboard because I’ve got the aurora store open

Mine is crashing and rebooting when I try to Update play services in Aurora store. Is anyone experiencing the same behavior?

Not sure what you mean - can you explain the issue further