isMappingType ImportError: cannot import name 'isMappingType'

I have been trying for the last 2 days to get HomeAssistant installed. I am running a fresh install of Raspbian full and each time I run the installer command, I get the following errors.

Cloning into 'fabric-home-assistant'... remote: Counting objects: 314, done. remote: Compressing objects: 100% (12/12), done. remote: Total 314 (delta 5), reused 0 (delta 0), pack-reused 302 Receiving objects: 100% (314/314), 136.05 KiB | 71.00 KiB/s, done. Resolving deltas: 100% (178/178), done. Checking connectivity... done. Traceback (most recent call last): File "/usr/local/bin/fab", line 7, in <module> from fabric.main import main File "/usr/local/lib/python3.4/dist-packages/fabric/", line 13, in <module> from operator import isMappingType ImportError: cannot import name 'isMappingType'

I’ve searched on here and from what I’ve found, this was fixed back in Jan but I can’t get past this. I’ve tried many times and each time it crashes here.

Before I ran the installer command, I ran a apt-get update and upgrade to make sure I was up to date. I also ran

curl | sudo python3
ln -s /usr/local/bin/pip3 /usr/bin/pip3

to make sure I was running the latest pip. (I saw this in a thread here as a possible fix.)

Can anyone help with this? I want to get this going so I can take advantage of all my automated equipment.


I am in the same boat - I get the same error. I am trying to install it using “Raspbian Jessie Lite”.
May be it is better to use “Raspbian Jessie with Pixel”?

I gave up after days of not getting any reply. I ended up installing it via the manual route. Wish I could help you with this.

Actually I followed the manual route as well :slight_smile:
I can highly recommend this guide if any one is interested in installing home assistant with Raspbian Jessie Lite:

the video might be a bit lengthy but I followed the instructions and I only had to do minor changes.

This fixed it for me:

mv /usr/local/bin/fab /usr/local/bin/fab.unused

Then re-install fabric:

sudo apt-get install fabric

Then a reboot and re-started the installer