Issue installing Broadlink integration


I’ve recently installed Home Assistant and I’m trying to create an interface for using Broadlink RM4 Mini. At first, it worked. However, after usinbg the learn command and creating a few scripts for A/C control, the Broadlink integration stopped working. It appearead in the integrations tab but it said “Not loaded”, so I tried uninstalling it and installing it again, but now I get the following error: “Config flow could not be loaded”. I have tried removing the scripts from the scrips tab and from scripts.yaml but I get the same error.

This is my configuraton.yaml file:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

  themes: !include_dir_merge_named themes

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Does anybody know a fix for this issue or what might have caused it? Thank you!

Sometimes the broadlink “locks” and needs to be unlocked for Home Assistant to find it. You can go in the broadlink app and make sure the “lock device” toggle is off.

Unfortunately this is not the issue.

A lot of people seem to be having this problem. Not just a Broadlink issue, apparently.

Yes, could be a bigger issue. If so I would comment on any existing github issue or open a new one. But to rule out a connection issue to the broadlink, can you ping the ip address of the broadlink from the machine running Home Assistant?

I solved the issue by performing a fresh install of Home Assistant, as there wasn’t much to be lost. Thanks for the replies.

1 Like