Issue setting up WiFi interface

Hi I am a newbie to this OS and to Home Assistant. I understand that Wifi is not the best option but I do not want to do the configuration in my basement.

That said I have tried using the steps in this link:
Install Home Assistant - Home Assistant (
To use a USB stick to configure the wifi and it never connects. I do not know what to use for the UUID, I used a randomly generated one a V1 version but doesn’t connect.

I then used the info in this thread:
Guide: Connecting Pi with Home Assistant OS to wifi (or other networking changes) - Home Assistant OS - Home Assistant Community (

To go to the OS and check the wifi radio (nmcli radio) and it shows all 4 items enabled. But when I try to do the “nmcli device wifi connect…” command it returns that no Wi-Fi device found.

So what do I do to get past this point?

When I do mncli con show command it only lists one item HassOs default type ethernet.



You can set up wifi networking in the supervisor menu now.

Hi Tom so Im at the console and I can exit out of the Home Assistant console and get to the OS command prompt.

From there how do I access this supervisor menu??



Open a web browser. Navigate to your home assistant Lovelace frontend. Click on the supervisor link in the left hand menu. Select the System option in the top menu of the supervisor page. It’s somewhere in the Host box. I don’t have wifi on my system so don’t see it and cant post a screenshot.

1 Like

To add to @tom_l’s answer, you may need to have your Home Assistant host down in the basement plugged into your modem/router so you can connect to it through the web browser on your computer and configure the wifi as he described. Once you’ve done that configuration, you can shut it down, move it to where you want to keep it, and start it up there.

I have to ask though, why not install it down there, if it will still be accessible over the network? There is virtually nothing you will ever need to do physically at it once you have it connected and can access it over the network

Hi thanks, so I have it in the basement on ethernet and have access to the web server now. Will leave it as is for now but issue is its ability to communicate with some of the zwave devices.

So zwave is my next issue, I have a Aeotech usb zwave controller but it does not appear to be discovered. I see it in the hardware file listing on USB0 but its not seeing any zwave devices. I watched this video on how to add one to the system but it appears to be for a prior version of HA as I do not have a file editor option.

home assistant zwave usb interface not showing up - Google Search

Any thoughts? I read a couple threads that indicated the people added a cheap usb hub and that solved their problem. Does it matter which port its plugged into? its a RPi 4 keyboard version.

Thank You


Can you not get ethernet fro. The basement to where you get a good reception for zwave?

Hi Sam, so ethenet is fine for now not concerned about that. My new issue is it doesnt appear the USB Zwave adapter is working. Its a AEOTECH Gen5 stick. I found a thread that stated on a Pi4 I needed to disable the onboard Bluetooth interface to free up the UART which I did, added two lines to the config.txt file. But I still do not see any zwave devices being discovered and I would think I would need to configure the zwave network properties.

I see some people talking about needing a USB hub for it to work but that doesn’t make sense. Also I see others reviewing a log, OZW_log.txt but I have no idea where that is to review it. The links in the HA webpage do not appear to have that detailed info.

Thank You


Have you installed the open z wave add-on, from the supervisor panel?

Hi thanks, so no I have not, the write ups are not clear, you would think it would say to install the add on for zwave to make it work. I didnt even go in and look at add ons thinking I need to get the basics work first.

Doing it now thank you!


So I installed the add on, it needed to be started but wouldnt saying it needed config info.

In the config I put this for the device, which is what I saw for it on the cli using another command I dont remember now.

In the device setting I entered “/dev/serial/by-id/usb-0658_0200-if00” and I did not enter a network key

After I restarted it, it now has this error: 502: Bad Gateway

I then went to go back into the configuration but could not find where that was as it was a pop up but went to the integrations screen and saw that Open Wave was now listed. I selected to configure it, selected the device and now it is starting and when I click on OpenZwave link I see a page and it appears to be asking for config info.

Its a client window and says the serial port is ttyACMO and when I click on enable it just goes away.

Is it working correctly now or do I need to do something else to make the zwave interface work??



Hi Phil,
Could you share a screenshot of this, I’m just trying to plot exactly where we’ve ended up in my head and have gotten a little lost :stuck_out_tongue:

Hi so because I have done so many ODD things I found and may not be needed I reflashed my SD card and starting fresh.

So during the initial setup in the web page and the initial integrations setup, I selected to add the OpenZwave add on. It is now asking to set it up and wants to know the USB device path, it is auto filling in this: /zwaveusbstick

Now at one point I had run a command in the system page to see devices and it listed these:

  • /dev/ttyACM0
  • /dev/serial/by-id/usb-0658_0200-if00
  • /dev/ttyAMA0

Im assuming my device is the second line and I should put that in or should I leave what it auto populated?



Yeah, that should be it

Hi so I made good progress I went with the suggested default tty port and it worked. I was able to add in a multi sensor.

New question. these zwave items show up on the dash board but listed as ready. doesn’t appear to be a way to assign to an area like my Hue lights.



Ive figured it out, I have been able to add them to areas and rename them. It is odd as I have to rename them both at the top of the overview page and down below where they are just listed as ready or sleeping.

I have other questions but will start a new questions/thread.