Issue to link Home assistant to Netatmo

Hi,
I have some issues when trying to link my Netatmo to Home assistant.
I can see the integration in the discovery UI. When I click to configure I got linked to Netatmos auth page. Here I got a choice to Accept the third party integration. But nothing happends when I click “Yes, I accept”.

I’m currently runnting 2023.11.2 (Home Assistant Cloud throught Nabu casa).

I’ve tried to create a develpoers account with Neatatmo, and added client seecret/toekn in configuration.yaml. If I try to link the account using this method it says that auth is done but I don’t get any entities in Home assistant.

Any ideas?

I have almost the same issue. When I try to add Netatmo (weather station) to my account via the integration page I get in a loop on the Netatmo site (can only answer accept and decline but accept takes me to the same page).

I have this exacte same issue. I’m stuck in a loop when accepting

Just saw there is another thred om this topic.
Seems to be fixed in next version.

Same issue here.
I tried multiple browsers, just in case, but still the same loop :confused:

I used a the dev version of HA to link my new Netatmo instance. This confirms that the issue is fixed in the next release of Home Assistant.