Issues adding Schlage Lock

I am adding a Schlage Lock to my network. It was working fine on SmartThings. I removed it from SmartThings and tried to add to HA.

I added using “Add Secure Node” I have a network_key configured so this should work.

It got added at first as “Unknow Device” but after a restart it showed up as “Schlage FE599GR Wireless Door Lock”.

I renamed to “Entry Lock” and that worked fine.

But when I use the UI to lock/unlock, nothing happens. When I manually lock/unlock status is not reflected in HA.

So I tried to “Remove Node” to see if adding it back in work work.

I selected Remove Node and put the lock in include/exclude mode.

Nothing changed, the node remained.

So I tried “Remove Failed Node”, again no change.

So I am now stuck with a device which may or may not be included and no real way to tell.

What should I do to repair this?

Edit: I might have made matters worse. I decided to try to include it again. Now I have the lock listed twice but neither works.
image

How do I remove remove these?
How do I get this lock working? I followed the post here


But that is how I got in the state I am in.

anyone have this lock and some advice?

When you remove the lock from HA can you see the green check mark on your physical lock? I removed mine following like this: Invoke remove node in HA, then go to your lock (as fast as you can) and provide your programming key to put your lock in exclude mode and you should see a green signal (in my case a green check mark that indicates that the lock was successfully removed. Then re-start HA or better reboot you RPI.