Issues with 3 way Switch On Stairs

I seem to keep falling into different issues with different switches but also trying to use ZHA in just Home Assistant and trying to come away from Smartlife App, so please bare with me on this as I keep getting different outcomes and some seem better but still not correct.

But then go to worse a day or so later or they do not work as they should. Due to one of the switches being a No live wire need which in the UK we do not have any No Neutral Wire in the properties. I have now added a capacitor in to make sure that is done right now!

Then Im told you cannot have an RGB colour Bulb when connected to a switch which is what I want and was then informed the best way is to use Hue Bulbs to do this but not fully sure if that will also correct on my needs to be more local rather than using other servers to run things.

Why the ZHA approach?

So I changed over to this new Switch a few days ago called a Yagusmart WiFi Smart Wall Light Switch, No Neutral Wire Required, No Hub Required, Compatible with Alexa and Google Home, APP Remote Control, Timing Functions, Voice Control(2 Gang-Black) [Energy Class A++] with AISIRER Alexa Smart Bulb WiFi Light Bulbs E27 Screw, 2 Pack, 10W 1000LM, App or Voice Control, 90W Dimmable White and RGBCW Colour Changing Light Bulb, Works with Alexa, Google Home, No Hub Required
and everything seemed to be working great with no issues at all the bulbs would come on and off from the switch itself as well as in HA then after me messing around with Automation and things.

I noticed the outside light started to come on whenever it felt like it and this was after I used a method of using automation to make a switch turn strip lights on and off I did that.

Then realised it needed to be done the opposite way around and when the button was pressed need it to have turned to on from Off which again was fine and works 100% in HA

But the Switch buttons a day after stopped working altogether, the lights come on and off when I used HA for lights and also the Automation all work right with the Sensors just not sure what has happened so I’m unable to use the switch buttons at all now.

I have also taken the sensors out of using Smartlife and just using HA now so Im now only using HA for the setup.

I then thought maybe I need to reset the switch a repair it in Smartlife as it’s not compatible I dont t think only using HA unless someone knows more about this to help me get it fully into HA be great, but any how I was unable to put it into pairing mode as like I said the buttons have stopped working.

So could it be a faulty Switch that needs to be sent back or a software glitch stopping me from pressing any buttons? I have not tried to turn the main power off yet to see if that will reset the switch as that will be the last thing I do before sending it back.

Hard for me to fully explain this issue as I have done many different things to get it working! the other Switch I tried was a MOES Tuya ZigBee Smart Touch Switch, which Requires Tuya ZigBee Hub, No Neutral Wire No Capacitor Needed, also Works with L & N wire, Compatible with Smart Life Tuya App Alexa Google Home, 2 Gang, White which gave me even more issues and did not work n HA at all really!

As I correctly understand your issue is that your pysical switched stopped working.

How are they added into HA? through the tuya API or just directly on the local network?

If locally, it might even be as simple as a DHCP “issue”, as the devices go to sleep and wake up and getting a different IP.

On the other hand, I think there is some automation in the way which was used before.
Within Tuya, create a new app and add only those devices into it. So any other connection is cut off.

I’m adding the Sensors into Ha with Zigbee Home Automation, which they are using a Sonoff

Detected as an RH3040 by TUYATEC and the bulbs are added into Ha with Tuya one of them is still showing up with a pir 4 that I set up in smartlife but not sure of to delete it so at the moment I have just disabled it. Then I have another to Automate the on-off of the bulb.

Not sure how these have affected the switch seem to be after I added an outside Led to the switch when I started to have the problem with the buttons not working.

I’m a little clueless on a DHCP as I do not fully understand what it is what’s it doing and where its coming from.

I have a Mesh setup with two routers being a ASUS RT-AX82U and within HA I have that setup to use Cloudflared so I have my own address to go to in Ha and am able to use outside as well! I also have the same switch upstairs which I have had in a few years now and never really gives me any problems at all button on it works fine and I can use it in Ha fine only difference is that that light is not using smart Bulbs and just being used as a normal light.

This is why I changed the downstairs to this kind of switch as I know I could use both and now very confused about what’s changed on it over the day.

I’m also not sure what you mean by making a new App? Are you meaning I remove all I have made and start again? Not at all sure how I can even re-pair this switch as no button will take me pressing it in 5 secs to put it into pairing mode again!

Also the switch and bulbs are still in smartlife but no Automations are set up for any of them now and Im trying to avoid using them within that App now!

I think it is good to review your post and let us know what is used for your automation, as now a PIR has come into play.
Where are the devices connected to? Are they integrated into tuya, and tuya to HA and Google home for example.

So for your setup there are a few components:

  • WiFi Light bulbs based on Tuya platform
  • WiFi wall switches based on Tuya platform
  • Zigbee motion detectors based on Tuya platform
Within HA you can see the state e.g. the lamp if it was turned off by a automation within ha.


DHCP gives a IP-adress to your devices within your network.
If you have added the lamps or switches directly to HA and not having the tuya platform involved, it can be that the change of IP adress causes to “lose” connection.

At day 1 you add a switch to HA directly. At this moment your switch has IP adress
You DHCP lease time is 6 hours.
Over night, the swtich can go into sleep mode, disconnects from the network and the lease time expires.
Next time it connects, it will get
Now HA does not recognize that device on that specific IP adress, thus failing your integrations.

But, this is all based on assumption as it is not very clear how things are tied together.

If unknown behaviour occurs, it is good to trace back where it comes from.
If this is unknown or not traceable, the last resort is to start over.

Are the switches compatible with LED lights? I have seen situations that a dimmer and/or switch are not compatible with LED Lights.
Is it possible to switch it out for a traditional bulb just for testing purposes?

I have 3 smart switches on a stairs that controll two lights bulbs. One is master switch that can physically control the lights and other two are slave switches with just neutral and live wire connected to it.
For master switch I use moes zigbee and for slaves tuya wifi.
It just works, as ha doesn’t care what protocol you are using on them.
I had problems when I had tuya wifi for a master as lights will randomly go on off for no apparent reason.
Whe I changed the master switch this behavior stopped.

Ignore the pir 4 as that is what I first used the sensors for in smartlife which now I Do not use in smartlife they are fully used in Ha with Zigbee!

It all started when I added the outside lights into smartlife which I think now I might be better trying to do from within Ha rather than smartlife if this is possible.

This light is a outside i sa strip light 10M Alexa LED Strip Lights with Remote Waterproof WiFi RGB Colors Changing Smart Led Light Strips Music Sync APP Control Work with Alexa Strips Light for Bedrooms Bar Birthday Party(2x5m)
which I have added not by the wire to the switch but by an Automation in Smartlife with a condition is met switch is on then turned on Led outside on

This is what I think has caused all the problems and I need to better way to try to add it to the switch without it stopping it all from working from me not being able to press the button.

On the DHCP are you meaning the ipadreese that show up in my router for the devices as I tend to not look at them until I really need to as It takes me forever to document them all at once I m ok doing this later when I have time too but to get things working at the start is very difficult to do it all!

I do not see bulbs vanishing and then coming back on they seem stable and there all of the time for me anyway not sure about it picking up with wifi like it has to but thank you for explaining more on it! I think I understand where you are coming from them having a static and dynamic ip address

So what I need to do is find the switch ipaddress within my router and see if any change happens to it? do I need to do bulbs too?

The other thing is its harder for me to test during the day and when it comes to night I find im in Darkness a lot :slight_smile: trying to do i millions things at the same time :rofl:

I have tested with the strip lights and no issues with smart plugs and not caused me any issues in Ha either, but for this switch I have no clue, first time trying! I also do not connect to a Neutral wire at the back of the switch it’s done by a capacitor.

I could just remove using the strip light from within Smartlife?
but I dont think the Buttons will still work now, maybe I might need to turnText main power off to try to reset the switch.

I also removed a moes zigbee as that switch gave me nothing but hassle on anything bulbs would not stop on kept making them go into pairing mode so that was removed when I added this better switch into it was brilliant until day 2 :man_shrugging:

I still have the moes zigbee here at the side of me ready to give away! :slight_smile:

I have a spare bulb that I can plug in which is my Attic spare bulb! to swap over to test the switch! I will try this now and get back to you all on what has happened after I do a turn-off of the power as that can have an impact on things for a few hours!

As long you are sure tis is fully deleted in any automation in other platforms, that should be no issue then.

I find this the best solution for my situation.
I’ve reserverd a block of IP adresses to use for such devices. to I can assign in my DHCP as static devices.
In this scenario I always use the same ip for IOT devices without having to search for it every single time. (additonally used for security purpose, but thats not the main topic :slight_smile: )
but again, this is how they are added into HA.
If the lights are controlled throug the Tuya API, it should be no problem.

On this part I think there is something in a automation in the tuya platform causing issues.
I’m not very familiar with tuya. Only have 1 el cheapo smart plug exposed throug the API.
However, on the first meet within the smartlife app, i was greeted by power saving measurements to enable. I ignored it and thus not enabled. Maybe that part is causing trouble here without knowing?

I’ve read that a capicitator is needed if no neutral is present. this is according manufacturer specs, so not seeing any issues here.

More and more I think some kind of automation in either platform is killing the switches.
e.g. when light = on ignore other input.

for exampe, I use a light group in my ha to do some controlling.
when light.all_lamps changed to off, shut off fan.

That’s the challenge of moving step by step from A to B.
If you really want to move it, would it more time efficient to clear the tuya platform and re-add those devices?

Is there any video to help me figure this setup way you are mentioning with the router settings, I find it hard to understand by text and more onhands seeing then this!

I have turned main power off and what a ball ach and now again have to re set all lights all automation and everything just because of a power cut be easier to go back to a normal light and a lot cheaper too!

I was doing this hoping it would make my life easier to handle than harder!

But forget thaat :slight_smile: frustrationg Im having now having to do it all again.

Its also a bit wired again how its doing things and I think it was better the switch not working at all as now they are I think they are resetting the bulbs again like they did with the Moes switch and why I skipped it!

I can at moment after reset turn lights on and off from voice and in Ha and also use the switch button too, but the button now does not do it right away there seems to be a delay in it and after I try to turn on and off 5 times I get no light on.

Then I keep it pressed off a few secs and the light can then be turned on and off but it reset the bulbs into pairing mode


I have also noticed there is 3 live wires so I have now connected alll 3 of them to the switch as one of them where missed! The other two are Nuteral wires.

I think it could be the bulbs not compatible but I have the same setup in my bedroom and no issues with Bedroom light but there is no Smart switch on that.

I’m not going to mess any more on outside lights until I fully know these two switches are working fine!

I have also got ipad to use as a switch at the side so to use HA on it but again it was setup a little but not fully and I need to figure things like it auto detecting me to turn the display on the screen to see to tuen lights on and off on the stairs. but that’s a different question to ask later :slight_smile:

On a quick look at my router setting I have a long list of devices I have no clues on what device any of there are! The only say Tuya Smart Inc or ESP-with a number and their ip addresses

not sure how to find a quick way to know what device each one it?

If you are not certified electrician please call one. There is no chance that you can have 3 live wires on one switch.
You have to wire switches like this.
Master switch, control lights by connected wires, has live, neutral and light wire connected to it.
All other switches are slave switches that has only live and neutral for power.

Look man this is not hard thing to do. I have it and everything is working fine. I called electrician to rewire all the wires for it like I wrote you.
I use simple automations in home assistant to turn lights on off manually and using sensors. I have plain led bulbs.
Just relax, sleep over it and call electrician.

1 Like

For now I think that is the best advice.
Don’t do things when frustrated, it will make it worse.

Just draw it out, think it over and confirm some things.

No need to get your frustration out on people giving you advise in your situation you created on your own :slight_smile: we’re here to help eachother :wink:

but the switches cut power to the lights.
Smart lights have a default state after power return. and if you have power on the lights and able to switch them on with the ipad… isn’t just as simple as setting that default value to on?

Cutting off power and expecting to find 1 device coming back online is not the best approach.

Like said, rule out some things… remove the smart lights from the switches… to confirm switches are working… and connect the smart lights to a plug or non-smart switch to confirm those are working…

stirring in a mess of automations you don’t have full confidence off, will lead to nothing.

1 Like

Take it easy bud.
This is not the place to be for you right now I think :slight_smile: Take a beer and relax.

1 Like

Maybe you have electrians that know what they are doing (I don’t)! as you can see from this photo. I will video it too if you like and add it to utube showig you they are all live wires! ? But I no need for you to say call one I already have though no one has a clue!

Suppose to be a blue wire for N!

I don’t know. I’m not an electrician. I called a guy in Croatia that have some clue about smart switches. A lot of electrician have no clue about it. That is way I wrote you how to rewire wires for it. But not by you.
For mechanical switches there is different wiring and that is way you think there is 3 live wires but there isnt. You have only one live. Probably you have 3 switches.
Anyway this is not hard thing to do but don’t play around.

I understand clearly there is not suppose to be 3 live wires and I can also clearly confirm there is I have a metre tester as well as an electric screwdriver that lights up when live if you was and electrician you would know this. Why Im also very much confused why this as come up this wire was also wired wrongly into the original switch it come from and you can clearly see they have put it into a L1 which is an out from a switch. Has for it being what it is I have no clue I’m not the one who wired the Fu in the first place! even the colour wireing is wrong for a new rewire like they said they had done! Why its better you do it yourself DIY then you knwo its done right and know its your fault but at least you not been ripped off a million to know its only going to get wire up wrong and you to blame again! Same old stories whY I know I orked on a builing site for over 40 years so I know the tricks of all the trades and they also dont want you to kill yourself and why they help rather than annoy! Think its a good idea to put normal bulbs in to test but I do not have any to had and dont really want any as no room to store them I m not in a mantion like electricians are :slight_smile: Maybe he can go an re wire a NHS and put some 6v usb’s in he wont kill is self touching them unless he sticks is touge in then he still should be ok as at school we did it with 9v batteries :man_shrugging: :rofl: :rofl: :stuck_out_tongue_winking_eye:

here is there usless wiring too one that did not allow user to turn off the downstairs light from upstairs! And double switch was removed from upstairs by them for strange reasons (prob to make profits for there mention) Be nice to have an electrain that can donate to my medical needs and put into my charity box to buy me medical items to keep me alive by him rather than he going to a pub be more help rather than him wasting it to a farmers fruit. so please keep tot the problems rather than electrians! to me would be much appreciated by me.

They like anyone make mistakes!

So the conclusion is here, the wiring needs to be checked/fixed.

Either by you or a electrician.

1 Like

Ok as you wish. I don’t know what country you are in and what type of electrical wiring is there a standard.
For me setup was
Master switch live, neutral, light wire. 3 wires only!
For slave switch live and neutral for power. 2 wires only.
You can’t connect more than one wire in a switch connector.

Dave go get a beer. This is ridiculous.

1 Like