Issues with Aqara Switch (not working) and Smart Plug (not reporting back)

This is my first voyage to Smart Home and I am at my wits’ end. I have purchased Conbee 2, Aqara EU Smart Plug (SP-EUC01) and Aqara Double Key Wireless Switch (WXKG17LM) and both appear to be broken each in a different way?

I’ve set up HA on an old notebook, installed Mosquito Broker and Zigbee2MQTT and managed to pair both… Kind of? They appear in Zigbee2MQTT but each has their own issues.

SP-EUC01 Never seems to send a response. I can send Off and On messages, but if I hit Reconfigure or try to refresh status at some point later I get an error notification that no response was sent. Also the devices is constantly displayed as Disabled and does not show power usage.

WXKG17LM I don’t seem to be able to add an automation to it. Action sensor is visible in Device information, but when I try to add an automation the only option I have is use battery level. I also installed blueprints from here, but using the blueprint doesn’t seem to work. No traces get registered when I click the physical switch ever.

What I am trying to achieve is for pressing one of the buttons on the switch will toggle the smart plug.

My last slither of hope is that I need to update the firmware in both, but I can’t even do that since registering to Aqara doesn’t send the verification email, and it’s not like I have an Aqara hub anyway. I bought those thinking that I’ll pay a bit more but at least will get a reliable piece of hardware from a known brand, but all I got was 4 hours of poking and prodding, getting no result and feeling I wasted money.

So, I don’t really know what to do next, how to troubleshoot it or what to try. I am an extreme newb so any help will be greatly appreciated.

I currently run HA from a pendrive on a Dell notebook, have Conbee 2 connected through a USB extension. HA version 2021.12.8.

Here is a list of the devices:

(since I am a new user I can’t post more images in one post, so I’ll add the rest separately)

Plug reports as disabled:

Tried to refresh the state of the on/off plug, here are the logs:

How the switch presents itself in devices:

And the available automation options for the switch:

Names are weird because I readded the devices like 6 times.

Which version of zigbee2mqtt. Did you tried to update it?

I have a plug like this connected to zigbee2mqtt working fine, so it should be possible.

And the Availability is set to Disabled for all devices I have (close to 40, different brands) so I shouldn’t worry about that.

BTW: I found that actions from some switches only become available in automations once the events have been sent through mosquitto at least once.

I set it all up yesterday, so I’d presume it’s the latest! Let’s see…

Current version: 1.22.2-1

Okay, so I’ll not worry about the Availability then. When you connected the plug, did it all start working immediately?

Also, I just found a YT video which goes into very deep details about connecting the specific switch I have - it says I need at version on Conbee from late Novemeber, I think I should try to update its firmware first, maybe it’ll resolve both issues.

Edit: Oh, the video even shows I can check coordinator version in HA! It’s 0x26580700, while the required one is 0x26720700, I think I may have found the culprit.

After updating Conbee 2 Firmware to 0x26720700 and repairing the two Aqara devices everything works smoothly, flawlessly and brilliantly!

As for how to update the firmware, at the moment of writing I installed deCONZ software and followed this guide, but for the most part the steps I did were as follows:

  1. Download deCONZ installer and install it
  2. Download latest Conbee 2 firmware, put it into where deCONZ was installed, into bin/ directory
  3. Connect Conbee to my PC
  4. Open CMD inside deCONZ’s bin/ directory
  5. Run command GCFFlasher.exe -l to get the path to the USB
  6. Run command GCFFlasher.exe -d <COM> -f <FIRMWARE FILE>, in my case it was specifically GCFFlasher.exe -d COM5 -f deCONZ_ConBeeII_0x26720700.bin.GCF

Yep, the plug worked right out of the box for me. I have the firmware version you had (0x26580700).

Was the firmware upgrade easy? I checked some time ago and it seemed a hassle (especially since I don’t run deConz anymore). And than I didn’t really need it, so let it go.

Anyway, great you fixed your issue.

Was the firmware upgrade easy? I checked some time ago and it seemed a hassle (especially since I don’t run deConz anymore). And than I didn’t really need it, so let it go.

Thankfully it was trivial! Connect Conbee to a PC, download two things, run two command line commands and wait half a minute for reflash to be done.