Issues with Zemismart Chain Roller Shades Driver M515EGBZTN

I found holding the button while powering on, then once the light is slowly flashing, quickly press the button 3 times makes it pair.

Pairing for me is not the problem (… there’s a useful youtube on it …). Getting it to DO something is another matter. I’m eagerly awaiting 2021.14 to see if it’s in there.

Updated to 2021.14 and the cover control appears. Sadly, it doesn’t work. :frowning:

Updated to 2021.14.1 and still not working. Any ideas? Is there something I’m not doing? The zigbee device signature looks like this … if that helps:

{
  "node_descriptor": "NodeDescriptor(byte1=2, byte2=64, mac_capability_flags=128, manufacturer_code=4098, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=0, *allocate_address=True, *complex_descriptor_available=False, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=True, *is_full_function_device=False, *is_mains_powered=False, *is_receiver_on_when_idle=False, *is_router=False, *is_security_capable=False, *is_valid=True, *logical_type=<LogicalType.EndDevice: 2>, *user_descriptor_available=False)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0202",
      "in_clusters": [
        "0x0000",
        "0x0004",
        "0x0005",
        "0x0102",
        "0xef00"
      ],
      "out_clusters": [
        "0x000a",
        "0x0019"
      ]
    }
  },
  "manufacturer": "_TZE200_xuzcvlku",
  "model": "TS0601",
  "class": "zhaquirks.tuya.ts0601.TuyaMoesCover0601"
}

This is how ZHA auto-detected it. I haven’t made any changes.

is there any zha events listed when pressing the buttons

Not sure. How do I check? Do you mean the buttons on the motor or in ZHA?

both, do the physical button do anything like turn the motor itself
to check in ZHA,
goto developer tools
then events

scroll down a you will see, listen to events
type zha_event
then click start listening
then press the buttons on the controller and see if anything is shown

this post here also mentions those blind controller now working in ZHA, Switch Zigbee TZE200 TS0601 paired but without entities - Configuration / Zigbee - Home Assistant Community (home-assistant.io)

it could be an issue with your device if not working

maybe removing the device from ZHA and then repairing?

As per the post above, the controls are appearing in zha. They are just not doing anything. I have still yet to check the zha_events as I am at work (at least for the next hour or so).

The signature looks slightly different to the quirk, if you post an issue in the quirks GitHub page, someone might be able to help

Looking at the PR, your model is added but shown as untested. The signature is slightly different to yours:

I’d raise an issue here:

I’m unable to see the code. I’m getting a 403 forbidden.

I posted a question to the brainstrust here

Yes, thats the post that helped me

@aidbish I’m a little confused.

Firstly there’s nothing coming through from the roller blind uniit when I’m listening to the zha_events. However, by the same token, very few of the of the other zha events are being displayed thgat I KNOW should be displayed. I have sensors that are triggering lights that should be coming up, but they are not. It’s very odd. (Yes I did click the start listening button).

I also re-paired the device as well. No effect. I hope the device itself is not faulty. As @Holdestmade seems to insinuate, perhaps the issue is the signature that’s being detected does not match with what’s in the quirk … but I’m afraid I’m not of the level of expertise to add my own quirks. I’ve tried mucking about in portainer to unhide hassio, but it didn’t work and I’m scared I might break something if I click on something I shouldn’t.

Not sure insinuate is the correct word, but anyway, send your zha logs to the device-handlers page and sure they’ll help you out

Sorry. I had a brain-fade. I was looking for the right word. That’s the best I could come up with at a pinch. Sorry for any offence.

NO zha_event can be tracked with those, don’t ask why :wink:

I was able to track them by looking at the state change attributes. All my other zigbee devices ( mostly aqara ) can be tracked with the zha_event but not those tuya zigbee rollers.

To be able to manage them i’m use the call service cover function , you might want to try that.

If you want to track them by listening to an even like proposed above, try listening to the call_service event and not the zha

`{“event_type”:“call_service”,“topic”:“call_service”,“payload”:{“event_type”:"call_service",“event”:{“domain":“cover”,“service”:"open_cover”,“service_data”:{“entity_id”:“cover.tze200_zah67ekd_ts0601_b23ccffe_window_covering”}}

as supplemental information, i had to remove my device, restart HA and then add it back in for it to work properly and there is also a slight delay after the restart before the devices works properly.

Thanks @Philippe_Audet. I used call_service and got the following when using HA to try and control the blinds.

Event 6 fired 7:39:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "close_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:39:53.117943+00:00",
    "context": {
        "id": "178969f61f9c37f4c03bb2e047c12ea4",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}
Event 5 fired 7:39:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "stop_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:39:29.926727+00:00",
    "context": {
        "id": "c9397df49e287bdd5a578df6aa92d42a",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}
Event 4 fired 7:38:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "open_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:38:38.107885+00:00",
    "context": {
        "id": "f933f22e6147438d565ca1ad59ebcfb4",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}

Oh, and I tried what you suggested (removing the device, restarting and then adding it back in). same result. It still didn’t work.

any luck with this yet?

I came across this post when setting up these except the wifi model.

It’s not a solution BUT can you send them back and get wifi motors? Super easy to setup: Zemismart Blind motor - configuring in Local Tuya

hth

1 Like

Do not buy the product. They’re shipping a new version that forces you to buy the HUB to configure the limits. Removed the option to configure with the physical buttons.