Issues with Zemismart Chain Roller Shades Driver M515EGBZTN

Yes, thats the post that helped me

@aidbish I’m a little confused.

Firstly there’s nothing coming through from the roller blind uniit when I’m listening to the zha_events. However, by the same token, very few of the of the other zha events are being displayed thgat I KNOW should be displayed. I have sensors that are triggering lights that should be coming up, but they are not. It’s very odd. (Yes I did click the start listening button).

I also re-paired the device as well. No effect. I hope the device itself is not faulty. As @Holdestmade seems to insinuate, perhaps the issue is the signature that’s being detected does not match with what’s in the quirk … but I’m afraid I’m not of the level of expertise to add my own quirks. I’ve tried mucking about in portainer to unhide hassio, but it didn’t work and I’m scared I might break something if I click on something I shouldn’t.

Not sure insinuate is the correct word, but anyway, send your zha logs to the device-handlers page and sure they’ll help you out

Sorry. I had a brain-fade. I was looking for the right word. That’s the best I could come up with at a pinch. Sorry for any offence.

NO zha_event can be tracked with those, don’t ask why :wink:

I was able to track them by looking at the state change attributes. All my other zigbee devices ( mostly aqara ) can be tracked with the zha_event but not those tuya zigbee rollers.

To be able to manage them i’m use the call service cover function , you might want to try that.

If you want to track them by listening to an even like proposed above, try listening to the call_service event and not the zha

`{“event_type”:“call_service”,“topic”:“call_service”,“payload”:{“event_type”:"call_service",“event”:{“domain":“cover”,“service”:"open_cover”,“service_data”:{“entity_id”:“cover.tze200_zah67ekd_ts0601_b23ccffe_window_covering”}}

as supplemental information, i had to remove my device, restart HA and then add it back in for it to work properly and there is also a slight delay after the restart before the devices works properly.

Thanks @Philippe_Audet. I used call_service and got the following when using HA to try and control the blinds.

Event 6 fired 7:39:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "close_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:39:53.117943+00:00",
    "context": {
        "id": "178969f61f9c37f4c03bb2e047c12ea4",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}
Event 5 fired 7:39:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "stop_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:39:29.926727+00:00",
    "context": {
        "id": "c9397df49e287bdd5a578df6aa92d42a",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}
Event 4 fired 7:38:
{
    "event_type": "call_service",
    "data": {
        "domain": "cover",
        "service": "open_cover",
        "service_data": {
            "entity_id": "cover.lounge_room_blinds"
        }
    },
    "origin": "LOCAL",
    "time_fired": "2021-04-09T21:38:38.107885+00:00",
    "context": {
        "id": "f933f22e6147438d565ca1ad59ebcfb4",
        "parent_id": null,
        "user_id": "be48dd355f774263a0a026f2f19e21ec"
    }
}

Oh, and I tried what you suggested (removing the device, restarting and then adding it back in). same result. It still didn’t work.

any luck with this yet?

I came across this post when setting up these except the wifi model.

It’s not a solution BUT can you send them back and get wifi motors? Super easy to setup: Zemismart Blind motor - configuring in Local Tuya

hth

1 Like

Do not buy the product. They’re shipping a new version that forces you to buy the HUB to configure the limits. Removed the option to configure with the physical buttons.