I've found a working ethernet lan-only zigbee home automation (ZHA) coordinator on AliExpress

Wanted to share the link to a working ZigBee coodinator (the device that is required to connect zigbee devices to HA) I’ve found on AliExpress that works in lan-only and does not need to be connected to your server via USB (it works over ethernet).

http://aliexpress.com/item/4000465421911.html (Moes Tuya ZigBee Smart Gateway Hub Smart Home Bridge Smart Life APP Wireless Remote Controller Works with Alexa Google Home, Wired Hub model)

It can be hacked by following this tutorial (steps are 100% identical. the board has visible differences, but pins location and instructions are completely identical): Tuya Ethernet Zigbee Gateway TYGWZ-01 Zigbee compatibility

It works :slight_smile:


The ZigStar LAN Gateway works pretty well as coordinator as well.

1 Like

I’ve bought another one for a friend. This time I’ve taken some photos. :slight_smile:

1 Like


Due to my current setup struggling I am looking at options and just seen your thread.

Is it still stable and up and running, any issues with different devices / brands?

Many thanks

any chance to get a link to purchase the yellow ping and the usb adapter device?
or maybe just tell what are they called so that i can search around for them?

pin header :mag:

usb uart :mag_right:

1 Like

Current version does not allow to recover the root password any more via escaping boot loader process.

Anybody has any idea on alternatives ?

I’m seeing the same with a similar gateway.
Can’t escape the boot process so cannot attempt to crack the root password.

Looks to be running quite a recent firmware - built 2022.09.02

EDIT: After multiple retries…it worked…please disregard message

bought a second hand lidl gateway from wallapop. All fine except I am struggling to upgrade firmware

it seems I am missing something

Xmodem sectors/kbytes sent: 0/ 0kRetry 0: Timeout on sector ACK
Retry 0: Timeout on sector ACK
Retry 0: Timeout on sector ACK

Hi There!

I have a question about Zigbee hubs, I hope this is the right place to ask:

This coordinator is a substitute for the USB dongle that most of the people use, right?

I was thinking about buying an ethernet coordinator (like this one, but already flashed with tasmota) that I can place on a reachable place in the house, instead of the dongle. But, is it going to work the same? Can I send ‘posts’ and ‘gets’ to trigger actions?

And regarding the documentation, do I need to use the zigbee2mqtt integration and look for compatible devices? Or anything Zigbee compatible will work flawlessly in HASS? I would like, for example, to trigger the alarm of this smoke detector from HASS.

Thanks in advance!!

Yes, this is an Ethernet based coordinator to replace an USB based one.

The ones you currently get if you order on AliExpress cannot be hacked anymore by interrupting the boot process. People successfully installed Tasmota by desoldering, modifying and resoldering the flash. Hacking the Silvercrest (Lidl/Tuya) Smart Home Gateway - #447 by ur5dco

I tried to get the ssh password from the manufacturer but they do not understand, or fake that they do not understand my question.

If anyone has a a new hack not involving removing the flash, or another reasonably cheap and sourceable Ethernet coordinator, I would be very happy to know about it.

1 Like

Hi Arduous, thanks for your response!

I found a model which is already flashed but I haven’t tried yet. Does it seems legit? I think that, if it works, it can be a good one to use.

Great! Thank you, I will order it. No later than this morning, I got confirmed that the development team do not want to give me the root password.

You’re more than welcome!

Would you mind keeping me updated about it? I would like to know if it works without shady workarounds with HASS and the standard integrations.

I hope it works :pray:

Do these only work with Zigbee to MQTT or will they also function with ZHA ?

Hi Rofo,

I have no idea, that’s what I was also wondering in order to implement it myself and look for the compatible zigbee devices. I think @ardous can enlight us when he recive the hub.


I received the device. I stupidly “upgraded” the firmware with a wrong one, and do not have a copy of the original one. I am waiting for the seller to send it. In the while, I successfully flashed a firmware with the instructions found at GitHub - vahempio/Tasmota-for-eWeLink: Tasmota firmware for eWeLink gateway (ethernet + ZigBee) . Caveat is that I am not able to activate the Ethernet interface, but ZHA configured with the information found at How to use the Sonoff Zigbee Bridge with Home Assistant - Tasmota | digiblurDIY allowed me to have a working ZigBee bridge through Wi-Fi.

So while I am not totally able to confirm yet, I am pretty confident that it this device may be what we are looking for.


I have to say I don’t understand what you did here… You flashed the firmware with a wrong version, but yet you got it working? Isn’t this already flashed with tasmota? Why did you flashed it again? Or are you talking about the other device you mentioned? The one you couldn’t flash because root access.

And thanks again for doing this research and posting it here!

I am talking about the ESP32 based device that I ordered recently. The Tasmota firmware that comes with it isn’t the latest one (1 or 2 versions behind). I wanted to flash it with a newer Tasmota firmware, but I flashed a firmware that does not support properly this board. Currently, the best I could do to recover from my mistake is to the flash the above mentioned firmware. Wi-Fi to ZigBee (ZHA) bridge does work, but as I cannot get the Ethernet interface to work, I cannot get the Ethernet to ZigBee setup that is our ultimate quest. I received the original firmware from the seller. Hopefully I will find some time tomorrow to flash it and report.

Oh, I understand, now we are on the same page.

Good that the seller is helping as well. As soon as I’m back from holidays I’ll order the hub as well (just the one I linked a couple of weeks ago, right?) and update the firmware too. How did you did it? With tasmotizer and an usb adaptor (the one with the 4 pins, I can’t remember the name).

In that case I’ll buy it as well :slight_smile:

Thanks for all the help!