Jandy iAqualink Pool Integration

I’ve had the same error a few times for about a week now. Reloading iAqualink doesn’t fix it, rebooting HA does.

If anyone leverages Grafana, I created a nice dashboard with integrations into EmporiaVue for Energy and iAqualink.


There is a temporary fix available: Latest fix to IAquakink (2023.2.4) has not resolved issue · Issue #88033 · home-assistant/core · GitHub

I am unable to get the integration to work at all. I get the following error:


Would it be possible to expose the standby status of the solar heater rather than just its on/off status?


I’m also trying to get a Zodiac EXO with a Z400 iQ Heat Pump integrated. I was able to get the Hydroxinator to show up using core/homeassistant/components/iaqualink at iaqualink-eXO · martinfrench92/core · GitHub. But it’s not showing the Heat Pump.

Did you get it working? can you please share your implementation details?


I have a Zodiac eXO and a Z400 iQ Heat Pump. Unfortunately I can’t help with Home Assistant, but instead I use Node-Red on a Raspberry Pi. It should happily co-exist with a HA installation.

Here’s a link to a flow you can import into Node-Red -


There’s been a recent change by Zodiac to the format of the unofficial API. Here’s a further post that describes a small change required to the authentication routine referred above -



Thanks. I managed to import your flow into Node-Red (which I already have running as a Homeassistant addon). I’ll tweak it talk to Homeassistant via MQTT.

Hopefully the Homeassistant component gets updated with all the changes that’s available in the Github forks.

1 Like

hello everyone.
I bought a robot for my pool and it have iaqualink integration.
I try to integrate in home assistant and receive this error:

Logger: iaqualink
Source: components/iaqualink/__init__.py:87
First occurred: 15:55:57 (1 occurrences)
Last logged: 15:55:57

cyclonext is not a supported system type.

Now is someone development this integration?, can we help with information or some testing to integrate this kind of robots?

Hi, I have a Zodiac Alpha 6800IQ robot included in iaqualink app but there is no way to get it in HA with the integration. ideas?

mine is Zodiac XA 3095 iQ
I think the IQ maybe have the same protocol, its connects at iaqualink.
Maybe we can make test. i try the curl comand to obtain my id but the zip file returned me a “autorization required”.

if someone can tell me if i can make some progress with curl comands os something similar, this will be enought for me. I only need the “power on” option, and i will be very happy :slight_smile:

Thanks to you @Tico, I success to retrieve values from my zodiac heat pump Z400iQ and chlorinator eXO too and send them to HA :slight_smile:

1 Like

Does anyone currently have the Jandy iAqualink integration working in HA?

Yes. Working here.

So if I’m getting failed to setup error, using the correct credentials, any idea what I can do to get this working?

Are you able to login to your system via their online portal? (Zodiac iAquaLink)

Once logged in - does your system show up?

If both to yes above - are you using the same credentials in HA as their site?

Realize some of these are ‘basic’ questions, but sometimes just starting over and making sure it all works is best… Hope this helps!

Yes sir. I can log in. I have a variable speed pump only, so I’m wondering if that is the issue. How do control via API and Node red?

Did the light fix ever get pushed to the integration? I just upgraded my pool to iAqualink last weekend.

Everything else is working (including a water feature light that is just a relay without color changing).

However, my main pool and Spa lights are Jandy LED Lights (and work from the website / iAqualink app) but do not work from HA card switch… they switch to On mode for a few seconds (pool light never turns on) and then fails back to off.

FYI - I also tried running a light.turn_on service for the pool light entity (and device) with data:effect: ALPINE WHITE (with and without _ and in varying combinations of alphabetization. No luck that way either.

My light is working. I think it was 2022.4.2 if I remember right that fixed it or maybe it was 3.2 in March?

Thanks for confirming Markus. Really strange… I had multiple entities for my spa and pool lights… _1, _2 etc… I reset my integration and now it’s working. Now I just need to set up the color control drop down.