Kasa HS103P2 not found

I am trying out my first HA install. I used the Balena etcher to make an image for a RPi 3+. That worked well and I was able to log into my HA and make my account.

I made a python 3.7 virtual environment and installed python-kasa version 0.4.1.

I am trying to turn on a lightbulb by using a Tp-Link Kasa HS103P2 smartplug. I plugged the Kasa in and the light was orange, then turned to steady blue. I held the power button for five seconds until it blinked orange, then tried to discover it via kasa discover. The output is:

No host name given, trying discovery…
Discovering devices on for 3 seconds

I tried a manual integration under the TP-link section of HA but it said no devices found.

I restarted HA and tried again. Same error.

I do not know what else to try, so I’d appreciate any pointers. Thanks!

Have you checked the firmware isn’t the latest? The local API was removed/blocked and if the devices are up-to-date they will not work.

The beta firmware they were also offering is no longer available.

Alerts – Home Assistant (home-assistant.io)

Weirdly this was asked not long before - TP-Link Kasa not linking - Third party integrations - Home Assistant Community (home-assistant.io)

Good question. I bought these in november of 2018 and just took them out of the box. I assume it is the earlier firmware but since I can’t see the plug on the network I don’t know how to check.

Thanks for that link, I did not see that question during my searches.

Inside the Kasa App if you select the device, then click the cog in the top right and then tap “Device Info” you should be able to find the Firmware version from there.

A few of mine are still on 1.0.4 which work but as I understand it if they are 1.1 or above they won’t.

Thanks again. Is the Kasa app proprietary software from TP-Link? I am trying to keep this under local control and not give my personal information to a company.

You need their Kasa (TP-Links proprietary software) app to configure these plugs. If that is your aim these are the wrong plugs for you, you need to find some that will support Tasmota and/or ESPHome.

No doubt others will be able to chime in with better, supporting or alternative methods.

That gives me something solid to look into, thanks!

I have the hs103 with firmware 1.0.3 they don’t need the kasa app. Just use this code and steps from github to initiate them on your home wifi network.

also worked for hs220 dimmers.

Excellent! I will definitely try that.