Known_devices.yaml cant find local pictures


I have added a folder called www within the same folder as my config file.
I have created a folder called local within the www folder and place my image in the local folder
This is in my know devices file, but

  hide_if_away: True
  name: LM
  picture: /local/lm.jpg
  track: true

No picture is shown. If I put a web address of a picture then the picture is shown

I created the folders using Samba share, so not sure about permissions?

If I ssh into my PI the sudo command does not work in so I dont know haw to change permissions.

Any clues

Regards Dave

Try to force refresh Browser. Or delete Browser Cache.
I had the same Problem. A few days ago, I changed a file. In some browsers and the, Home Assistant still shows the old picture.

www/ is local/

place your picture in the www/ root inside the homeassistant dir and your syntax is correct. If you’re using www/local then you need to reference the file via


1 Like

you are right. I have not read correctly :upside_down_face:

Thanks, now working, looking at other posts there seems to be confusion over this.

Did not know that WWW was Local

Many thanks for your help

Regards, Dave

So I have installed and used samba to create a www dir in my config directory (same folder my configuration.yaml is located).

I use /local/image.jpg to try and show an image. I can never get an image to display though. Always just a blank icon. I have no idea what I’m doing wrong. I have tried doing this multiple times and cannot get an image to display.

Here is a screen dump of main folder

main folder

here is the contents of my www folder
www folder

known_devices.yaml file

  hide_if_away: true
  name: Lyn Mobile
  picture: /local/lm-beech.jpg

This is what I have and works a treat

Re Dave

not working for me and i got www folder in config and a test.jpg

does not help to delete cache or refresh

name: Iphone 5S
picture: /local/test.jpg
track: true
vendor: Apple, Inc.

you have to restart hassio every time you add a picture, then it works

I am running Hassio, I seem to recall it being different in my old set up.

What are you running?

Yeah, my folder looks exactly like that. Again created with Samba not SSH (because I have no idea how to create the directory properly with Add a photo to www then restart HA and still just blank

Hi, like I created my with Samba, have you tried another jpeg?

Do you want to post the relevant parts of you config, I am happy to have a look.

Regards, Dave

Oddly I got two jpegs to work. Both of those were downloaded from websites. The ones I can get to work are jpegs from photos I’ve taken.

Are there any sort of size limits to them? I’m considering that as the issue.

Hi Ciwyn

Not sure if size is an issue (No jokes) but mine are 25K (184px x 177px 96 dpi).

Re Dave

I am also having issues with this. I am running hassio on a RPi3. I used samba from a windows10 machine to create the www folder in the config folder which contaings my .yaml files. I then put a picture in the www folder and linked to it in the know_devices.yaml file. I used /local/picname.jpg as the path. When I restart hassio, it just hangs and never comes up. If I remove the path to the picture in the known_devices.yaml file, then hassio comes up normally.

Did you try without icon: and picture: at the same time (even while only 1 of those is populated)?

This is what worked for me:


I did what RonJ103 did and it worked, so long as the file size was small enough. I guess when you’re running a DDNS service the address needs to reflect this. I couldn’t get a 167kb file to work, but a 68kb did. Also had to clear the browser cache.

When I try that This site can’t be reached refused to connect.

Do you have duckdns setup?