Known issue with Insteon PLM and Leak Sensors?

I’ve encountered an issue when using the Insteon integration in Home Assistant with a USB PLM (model 2413U) and leak sensors (model 2852-222). The problem is that the “wet” state is detected but won’t return to the “dry” state until Home Assistant is restarted. I have four leak sensors and they all behave the same. (I am aware that you need to press the button on the leak sensor to force it to clear the wet mode and return to the dry mode.)

Until recently I was using an Insteon hub (model 2245-222) and the leak sensors worked properly. Whenever you press the button on a leak sensor, its state would change between wet/dry. Now with the PLM, once it enters the wet state, the state won’t change.

In case you’re wondering, I switched to the PLM because the hub would periodically stop responding to requests from HA. (This is a known issue. Insteon Losing Connection Regularly = "Can not connect to host")

As a test, I…

  • unlinked a leak sensor, then factory reset it
  • setup a clean Home Assistant install. (I run a VM, so it’s easy to do.)
  • installed the Insteon integration using the hub
  • added the leak sensor device
    The leak sensor worked properly. Whenever I pressed the button on the leak sensor, the device in Home Assistant showed the state change (Wet/Dry).

I then repeated this, but used the PLM. The problem returned. The device would enter the Wet state, but wouldn’t exit that state until Home Assistant was restarted.

I compared the following config files used for these two “clean” Home Assistant installs, but don’t see any difference that would account for this problem.


Are there known issues/limitations with the HA Insteon integration when using a PLM? Or perhaps the PLM doesn’t fully support leak sensors? I’ve done a lot of digging, but have only found one other reference to this problem - Insteon leak sensor doesn't update

Better yet, does any one know how I can get the leak sensor state reporting properly?