KNX climate glitch with setpoint_shift_min/max

Dear HA community,

I’m just starting with HA and am currently adding my KNX setup into HA.

While working with the climate devices I noticed a disparity between the integration and the documentation. My setpoint_shift_min is -2.5K, and according to the documentation this is a float, so should be alright.


However, when I run a check on my YAML files, it complains that this should be an int type and it won’t work:

Invalid config for ‘knx’ at knx.yaml, line 334: expected int for dictionary value ‘knx-climate->0->setpoint_shift_min’, got -2.5

Why shouldn’t that be a float and why is their a disparity between the KNX integration and the doc.



What is your shift_mode?

Oh, that is just a bug. I guess no one ever tried to use a float for this.
I’d have to check if it can lead to unwanted effects though (especially with DPT 6 shifting). Then either the validator or the documentation can be corrected.

@jeffcrum @farmio Thanks for your prompt responses.

It is indeed related to setpoint_shift_mode.

When omitted or in auto mode it will not accept floats, but when set explicitely to DPT9002 it does. It makes kind of sense, but since auto mode can extend to DPT9002 it should accept floats, and just convert to int in case of DPT6010 (IMHO)

Strange. The schema doesn’t differentiate there. It will always only accept integers.

You are right. :person_facepalming: I set it to 3 for testing and totally forgot about it. It still won’t accept it with 2.5.

But the reasoning stands, it should accept floats in the first place.