KNX configuration issu


Trying to connect HA to my Logicmachine.
The IP of LM is

My ETS connect fine to LM, but HA doesnt. They are on the same network…


I’ve having same problem with conneting to KNX
Node Red i Home Assistant with KNX integration is working fine, but HA would not connect to KNX.
If i’ve delete KNX integration and try to connect then is find all my KNX connections but i’it will not connect

Works fine for me with my existing configuration (although I did leave the last field with the local IP empty, but not sure if that plays any role).

What HA version are you on?

local_ip is the IP of the HA instance, not the knx Gateway. Die to a bug in the frontend logic it can’t be removed when once assigned. You can, as a workaround, delete the integration and add it again from UI - it should default to None.

1 Like

HA OS 7.0

@farmio This fixet my connection now it is working :slight_smile:

Local ip = ip adress of Home assistant this was not clear for me :laughing:



Still doesnt work for me…
Tried not commenting the local ip, but got an error. The IP ( is the IP of HA

Why do you use nat-mode?

in desperation. Tried without NAT first.

Disable it again and look for Log messages

maybe you don’t have the logger integration activated?

Tried activating logging, but it created an enormous amount of data.

Should i add som parameters?

Yes. See the link I posted above. I’d start with xknx.knx and xknx.log set to debug.
And yes, the point is to generate lots of data.


Is this correct?

Where do i find the knx log file afterwards?

Using xknx works, but will yield more than necessary. I guess xknx.log would be enough. Just try it.
It will be added to your HomeAssistant log Open your Home Assistant instance and show your Home Assistant logs.

Like this?