KNX interface does not reconnect after a power failure: solutions?

I had a power failure today and hadn’t noticed that the IP interface did not reconnect until now, hours later.
Is this typical behavior and can this only be solved by power cycling the device?

Usually this should take max. a couple of minutes. Have a look in the logs to see why it took longer.
Did some IP addresses change (HAs or the interfaces) after the power cycle (DHCP)?

1 Like

Hi Matthias, this is all there is in the logs concerning KNX

Logger: homeassistant.config_entries
First occurred: July 1, 2023 at 6:24:27 PM (1 occurrences)
Last logged: July 1, 2023 at 6:24:27 PM

Config entry '' for knx integration not ready yet: No usable KNX/IP device found.; Retrying in background

Most of the devices on the network have fixed IP’s, surely the KNX IP interface and HA.
I don’t know if this is of any importance: the KNX are powered on automatically/immediately after I restored the power.
My server with HA needs to be powercycled manually, meaning HA came up after the KNX devices: does that matter?

Hm :thinking: probably requires debug log level to see the reason.
Do you use “Automatic” connection?
Have you uploaded a Keyfile?
What interface do you use?

How did you solve it? Restarting HA again? Or the Knx interface?

Not at all. That should be the same as every other restart of HA.

TBH: I have no idea about this :blush:

This is the IP interface I use.

Powercycling the KNX system solves this problem.
Of course powercycling was easier then starting a topic here but I have waited to do this because I am mostly curious for the reason and if there is a solution.

Well, if you can reproduce the issue, I can have a look at debug logs or a Wireshark capture.

1 Like

Where can I find information about this because I have looked in the KNX integration documentation without success or is this something typical KNX/ETS?

In the meantime, I have powercycled the KNX system but still the integration was not loaded.
After reloading it manually it seemed to be stuck in Please wait while the options for KNX are being initialized
HA was under heavy load, almost unresponsive so I restarted HA.
Of course now everything is OK.

“automatic” or “tunneling” is a setting of the Knx integration.
The keyfile is only needed for Knx Secure, so you can probably ignore that.

Tbh this doesn’t sound like a problem the Knx integration would cause.
Are you running the latest version? Any custom components? Any other log errors? Dying SD card?

1 Like

Ah, now that you mention tunneling: it is on automatic

My HA is up-to-date as you can see from my signature: 2023.6.3, Python 3.11.4 (if that matters)
It’s a virtual machine on my Proxmox server, so no SD card of course.

I’m not sure what you mean by custom components, but I use:

  • browser_mod
  • webRTC
  • some custom cards

Automatic should be fine.
Again, without a full debug enabled log, I can’t say any more.

Ha, I didn’t even know there were signatures in this forum :rofl:

1 Like