KNX Status not updating after reboot 0.118.0

Tags: #<Tag:0x00007fc4148723e8>

Has anyone else seen that KNX status (e.g. lights and HVAC controller) messages are not updating following server reboot? Was OK on 0.117.4 and before. (viewed from Lovelace).

yes same here since updated to 0.118.0, KNX Switch status are not showing up.
Working with my light

1 Like

same here… Will check the .1 and .2 release. Just checked with 0.118.2 but the same issue. NO KNX switch satte sync after restart

1 Like

It’s a known problem for switch, cover position and climate mode.
Lights should properly initialize!?

Matthias, I don’t quite understand, is this a new 0.118 issue? I’ve not see this issue for two years now, 0.117 was fine. It appears that after restart the status is not queried. I do have a big KNX system in my house.

PS: I do wish we could sort out the thermostats (KNX operating modes) in Lovelace. It’s used to be so good.

Same hear 0.118.2 is the same.

I stopped searching and have reverted to 0.117.6 where everything is just fine.
Am going to keep watching the updates and the changes to the xknx.

Hi,

I confirm that I have the same issue with 118 (all subversion). I also have some problem with brightness value update (I start some light, but the brightness value stay at 0).

Maybe the problem is due to the fact that I split my command and status group (which is needed is some circumstance).

Till 117, everything was working fine, but with 118, it’s not working.

ex of a knx switch

- name: 'outlet living room'
   address: '2/0/1'
   state_address: '4/0/4'

anybody can help ?

Fred.

Fred, I have split command and status groups, but in the same yaml sub-file and I’ve not seen this, but I do have the status update intervals set to about 5 minutes and on status change on the sensors. (Gira TS3/Plus in most cases). Example below:

- name: 'Lounge Downlights'
  address: '2/3/4'
  brightness_address: '2/5/4'
  state_address: '0/4/4'
  brightness_state_address: '0/2/4'

My knx is set to only send status on change. If I do a ‘manual’ read status with ETS, the value is well updated in HAss. So, the main problem is at boot.
Can also be a problem with the management of the KNX queue…

Yes, agree the problem is on boot since 0.118.x no status information is queried from any sensor. The key line that not working is the “state_updater: true” which according to the documentation:

state_updater boolean (optional, default: true)

The integration will collect the current state of each configured device from the KNX bus to display it correctly within Home Assistant. Set this option to False to prevent this behavior.

It worked prior to .118.x

configuration.yaml

knx:
  tunneling:
    host: '192.168.0.254'
    port: 3671
    local_ip: '192.168.0.24'
  state_updater: true

  switch: !include knx_switch.yaml
  light: !include knx_light.yaml
  sensor: !include knx_sensor.yaml
  scene: !include knx_scene.yaml
  climate: !include knx_climate.yaml
  binary_sensor: !include knx_binary_sensor.yaml

I open an issue: https://github.com/home-assistant/core/issues/43640

Another pull request that might resolve this: https://github.com/home-assistant/core/pull/43645
Let’s hope we can get this in 0.118.4 or 0.118.5 or something :slight_smile:

Yes, I hope, I cannot revert to 117 due to other bugs…

I did revert, but as I had not taken a backup of my data before updating, the db is now in a mixed state, breaking some other integrations. :expressionless:

seems 2020.12 has fixed it for me

1 Like