Komfovent C6 & C6M Controller Package File

Continuing the discussion from Modbus Sensor TCP for Komfovent:

I have created a Package file from all the good ideas in this linked topic.

It has a great deal in it, but it is not complete by any means so commits are welcome :slight_smile:


I am curious, why do not create proper integration? Is there any limitation or just spare time constraints?

BTW, thanks for sharing configurations!

I don’t really have the right skills to do an integration. This works well enough but I’m happy to support anyone who does want to do a full integration.

Hi, for beginner little difficult, but i have done, thanks!!
I dont understand kitchen button, how it work? Is there anything else that needs to be done? Not working at the moment.

btw… don’t notice the temperature on the supply, the sensor is faulty

I have user your package without much of the review. After updating komfovent.yaml with my local IP it does work for the functions I tried. Happy with this :slight_smile:
however in general I try to keep HAOS error free as much as possible.
After implementing this package I get modbus error which occurs quite often, maybe you could help me to debug it?

this is the error from home assistant core log:

Logger: homeassistant.components.modbus.base_platform
Source: components/modbus/base_platform.py:387
Integration: Modbus (documentation, issues)
First occurred: 11:27:00 AM (6 occurrences)
Last logged: 11:27:15 AM

Unexpected response from modbus device slave 0 register 4, got 0x 3

spent some more time and I was able to troubleshoot and narrow down that the error is about reading operation mode. I get such error each 15seconds.
basically it doesnt recognize modbus response for the mode setting it is in.

now trying to figure out what response is expected and which code line is creating a request to retrieve the state. any help would be appreciated

I’ve just not had time to get to this yet. I need to update a load of the code because of changes to HA core templates :frowning:

The issue might be the C6 firmware you are running. Komfovent are not very forthcoming with new firmware or the MODBUS document. I have both, just not had time to do anything with it.

What I know is they changed this and added a new mode.

I am running this firmware


I got confused with the results of my testing yesterday. I see that actually HA is able to retrieve operation mode information it is just it gets not all responses formatted in the same way. see the mode graph:

so I though what if I update the unit as maybe some performance issues would be fixed. Now I am on this version:

maybe not the wises move with the update though as Komfovent indeed is not doing well with the documentation either changelogs

I found also the thread about unit of measurement and did commented out those lines.
now most of the errors are gone.
I still get the error when auto mode is not on. cant really understand why all other times responses are good but when auto is off it doesn’t understand the operation mode value.

        # unit_of_measurement: "State"

For now giving up. function wise all sensors, switches are working fine however it just keeps posting errors even all entities have correctly updated values. no clue why it errors out…

Maybe someday I will be wiser than now (just 2 weeks as a Home Assistant user).
It is worth evaluating and rewriting the code to fit with standard integration for HVAC. then I believe it would be more future proof.
Climate - Home Assistant (home-assistant.io)

here is my few adjusted cards to share:
Card for the home summary dashboard with long press action to turn on boost and tap action to navigate to the next page with the info as bellow: