Konnected not connecting to wifi

Hi, I am trying to setup my NodeMCU with https://github.com/konnected-io/konnected-security.
I followed all the steps and loaded all the files. I cant get step 4. anybody have done this set up

Do you see a WiFi access point called konnected-security_XXXXXX to connect to?

If you can then connect and goto http://192.168.4.1 in your browser where you can set up your own WiFi details

No, that’s the part I am missing I don’t see konnected-security_XXXXXX WIFI access. I double checked that all the files on SRC are present on the Node MCU using ESplorer.
the latest firmware I flashed my mCU is nodemcu_float_0.9.6-dev_20150704. I guess that is the latest.
anything else I can check.

Did you flash version 2.2.0 and the included node MCU firmware using the flash tool?

See
https://help.konnected.io/support/solutions/articles/32000023470-flashing-new-konnected-firmware-software

You need the flash tool and both the firmware and filesystem bin files.

So I tried to flash the Node MCU first with latest konnected-filesystem-0xa0000-32mb and konnected-firmware-2-2-0. but I couldn’t load the SRC file using ESPlored, the LED doen’t stop flasing.
next I flashed NODE MCU with nodemcu_float_0.9.6-dev_20150704 and I was able to send the SRC files.after your reply I went ahead and re-flashed with konnected-filesystem-0xa0000-32mb and konnected-firmware-2-2-0. but with the same result, I used 9600 and 115200 with not result.

I think its something wrong with konnected-filesystem-0xa0000-32mb and konnected-firmware-2-2-0.

The firmware and file system work fine, unless you have corrupted downloads. Sounds like a flashing problem. I would try using esptool.py directly to flash after erasing the flash as I had one board that was just plain stubborn and needed it this way.

esptool.py --port=YOUR_ESP_PORT erase_flash
esptool.py --port=YOUR_ESP_PORT write_flash --flash_mode dio 0x00000 konnected-firmware-2-2-0.bin
esptool.py --port=YOUR_ESP_PORT write_flash --flash_mode dio 0xa0000 konnected-filesystem-0xa0000-32mb.bin

Good luck!

Just looked back at what I did, I used the 2 bin files you mentioned and flashed with konnected flash tool 3.0 in the folder called pyflasher. I then just rebooted and could see the WiFi signal. I used the lolin style nodemcu as shown in the konnected images. Don’t know what else to suggest if you have done the same. Could your nodemcu be faulty?

@sreknob I followed your steps loaded both files using pytho and also tried with esFlash. The confusion now with @Crhass is, once I load the 2 firmware files according to you are saying when I reboot, I should see the WiFi. Is this what you mean? Did you load the SRC files as well or you were able to see the WiFi before loading the SRC file?

In my case when I load the 2 Konnected firmware files, i don’t see the WiFi and i am not able to see what’s inside My Node MCU using ESplorer tool. Plus it’s doesn’t let me load the SRC file first!

Once I load the old firmwares. Then I could load the SRC files. But that I guess doesn’t help.

I will try again tonight using python to load the files.
Just one final question @Crhass when you plug the power supply to Node MCU do you see the blue LEd flashing or On. Thanks.

Yes, when you power on it will broadcast a WiFi access point.

I can’t remember the status of the led when I first flashed the device. Now I have entered my WiFi and use Hassio to configure, it flashes a few times and then goes off. It flashes when I open and close sensor inputs.

Have you tried using the konnected flash tool 3.0?

@Crhass sorry to bother you bro, but you didn’t answer my important question. Did you upload SCR file step 4 in the set up


Or just flashed the 2 files with Konnected flash tool V3? because I just flashed it again with Konnected V3 and I don’t see the WIFI.
My thoughts are. 1) since you mentioned LoLin Node MCU could it be because I am using Amica Node MCU and its V2 should I use V3 Node MCU.
2) when Konnected was done flashing the message was : Wrote 621600 bytes to 401377 (compressed)
flashing filesystem at address 0x0000 compressed 3514368 to 25843…wrote 3514368 bytes to 25843( compressed) .
could it be memory issues with v2 Node MCU it seems like its strying to write more bytes then the memory has? Thanks again

Hi, I have only flashed 1 device so far and it was a lolin V3. I only used the 2 bin files and the konnected flash tool. I did not use an SCR file. Hope that helps. I am also powering the nodemcu on a nodemcu base, not sure if that makes any difference.

Great Thanks for the quick reply. I will buy a V3 then and I try. I will be back here I guess in few weeks.

@ssinseeme
SSID will not broadcast until the file system and lua files have been added.
Might be a memory addressing issue with a V2, not sure.
To best address this, I would use the old Konnected instructions where you flash the firmware only first.
THEN, reboot, it will format the filesystem, THEN use ESPlorer to upload all the files from the “src” directory.
After another reboot, the lua files will get compiled and the SSID should then broadcast. You should be able to watch this all happen in ESPlorer if everything is going well.

@sreknob thanks for thé idea. Where could I find the old Konnected flash files? May you would be right if this files would be smaller and fit on V2. If you know where to find the old file please share appreciate it. Thank you.

In GitHub, they’re all tagged as releases:

My suggestion would be to try again to flash the firmware without the filesystem after erasing the flash, then load the lua files and reboot, like:

esptool.py --port=YOUR_ESP_PORT erase_flash
RESET
esptool.py --port=YOUR_ESP_PORT write_flash --flash_mode dio 0x00000 konnected-firmware-2-2-0.bin
RESET
Open up ESPlorer and try and upload all the files from /src in whatever release you’re using.
RESET

Hopefully you get some wifi love.

@sreknob I appreciate your reply but somehow brother, when I flash with Konnected firmware without filesystem or with the filesytem the NodeMCU gets into a weir mode, the LED flash rapidily, then when I try to ready the firmware with ESplored its wouldn’t read anything, it just print weir signs… I used multiple baudrate just to test. then I tried to load the files but it wouldn’t. This doen’t happen when I load the nodemcu_float_0.9.6-dev_20150704 firmware even though it 450kb file. Konnected firmware is 650 KB I still believe its memory with V2. unless someone for a sure can come over here and say they have done it with V2. I am waiting for V3 and see

sorry for the late reply @ssinseeme
I was looking at the differences between the ‘V2’ and ‘V3’ boards and I’m pretty sure they have the same memory, just different USB controllers (CP2102 vs CH340) so that may not be your problem… could just be a bad board…
There is also a new beta release you could try as well:

Direct links to 2.2.1 images here:
2.2.1 firmware
2.2.1 filesystem

Thanks for the reply. I was able to confirm that its working with V3 not V2. tried also 2.2.1
well, the V2 Amica board NodeMCU works fine with Tasmota so its not the board, it just doesn’t like Konnected Firmware.

Now the question: I was able to load both files, and set up the WIFI to the board.
went to YALM and set up the code but I when rebooted by R Pi nothing hapen. the YALM dont show any error.
this is the codes I use:

konnected:
  access_token: MessiGoal
  devices:
    - id: 8bcd53
      binary_sensors:
        - zone: 1
          type: door
          name: 'Front Door'
        - zone: 3
          type: motion
          name: 'Test Motion'
      switches:
        - zone: out
          name: siren
    - id: 438a38
      binary_sensors:
        - pin: 1
          type: motion
          name: 'Office Motion'
        - pin: 2
          type: door
          name: 'Office Door'
      switches:
        - pin: 5
          name: 'Garage Door'
          activation: low