Last Notification Has Stopped Updating

Hi All,

Since around the 28th of December (when I finally got around to updating to December Releases…) I have found the last notification sensor no longer updates when notifications are sent from apps in the allowed list.

I’ve updated Home Assistant to the latest Release, and re-installed the app onto my phone (Pixel 6) but it’s still not updating. I can see the notification count sensor is working, so it seems to be an issue with last notification sensor

Has anyone else experience this and is there anything I can do to resolve?

1 Like

Install the latest beta then make sure to use an allow list in sensor settings. If you get stuck read the docs in this sensor.

How do install the beta? And what’s changed there that might fix this if you don’t mind me asking?

I’ve used this sensor perfectly for the past few months and the state is now not updating. Allow lists are all added as required it’s pretty bizarre?

we had a breaking change where the allow list is now enforced, there was a logic issue where data was only being sent if the disable allow list setting was checked off. Now in the latest beta that issue is fixed and its functioning as designed with the breaking change. The sensor will no longer send data if its left with default settings in order to prevent excessive battery drain and complaints.

Ok 100% happy that it’s not just a “me” issue! Cheers for the great explanation!

Sounds like it’s fixed in the beta of the app. Is there any sort of release timelines for that to go into the main version or is it worth me diving into the beta?

we normally cut a release after HA core does, depends on what changes we have and if we feel we need a longer beta test

Speaking of this topic.

Is there any way to get the allowed list smaller?
Browsing through it is quite confusing and has lots of “bloat”.
In my phone I see fonts and colors, and I guess they are “apps” in android but that is not really useful.
Also for instance Facebook has multiple lines.

Could they be “grouped”?
In Tasker I get this when selecting an app

It’s a bit less confusing and easier to browse.

If this is too much work, then perhaps remove the prefix at least so that we don’t need to see “” and all the variants of it.

I have had the beta now for over a year and have never had any issues because it’s the beta version.
I find the beta version very stable.
They are doing a great job!

The list shows all packages including system packages that are installed on the device. We had to include system because that includes default apps like messages. If there is a safe to ignore list then we could look into using that.

It’s too difficult to guess what is a system app that will never post a notification and what is not especially with all different manufacturers and variants. It was easier to let the user decide which packages they wanted to use.

Thank you we also aim to fix beta reported issues faster since we get the fixes tested faster. Especially if an issue is reported soon after a PR has been merged

1 Like

Hi, first of all - amazing work on the app!

To add a couple of cents to the topic of notification packages filtering:

First of all, I’d suggest adding a simple filter/search bar at the top of the popup, this will solve use cases when you know what package you are searching for - this is probably the most common use case actually.

To improve the general UX for the list I’m thinking we have 2 options:

The naive approach:

  1. Sort package names alphanumerically
  2. Select the longest prefixes and group items using them (group only items with 2 or more slugs)
  3. Order groups by the number of items in them (starting with 1)
  4. Display all groups with 1 item at the top of the UI as this list will be small and will probably contain the most needed apps - this should be a list similar to what we have right now
  5. Display all other groups as separate lists (put the prefix as a title of the list) - this will reduce the visual clutter as only package suffixes will be shown in each list and prefix will be a title. (you can reverse the slug order in the title so that it matches the domain name better)

The better approach is probably to use application names/icons

It should definitely be possible to get a list of applications with icons due to the fact that all smartwatch companion apps do that already.

Something like this should work:

PackageManager pm = getContext().getPackageManager()

Drawable icon = pm.getApplicationIcon(pkg);
ApplicationInfo ai = pm.getApplicationInfo(pkg, 0)
String label = pm.getApplicationLabel(ai)

I’d still try to group and order the results using the naive approach by package name as this is something I always wanted to be able to do in the aforementioned smartwatch apps.


I had a similar problem.

In the HASS Android application, when the “Last Notification” sensor is activated, everything works fine. But a few hours later, a problem occurs. When a new notification is received (from apps in the “Allow list”), the sensor data in the app is not updated. It remains in the data it received the last time it worked.

The same problem occurs on both mobile devices.