"LED Light bulb" with Magic Home app" integration?

I suspect that with the error you are getting, you are setting the devices up in the automations.yaml

The problem with these bulbs is that they use a Broadcom chip in the hardware and there seems to be no method to flash it with something like Tasmota. I had success with the earlier firmware but as soon as it got updated, they stopped responding via HA and were only controllable via Google or Amazon assistants.

It would help if you could describe what you have in place and show us the code you are using in which files. Remember to use the code tags and make sure you have no usernames or passwords accessible.

Just found this thread while trying to setup this lamps in HA.
Having the same problems with the new version of the firmware and I can’t even find an open port on the lamps to start tinkering with them.
Does anyones has any idea on to work with these lamps?

There is a blog post out there somewhere - I had a quick look but couldn’t locate it in the time I had - that details a tear-down of these bulbs. The outcome is that they do not use an ESP chip but something else entirely. The post explained that the user had a custom PCB manufactured on which he soldered an ESP12 and then flashed that. He didn’t detail the schematics for the custom PCB and it had already gone past what I wanted to do with that bulb.

My solution was just to order alternatives. I bought the FCmila RGBW bulbs but they also needed a chip replacement with an ESP12F but at least they were a direct swap with the Broadcom chip that was on them.

Unfortunately, unless you want to learn to reverse engineer the firmware on the bulb, these are a dead duck for our purposes.

Thanks for the feedback.
I did an nmap scan on it and it seems to believe that it has an ESP chip:
Running: Espressif embedded, lwIP, NodeMCU embedded
OS CPE: cpe:/a:lwip_project:lwip cpe:/o:nodemcu:nodemcu
OS details: Espressif esp8266 firmware (lwIP stack), NodeMCU firmware (lwIP stack)

Strange…

It is entirely possible that they have switched to different chips but here is a picture of the Broadcom chip that is in the bulbs I have:

Didn’t opened my lamp but went along and tried to use the python broadlink implementation and it seems to detect the lamp. Still no luck in controlling them but at least they are discovered:

There is a thread about this lamps with broadlink here:

Also after resetting the lamp and configure it using the official broadlink app I can now use the python-broadlink to control the lamp.
I did tried the broadlink integration in home assistant but that one doesn’t seem to be working (at least not yet)

Hey, I tried controlling my bulbs with the latest version of the ‘python-broadlink’ library but I get:

broadlink.exceptions.AuthorizationError: [Errno -7] Control key is expired

I tried running auth() but that gives me the following error:

broadlink.exceptions.AuthenticationError: [Errno -1] Authentication failed

broadlink.discover is able to discover all the bulbs and identifies them as model=‘LB1’. My bulbs are not RGB but only white/warm colors (device id: 0x60C7). Might that be the issue?

I had a similar problem and opened an issue in the python-broadlink:

It seems that in my case the device is locked. Unfortunatly I can’t find a way to unlock but using the broadlink app to configure the lamp instead of the magichome app sort of did the trick to unlock the lamp (although then the broadlink app complains that it can’t add the lamp…)

1 Like

yeah I tried to configure it with the broadlink app (instead of magichome) and it failed as well. Can you please specify the exact steps you did so I can try it myself? :slight_smile:

Update: I tried setting the lights using the Broadlink app and although it did fail, I am now able to control my lights using the python-broadlink library! Great find! Thanks for sharing!!

Yes, that’s the same with me. The application fails but for some reason now the python-broadlink can now interact with the bulbs. Now it’s only a question to understand what we need to do to make it work in Home Assistant.

I’m trying to get HA to install that library but it seems like I’m only able to import the broadlink integration HA has (https://community.home-assistant.io/t/custom-python-library-name-collision/)

Apparently, you have to register the lightbulb in the broadlink app instead of the MagicHome app. In this app, you can “unlock” it. I tried this with my smartbulbs, but the setup seems to fail while it’s successfully connected to the Wi-Fi, so I can’t seem to register it with the broadlink app… I contacted broadlink support now, hopefully they provide a clear explanation.

Once you do that you can control the bulbs using the python library (even though the broadlink setup fails)

aha ok, that’s good to know! I tried it with the failed bulbs and as you say, authentication succeeds with them. I misunderstood the previous conversations here, thank you for clarifying.

Did you get any luck with the custom python library in HA?

No, support is missing from the HA integration. I ended up having a python script constantly running on my HA docker host (rasp pi) listening to MQTT requests from HA and turns on/off the bulbs accordingly using the python library.

Damn, that’s a shame. Good idea on the MQTT-client, it’s a good last-resort.

for anyone interested, I created a pull request which adds LB1 support to the broadlink integration. Locally fully tested and working. Broadlink Integration add support for LB1 by L-I-Am · Pull Request #50953 · home-assistant/core · GitHub

Thanks a lot @L_I_Am, I saw that your PR is under review. Do you know how long does it usuly take to merge changes back? Is there any way to deploy your changes from dev as a custom component?

Actually Magic Home-Smart Home works too, but you have to use AP mode:

  • click on + to add lighting
  • choose AP mode
  • follow the instructions to reset the bulb in AP mode
  • cancel adding new bulb in the app
  • use broadlink-python to connect the bulb to your wifi
  • you can now add it to Magic Home-Smart home
1 Like