LG WebOS TV shows as "Playing" when the TV is really off

I’m having a little hiccup with my LG OLED55B7V TV (WebOS 3.5) and home assistant.

Everything else seems to work perfectly, I can even turn on the TV via WiFi as it seems that this model keeps the WiFi-adapter powered even when the TV is off.

The problem is that whether I turn off the TV from the remote or home assistant, it still shows it’s in “Playing” state on the home assistant overview screen.

Now, if I click the power button on home assistant while the TV is off and shows as “Playing” in home assistant, it goes to “Off” -state for a little while and pops up a “Turned off LG OLED.” -message, then the TV powers on and after that the overview window shows the correct info about what’s playing on the TV screen.

I’m not even sure if this is a configuration issue, since everything else seems to work. Could it be something with the WebOS -implemention of home assistant?

I’m tracking down the same issue; seems off is flakey. On works reliably.


I have the same issue (same TV and WEBOS version), but only when I use the remote to power off.
I’ve noticed that if I wait some minutes (5-10) the TV status is correclty updated.

Have anyone found a solution to this?

I have the same TV and see the same behaviour. Usually, it won’t enter ‘off’ state until after a while. On the other hand, I am quite sure this behaviour is due to the processing to minimize burn-in that happens after the TV is turned off. I see power consumption is kept high for some time after the TV is turned off, usually corresponding with how long you have been watching. Longer watching means longer turn off period. The state changes the same moment the power consuption goes to standby level. Seems like the usbports get power during this processing phase as well.

I faced the same problem and this method works for me, you can try it but I cannot guarantee because I don’t know why it works :stuck_out_tongue:

After pairing the TV, shut down your Hass server, use the remote to turn your TV off. Keep it off and start your Hass server, you will see the TV state shows off and you cannot turn it on by click TV virtual power button which on the Hass front end webpage. Finally use your remote turn on your TV, and then the turn on/off function by Hass will work again and update TV state correctly.

I don’t know my problem is really solved by this process but some other approach I made. But try this first and I still looking for someone can give more reasonable solution.

you can also see this topic, looks like Samsung faces same problem.

I have the same issue, and it messes up my automations somewhat. I read somewhere that the problem is with how the off state on the TV is determined - a packet/ping is periodically sent via network see if the TV is on/off. Problem is when the TV is on for a while and you turn it off via the remote, it doesn’t actually go off completely due to the “pixel refresh” thing that OLED tvs have to do. So HA thinks that the TV is on and sets the state accordingly.

Don’t really see a way around this.

Same thing here with a pair of LG OLED’s.

It seems only to do with the local power off; it doesn’t really go off. A remote network power off seems to do the right thing.

But if a local power off has been issued; and it has not “completed”; and a remote is sent it turns the TV back on… Annoying for bedtime automations as it often turns the TV back on…

I’m having the same problem with my LG B7.

Has anyone figured out a neat workaround?


It’s the screen clearing process on shutdown. The tv appears off but it clears the screen for a few minutes to avoid burn in. During this time the tv will report as playing but appears off, and if you send a turn off event it will turn it on

It’s flawed code on the tv and likely will never be fixed.

I’ve disabled all automations and use the remote, was tired of waking up in the morning to TVs being back on.

Had this been fixed? My LG doesn’t even up change to the paused state when I pause the TV, it only updates if I pause it in the frontend of HA. I need pause state for automations. Any work around for this?

Very new to this Home automation, very cool (and time consuming) hobby B)

My LG does change from playing to off when i turn off the tv by remote but, it indeed stays in playing state no mater what i do or wich source is active.

Sure hope someone is keen enough to find a workaround. Cause i sure would like the light dim/bright when play/paused.

Turn it off and wait a couple minutes; does the status turn to off eventually?

Any updates to this? HA doesn’t register pause/play triggered from the TV. But HA will successfully send the pause/play signal to the TV.

** Update, I spoke too soon. The new entity is for plex running on webos **

I have an interesting update here.

I just did a clean install of hass.io and I now have two LG entities, my original LG that I setup in configuration:

  • platform: webostv
    name: lgoled

And a new LG media player has show up as a cast looking device:


The new one reports the correct state when playing, pause etc. It doesn’t show the source, like Netflix, Stan etc. But it does report the show title and the correct media state.

Using both of these in tandem I can now get all of the information I need.

Just posted an update that may help.

I’m experiencing the same thing. I can turn my TV on and off from HA or from the remote and it shows in HA correctly.

However, switching between play/pause from the remote does not show in HA. It only ever shows play.

Interestingly, switching between play/pause from within HA does show the correct state, and it does control the TV.

This would be awesome to figure out for automations like light dimming, etc.

After fiddling with this for a bit, I figured out a solution. I own an LG C7P and this fixes my problem with the lights turning off then back on after you turn the TV off.

I noticed that when the TV is actually “on”, there is an attribute called “entity_picture”, and when the TV is actually “off”, there is no attribute called “entity_picture”, so I set up a flow in node-red to check for this attribute’s existence before turning the lights on. There is a small couple second delay while it waits for entity_picture to show up, but it’s better than the lights turning off then on.

In node-red:

  1. Start with event:state node,

  2. Link if state is true to a switch node & connect the switch node to turn on your lights.

  3. $$

Here’s a basic example of what your flow might look like:

1 Like

Smart thinking!
Any chance you can also find a solution to “tell” HASS media is played/paused state when remote is used?

I found a workaround for the pause/play dim/brighten issue.
Basically, i’ve added mute/unmute to the automation.

Can you explain this please? I have been looking for a solution as well :slight_smile: thx