Life360 very inaccurate

After successfully using Life360 in my homeautomation for many months, it has become “crazy” and is very inaccurate on my Huawai mobile phone. My wife uses an iPhone, and nothing is wrong there.

I can look at the Life360 app and actually SEE myself driving around in my neighborhood when I’m sitting in my office! A miracle!

The problem is that I have setup an automation that turns my officelight off when I’m gone. When I’m “visiting” my neighbors - according to Life306 - the light turns off. I have also setup Tado smart thermostat to controll all of the radiators. They will too turn off the heating when Life360 acts like this. Not a problem in summer though.

My question is; have anyone else experienced the same lately and maybe know how to fix it?

I’ve been using Life360, and the HA integration, for a long time, on two Samsung Android phones, and one Apple iPhone, and I’ve not noticed it being any less accurate lately.

Are you saying the life360 entity in HA is not updating as accurately as the Life360 app for this one phone? Or is the Life360 app just as inaccurate? Note, though, when you open the Life360 app on the phone in question, that may make it update more frequently than when the app is not open, so you’d really need to compare what HA sees to what the Life360 app (or website) see from a different phone.

I also use life360 and rate it very highly.
I did have 2 days near the beginning of the month when it just wasn’t updating but they acknowledged the fact and issued a warning of such to members, since then it’s been fine. The signal does jump about ‘sometimes’ but only by about 10m and that’s well within my home radius.
I’m curious, when you say you see yourself driving around, is this just you or other members of your household ? Are they all using the same platform ? Can they report similar anomalies ? When you say driving about, is this like a time delay version of the route you actually drive or is it maybe someone else ?
You say it’s Huawei, maybe they are getting back at the west and you are the test candidate :rofl:

I know you said your wife uses an iPhone but any other examples ?

ditto. IT’s now my single source of location as all the others I tried where not great

1 Like

Thanks for the answer.

I should have said that Life360 was working great earlier on the same phone (Huawai). Im not sure if it has been an update to Life360 or to HA that have caused the error.

However, I’m still quite sure that HA just reports - and acts to - what Life360 tells it, because as I said earlier, I can see myself moving all over in the Life360-app.

Mutt: I have witness errors of about 1 km at most… Mostly the error is greater than the zone I have setup for home (300 m). Sometimes also in the middle off the ocean, and NO - I’m have not a floting home :sweat_smile: My wife’s position is stable, it’s just mine position that is all wrong. There are no others in my household.

Life360 uses proprietary technology to help its positioning whilst using the smallest amount of power possible (checks wifi cells and Bluetooth beacons I believe) anyway it’s made life360 both ubiquitous and pretty reliable. Like Lolo and Phil, I sing its praises, HA (as via Phil’s integration) can only report what it thinks (ie what it’s told) .
So it’s not HA and as most people have no issue, so it’s either the phone itself or the app is confused. Did you change phones recently ? Did you pass on the old phone or is is switched off in a drawer somewhere ?
I don’t subscribe to the view Huawei have it in for us (at least in this petty way)
Most likely though I’d say that your phone may be damaged (the GPS part at the least)
Try a few other GPS positioning apps including checking Googles own.
Do some comparisons.
Report back when you know more

Sorry, that’s a bit confusing and apparently contrary to what you said before. Yes, HA’s life360 integration can only use the data as it gets it from the Life360 server. And, AFAIK, the HA integration is working correctly. But this recent statement seems to imply that the HA integration is responding just as well as the Life360 app. So now I’m confused.

Thank you for pointing me in the right direction! After some testing, I found that Google Maps also was acting “crazy” on my phone, like Life360. It seems that the phone’s GPS is faulty. I tried some apps for calibrate the GPS but with no luck so far. I guess it could be something wrong with the antenna. Too bad for the phone is quite new.

So can you then change the title of this topic from “Life360 very inaccurate” to “My Huawai phone’s GPS very inaccurate”?


Have to mark your answer as the solution :slight_smile:

1 Like

Eh.? Why ?

What did Phil add ?

I added that his initial assertion was “inaccurate.” :laughing: :laughing:

Has anyone else noticed recently that the Life360 app is no longer happily and reliably background updating? Both my wife and I are now getting frequent messages from Home Assistant that an update is overdue. It’s generally restored after about an hour or so.

We now have four phones in our Circle, two of which are Android and two are iPhones. I’m seeing this on the two iPhones, and they are tending to take upwards of an hour or so to update. I would say this started probably a few weeks ago.

So relieved it’s not just me. I’d contact life360 but they are spectacularly uninterested in such bug reports and would rather just send copy pasta replies

well “copy pasta” is the tastiest :smiley:


Just an update: I found that something is interfering with the GPS-signal - probably something with the wifi-router. Nothing wrong with my Huawei phone :slight_smile:

So I’ve updated to the latest version of life360 and it seems to have (possibly) resolved the big delays between updates bug but it’s introduced another one - for the first time ever I’m now getting inaccurate updates. Marked as home when I’m not and marked away away when I’m not. Ridiculous. I don’t understand how they can keep breaking something which was working!

I have no issues whatsoever.
1 x iPhone 10S, 1x 1Phone 11, location is accurate and quick

Glad it works for you. It’s gone to S for me. iPhone 6S here (both). Don’t know if the creator of the integration is still having trouble with it or not.