Limitlessled no longer working since update

My mi lights no longer show up in the overview page since the update to 77.3.
I’m running a pi3B+ with hass:io
I have the newer wifi bridge box (little led light) with 2 rgbw strip controllers.
everything works fine in the app and when originally set up I had to set the type as rgbww, to get them to show up in the overview, even though they’re only rgbw controllers.
but now after this update, i get nothing. I’ve tried reinstalling, I’ve tried making the type rgbw instead of rgbww still no luck.
anyone have a solution to this?

set up below

  - platform:  limitlessled
      - host:
        version: 6
        port: 5987
        - number: 1
          name: Desk Bridge
          type: bridge-led
          fade: on
        - number: 1
          name: Desk Strip
          type: rgbww
          fade: on
        - number: 2
          name: Wall Effect
          type: rgbww
          fade: on

I am also having a problem after the update to 77.3. It finally dawned on me to check the forums. :slight_smile: I had everything working last week with a recent purchase of the new milight controller (non led version) and a mk16 landscape light. I followed the instructions and was pleased it worked as the docs said. Then everything stopped with the update. HA still seems to think it is controlling something if I select blue or red, it sets the light icon correctly. It just seems like the bridge is not getting the message (or a malformed message). This sucks because I was trying to write a script to change the lights in a cool sequence of colors (for Halloween) and basically I can’t do any work on that now. :frowning:

1 Like

Ya, mine worked 2 days then the update seemed to screw that.
I’m hoping the next update rectifys the issue. Or better yet someone in here figures out what got broke and how to fix it.

you can’t have 2 groups with the same number… oh hang on… maybe you can if they are different types…

Mine haven’t missed a beat.

Ya as long as they’re different types the group number can be the same.

Anyone try 78.1 to see if this is fixed yet? I read the release notes any didn’t see anything on limitlessled in there.

Ya, release notes mention nothing about it. But I figured I would give it a shot anyway and upgrade.
Good thing, upgrade went rather fast and smooth
Bad thing, my apple TVs done show up on overview page anymore. Lol
Oh, and limitless still don’t work, but I had that issue prior so not a big deal.
Seeing how I’m just starting out with HA, I’ll think I’ll just blow it away and start from scratch again and see what’s what.

There is a problem with discovery in 0.78.1 that is fixed in 0.78.2 -that explains the Apple TV issue. I still have zero issues with LimitlessLED - they have worked perfectly in every version I have used including the 0.78.x series.

The missing lights must be a configuration issue.

The limitlessled lights will show up just from the configuration, even if they are unavailable to Home Assistant because the host or type is wrong.

Maybe you added two light: sections and one is getting ignored?

1 Like

When I look for an error, this is what I find, which is pretty much Greek to me.

    Error while setting up platform limitlessled
    Traceback (most recent call last):
      File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/", line 128, in _async_setup_platform
        SLOW_SETUP_MAX_WAIT, loop=hass.loop)
      File "/usr/local/lib/python3.6/asyncio/", line 358, in wait_for
        return fut.result()
      File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
        result = self.fn(*self.args, **self.kwargs)
      File "/usr/local/lib/python3.6/site-packages/homeassistant/components/light/", line 120, in setup_platform
        version=bridge_conf.get(CONF_VERSION, DEFAULT_VERSION))
      File "/usr/local/lib/python3.6/site-packages/limitlessled/", line 112, in __init__
      File "/usr/local/lib/python3.6/site-packages/limitlessled/", line 269, in _init_connection
    ConnectionRefusedError: [Errno 111] Connection refused

Oh, I did not think that could happen. Anyway, I still think it means that you have a configuration error.

Check your host parameter. It should be the IP address of the wifi bridge, not the address of the Pi.

Bridge IP is correct.
I tried tracing down some of the files/folders mentioned in the above error.
Something is goofy cause a couple of them don’t exist.
My forehead is tired of the keyboard imprints, and I’ve decided to blow away my HA. I am now in the process of re installing everything from scratch.

My Limitless devices disappear at times.

How I’ve rectified this:

Open the milight app from your phone

Tap on your milight bridge (if you do not see a blue globe at the right close, kill, and restart the app until it appears)

Once connected to your bridge verify that you have control over your lights

SSH into the Pi and send a sudo reboot command

Wait for homeassistant frontend to become available

Check to see if your limitless devices have returned

Let me know if this works for you. It seems that my bridge just randomly decides it doesn’t wish to talk to homeassistant.

I have no freakin idea what was wrong. But after rebuilding everything they now work.
So I’m marking this resolved.
Thanks to everyone for their ideas and help.

What does “disappear” mean?

J5L7R, what does “rebuilding everything” mean? It sounds like you started from scratch with a vanilla HA and setup up the config file again. Groups file? automations file? seems like a lot of work. I still haven’t gotten mine to work again. They worked fine at first but now… nada. I tried removing the lights from the config files, restarted HA, lights were gone, added back to config file, restarted, and still not working. I even did what majiksmoke suggested and can control the lights with the app on the phone, rebooted, and still nothing. This makes no sense that it worked, then doesn’t, yet others having it working on the same version of HA.

That’s exactly what I did, I started from scratch.
Truthfully I had only just set up my HA so didn’t have a lot of time/effort invested into it yet. Had the basics setup, I’m mostly HomeKit stuff, so I had that set up and just started adding non HK devices when I ran into my little Limitless problem. It worked for about a week, I’m assuming that my fat fingers must of hit a key some where when they shouldn’t have. But to be honest, I deleted everything to do with Limitless and added them back in manually a few times, and still had no luck. The blowing it away was a sorta last straw type deal.
No idea why it worked, but it did.

I will copy my config directory and start from scratch to see what happens with just limitlessled. I guess if it works I can copy over pieces of my config a piece at a time.

Well good luck. Mine seems to be fine now. But now I’m having issues with AppDaemon when I re loaded it.
Damm keyboard indents on my forehead are getting deeper and deeper. :wink:

No luck. :frowning:
So I was trying to remember anything that I did that could have caused the problem. And this may have started when I changed the remote type in the mobile app. I have the latest controller and wanted the 8 zones and milight’s tech support said the last remote (on the far right in the selection set) is the one that works with 8 zones. I had to re-pair the light to that “remote” type. It seems to have worked (it does work with milight’s app) but maybe it doesn’t with HA because maybe it uses different commands for the protocol. I can retest tomorrow by re-pairing the light with the first remote when it worked before.