Linear NGDZ00-4 Garage Door

A .storage folder should exist, attempt a cd ~/.homeassistant/.storage and see what happens.

Definitely doesn’t. I know my way around Linux :slight_smile:

[email protected]:~ $ cd ~/.homeassistant/.storage
-bash: cd: /home/pi/.homeassistant/.storage: No such file or directory
[email protected]:~ $ cd .homeassistant/
[email protected]:~/.homeassistant $ ls -al
total 24056
drwxrwxrwx 2 pi pi     4096 Aug  1 20:10 .
drwxr-xr-x 8 pi pi     4096 Aug  1 09:00 ..
-rw-r--r-- 1 pi pi      478 Sep 15  2017 automations.yaml
-rw-r--r-- 1 pi pi     1024 Sep 15  2017 .automations.yaml.swp
-rw-r--r-- 1 pi pi     2395 Jul 31 23:24 configuration.yaml
-rw-r--r-- 1 pi pi     2614 Sep 15  2017 configuration.yaml.bak
-rw-r--r-- 1 pi pi     1053 Sep 15  2017 groups.yaml
-rw-r--r-- 1 pi pi        6 Sep 15  2017 .HA_VERSION
-rw-r--r-- 1 pi pi    18561 Sep 15  2017 home-assistant.log
-rw-r--r-- 1 pi pi 24521728 Sep 15  2017 home-assistant_v2.db
-rw-r--r-- 1 pi pi        0 Jun  5  2018 ip_bans.bak
-rw-r--r-- 1 pi pi        0 Jul 31 00:55 ip_bans.yaml
-rw-r--r-- 1 pi pi        0 Aug  1 20:10 OZW_Log.txt
-rw-r--r-- 1 pi pi     8192 Sep 15  2017 pyozw.sqlite
-rw-r--r-- 1 pi pi        0 Sep 15  2017 scripts.yaml
-rw-r--r-- 1 pi pi       44 Sep 15  2017 .uuid
-rw-r--r-- 1 pi pi    35676 Sep 15  2017 zwcfg_0xc2236907.xml
-rw-r--r-- 1 pi pi      108 Sep 15  2017 zwscene.xml

Very odd, homeassistant is supposed to create the directory, but your configuration should live in /home/homeassistant/.homeassistant unless you’ve modified the service, since that’s the default location for the configuration files in hassbian.

Can I just create the dir and file underneath it? I don’t know the format of the core.config_entries file, though. Maybe I should just blow this away and start over.

No.

Assuming /home/homeassistant/.homeassistant doesn’t exist then?

Correct, does not exist

Edit to add: My system does not even have a “homeassistant” user, so it will of course not have a home dir :). Guess this thing is seriously fubar’d - one of the upgrades must’ve gone sideways and I never noticed til this adventure with the opener.

hasbian from what i understand should have the user pre-made for you… :man_shrugging:
I prefer the venv install myself.

If you have upgraded to 0.96.5 then the .storage directory is somewhere on your system… but it might be easier to nuke this and start over at this point :frowning:

I think it’s totally hosed :-/ If I do: find / -type d -name ".storage", nothing shows up. It’s super unhappy haha.

Got it taken care of. Entirely rebuilt my Pi using the latest image, setup my network key, did a Add Node Secure, annnnd it all shows up fine now. :slight_smile: thanks for your help @firstof9

1 Like

Seems homeassistant-pyozw==0.1.4 doesn’t compile on alpine when using the dev flavor. I tried to take a look but didn’t have the capacity to spend time on it. Get ready for it now if you’re still doing your own builds. Only reason I still want to is the user lock code clear that is not in the current version.

i cant get mine to pair in secure i know it has to be secure but no matter what i do it wont pair help please

What does your OZW_Log.txt show?
Specifically the first 5 lines, then the lines where you attempt to add the device.

I’ll check and post it


hope that’s what your looking for i’m very new to HA

Your problem is in line 2, you have no network key setup so you cannot pair secure devices.
Also it looks like you don’t have the correct tty device configured for zwave.

Alright I’ll put in a key and try to fix the others but my z wave does work

Alright Put the key in But my z wave works what am i doing wrong
running it on a pi3b+ with a nortech usb stick

Try pairing the device now, see what happens.

i tried it showed up for a second but then disappeared in the nodes that was doing it secured more the what its been doing

Those CAN message are not good.