LinkPlay Integration

Does this work for all internet radio, or just lastfm?

It works for all Internet radio that has the icecast data embedded. LastFM is just used to get the album art.

Hmm, doesn’t seem to work for me

Does the media player show the track and artist?

LastFM requires a good match so, for example, this one I am listening to right now won’t work because it has (87) to denote the year on it.


Also, not sure if makes any odds but I have icecast in double quotes :

icecast_metadata: "StationNameSongTitle"

I changed to double quotes, but it’s still the same anyway.

Are you using an Acrylic board?
And what internet radio station?i

Hmmm the fact you don’t have the song and artist showing probably means the station doesn’t do icecast (i.e. embed the info).

I’m using a Tibo for my source, but that should make any difference.

Here is my full conf with the radio stations :

  - platform: linkplay
    name: Office Media
    icecast_metadata: "StationNameSongTitle"
    lastfm_api_key: redacted
        "bluetooth": "Bluetooth",
        "line-in": "Line-in",
        "": "Female Vocal in Metal",
        "": "Medieval Metal/Rock",
        "": "Mixed Metal",
        "": "Power Metal",
        "": "Speed Metal",
        "": "Symphonic Metal",
        "": "Thrash Metal",
        "": "Death Metal",
        "": "Thrash Death Metal",
        "": "Melodic Death Metal",
        "": "Epic Metal",
        "": "Doom Metal"

The mixed metal station won’t show artwork because they add the year to the end of the song. All others work 100% with album art.

1 Like

I take it you like metal?

Just a bit :wink:

I have problems with the different sources on linkplay media players, maybe someone can help. My setup consists of 6 linkplay devices (4 audio pro speakers and 2 wiim devices) and I’m using the newest beta of the linkplay integration.

When the source of a linkplay media player is changed to Bluetooth, the state immediately changes to ‘playing’, even if nothing is actually playing. The same happens with all other sources, except when the source is wifi. I understand that getting meta data with Bluetooth doesn’t work, but is reading out the players state also not possible?

Can you share your config? I have up2stream mini but cant get it to work. Its shown as unavailable

  - platform: linkplay
    protocol: https
    name: Dnevna Soba Speakers
    volume_step: 10
    uuid: FF31F09EbA6B3B07CA957731
    icecast_metadata: "StationNameSongTitle"
    multiroom_wifidirect: False
    sources: {}
a question from a newbie that just bought an Arylic A50: how can I get the device uuid ?

I am getting this error on HA log: 
2024-01-20 23:03:49.050 WARNING (MainThread) [custom_components.linkplay.media_player] Failed communicating with LinkPlayDevice (start) '': uuid: <class 'aiohttp.client_exceptions.ClientConnectorCertificateError'>

2024-01-20 23:03:49.050 WARNING (MainThread) [custom_components.linkplay.media_player] Get Status UUID failed, response code: Unknown Full message: None

2024-01-20 23:03:53.441 WARNING (MainThread) [custom_components.linkplay.media_player] Failed communicating with LinkPlayDevice (httpapi) 'Sound Bathroom01_Level01_SoundSystem': <class 'aiohttp.client_exceptions.ClientConnectorSSLError'>

I guess it happens because I am not setting the uuid on my configuration.

Thank you.

Hello everyone, please has someone tried to connect this integration with the A88 v4.0 chips for example with Harman Kardon astra or Allure models?

Hi @mariomor , have you managed to resolve this issue? I’m getting exactly the same log error:

2024-02-25 09:15:41.121 WARNING (MainThread) [custom_components.linkplay.media_player] Failed communicating with LinkPlayDevice (httpapi) 'Living Room': <class 'aiohttp.client_exceptions.ClientConnectorSSLError'>
1 Like

In the linkplay release notes it is stated that the home assistant native speaker join function is supported, but using ‘media_player.join’ results in an unknown error. The linkplay join service works flawless, though.

Can anyone confirm if the native join service is supported? It would be so cool to use my linkplay speakers with the new ‘maxi media player’ card.

Btw if anyone is interested in my custom linkplay card (made with paper buttons) which I am using instead, I am happy to share it with you:

1 Like

Please share

Sure. Currently it’s just one huge block of yaml that’s probably hard to edit. I’m going to simplify and clean up the code a bit so it’s easier to use for others. I will post the full code here in a few days

@d101au04 , @mariomor To get uuid you can use below link, just change ip to your device.

But for me error was caused by protocol variable, just change it to:

protocol: http

This is how my config for Arylic A50+ looks like

    - platform: linkplay
      protocol: http
      name: Arylic
      volume_step: 5
      icecast_metadata: 'StationName'
      uuid: 'FF...'
      multiroom_wifidirect: False
          'optical': 'TV sound OPT', 
          'line-in': 'Line Inr', 
          'bluetooth': 'Bluetooth',
          '' : 'Radio Nowy Świat'

I’m having a issue with the IEAST Olio streamer. In the linkplay integration, the device goes to unavailable state every 3-4 hours for about 10 minutes. I have a ping and I can confirm the device responds.

  - platform: linkplay
    uuid: "FF970015D9C1D807404A3E86"
    protocol: https
    icecast_metadata: "StationNameSongTitle"
    name: olio_linkplay
    volume_step: 1
    sources: {}

(it only works via https, http the device is always unavailable)

I only see this log:
2024-04-01 20:29:49.935 WARNING (MainThread) [custom_components.linkplay.media_player] Failed communicating with LinkPlayDevice (httpapi) 'OlioTeste1': <class 'TimeoutError'>

Anyone had this issue?

Is there any way to reload the integration (like using the reload-config-entry)? Sometimes the Olio isn’t found by the integration and the only solution is to fully restart HA

Thanks @Kamil-u , adding in the “uuid:” has enabled the device to appear in HA and I’ve successfully set-up access via lovelace.

Interestingly however, I’m now seeing a new error in the logs that is similar to that which @rafareusch recently reported:

First occurred: 18:10:20 (1 occurrences)
Last logged: 18:10:20

Failed communicating with LinkPlayDevice (httpapi) 'Living Room': <class 'TimeoutError'>