Local Tuya - Fan Controller

I’m trying to get Local Tuya setup for these fan controllers from Amazon. I’ve set them up in the TuyaSmart app and can get them to show up in the Local Tuya integration. I can also get them to turn on/off, but that’s it. There are options to set speed controls, but no docs that I can find on what setting maps in what direction, that kind of thing.


Any suggestions?


Did you go through the whole process of getting your local key?

Yep! Have it set up, I’m just only able to control on/off, not fan speed.

I would ask here then:

I know assigning the attributes to entities was confusing so maybe try to re-configure it.
It says it supports fans so maybe it’s just an issue of selecting the correct attribute while re-configuring it.

Yeah, I think that’s the trick. I haven’t seen a “key” to what each attribute means, so I’ve been guessing. I’ll see if I can get some help on the repo.

1 Like

The DP #3 is what controls the speed in my Tuya fan controller. The challenge I’m facing is that my fan speed controller has 5 steps - 1 through 5 while the local Tuya configuration allows only 3 steps - low medium and high. Due to this I was using Tuya scenes for getting speed to work but that was cloud based. However just two days ago I managed a dirty hack which after proper configuration controls the speeds perfectly from the HA front end.

Did you manage to sort this problem any other way?

1 Like

Hi, I have been having the same issues. What ‘hack’ did you come up with to get it working?

I tried customising the entity and can get the slider to move in 18% increments (giving 6 “speeds”) and I set the speed list to [“off”,“1”,“2”,“3”,“4”,“5”,“6”] but it doesn’t actually set the speed correctly

Any help would be much appreciated

Hey Stephen,

You’ll have to tell me how you managed to get the slider to move in 18% increments as that was something I wasn’t able to do.

I ended up configuring the fan as a light in Local Tuya. Assign DP 3 (or whatever DP is the speed control in your device) as Brightness when adding the light control. Set Brightness Lower Value as 1 and Brightness Upper Value as 6. This will cause the brightness slider to control the speed. In my case, I set it from 1 to 5 and hence my brightness slider % to fan speed mappings work as follows:

Slider 1% = Speed 1
Slider 25% = Speed 2
Slider 50% = Speed 3
Slider 75% = Speed 4
Slider 100% = Speed 5

Yes, this makes your entity of the type “light” rather than “fan” but apart from this, it works perfectly. No hassles for me so far.

Hope this helps you out.

1 Like

Thanks for your reply

I’ll give it a go

As to the slide increments, I set HA up for entity customisations.

Then I set the following. As you can see I refined the percentage steps

Ah wow. Thanks so much @goldeagle2005 . I just installed a few DC smart fans, and have been having some trouble getting the speed control to work, but your light brightness hack was brilliant.
@Stephen_McKenzie , would you mind sharing some more details on your entity customisation for the speed control? Sorry, I’m still wrapping my head around how HA works, specifically when it comes to customisation like this.

1 Like

Glad it worked for you @daichisuba.

One more thing if it helps. You can also configure a sensor in Local Tuya corresponding to the DP which will display the current speed. Since it is local, any speed change you make via the physical switch will reflect immediately in your dashboard.

Would be amazing if you can share your setup, I’m battling this with a DC SKYFAN. Trying to get it working correctly


Weeks of guessing and playing with it and then upon stumbling into this thread, I decided to give it another go and I figured out why it wasn’t working but I still don’t know why it doesn’t work in my previous configuration. Here’s what I learned:

If I use this EXACT setup, it works:

For some reason, even though I know my fans respond to high med low, when those settings were in these fields, it would never work. As soon as I changed to 1,2,3 it started working. I tried the small, mid, large and got the same non-results. Now that I have the setting, I am going to copy it to all my other ceiling fans. The light and 3 step speeds and on/off now work with my local tuya fans with this config.

So, I know this config works, but I still don’t know why if you use high, med, low it does nothing. At this point it doesn’t matter to me but it’s something I never considered to alter because I know these fans have always responded to high, med, low.

I hope this helps some other local tuya ceiling fan user and saves the headache of trying all the combinations.


Interesting! Just tried that on one of my Tuya ceiling fans and it didn’t allow me to adjust the speed, just on/off still.

1 Like

It’s unfortunate that is always going to be the case with Tuya …

As it is a platform, with no set standards in place … these various settings are always going to be hit and miss on different manufacturers.


I am back again with my fan controllers and local tuya. I got it all set up and working right but then I later realized two fans were not working correctly despite them all being the same. I went through the setup and removal of these two problematic fans multiple times and I finally noticed something different but I don’t know what’s causing it in 2/6 fans.

First, all these controllers were bought at the same time about 3 years ago. They’ve all worked the same all this time. It’s only in the Local Tuya app that I’m having an issue. The fans otherwise work fine and as long as I don’t want to control fan speed, technically the fan controller still works (on/off).

This is what I noticed:
On a successfully running fan:

it says at the top editing an entitiy with DPS 1 and the fan speed control dps is 3 (value: 2). This configuration works flawlessly on 4 fans. No problem here.

Now, move onto the Bedroom and Den fans and when I try to set them up, they BOTH look like this every time despite them being the same device:

You’ll notice that at the top of this one, it recognizes it as a fan, but then doesn’t give me the option for 3(value: 2) which is required to give me the fan speeds.

I don’t understand why only these two are having issues. It’s consistent every time I set them up. Do you folks have any ideas or know where I might look to determine the cause/why it’s reading these similar devices differently?

long shot … on the Tuya app … is there a firmware update for the other 2 fans?

I just confirmed that all 6 fans are on the most recent/same firmware and tried installation again. Same results.

more long shots … there was a recent update to Local Tuya that broke some of my fans … and I had to re-install … did you do the update?

I think that’s the update that caused a few of my fans to break, I reconfigured them and copied them down and I thought they were working for a few days (despite me noticing the difference in the setup) and then realized some days later that the setups were behaving differently.

So I am on the most recent local tuya. Today, trying to fool with it and clicking too much I clicked ‘restore defaults’ in the API Explorer which I idiotically thought would be basic settings. No, wiped them out of Tuya completely; no worries, I readded them, they now have a new ID and local key but I still get the same results on both of these and none of the others.