Logbook exclude dont work

I want some of my entities not to appear in the logbook. I currently have the following in configuration.yaml:

      - switch.luz_escritorio_117

But the entities continue to appear in the logbook…
Can anyone help me?

I’m using the MariaDB add-on to save and I want to continue saving, but I wish it didn’t show up in the logbook

I’m on 2022.6.4 and confirm same behavior: here I have a logbook exclude filter for a few entities, and they still appear on logbook. Please note that in my case these same entities are also on include filter of the recorder integration.

Checking more deeply in the logbook integration, it seems it merges the logbook and recorder filters. I’ve no idea why that, but maybe that’s why explains this behavior.

recorder_conf = config.get(RECORDER_DOMAIN, {})
logbook_conf = config.get(DOMAIN, {})
recorder_filter = extract_include_exclude_filter_conf(recorder_conf)
logbook_filter = extract_include_exclude_filter_conf(logbook_conf)
merged_filter = merge_include_exclude_filters(recorder_filter, logbook_filter)
1 Like

Having the same issue.
I’ve opened a bug at Logbook exclude filters not working · Issue #80716 · home-assistant/core · GitHub


That’s exactly the problem, the merged_filter was introduced recently and it does not make much sense too me as the logbook filter should be prioritized.

It’s impossible to exclude entities from the logbook only if they have been included in the recorder.

Ad the GitHub issue does not get much attention from the devs hopefully some moderator comes across this topic :grinning:

same Issues: Excluded Entity still shows up in logbook

1 Like

Still appears to be broken. I tried excluding the same things from recorder, history and logbook, by entity, domain (image) and entity_glob and nothing worked. It seems completely broken.