Login attempt failed - Identify what's failing a login every 5 seconds

Hi all,

I’ve got a RPI 3 running Home Assistant 0.81.6 (Hassbian). It’s a completely local instance and it also runs Nodered. I recently updated from a version before the new auth implementation.

Ever since the update I’ve had an error every 5 seconds saying:

“Login attempt or request with invalid authentication from”

I’m able to login perfectly fine so I’m at a loss for how to identify what’s causing this.

Main things I’ve tried (not exhaustive):

  • Deleting the three auth files from within the .storage folder
  • Disabling nodered completely
  • Excluding Hass from Nmap scan/disabling it entirely

Any ideas at this stage would be appreciated :slight_smile:

Is it possible that something in your config is trying to send something to the api?

I’m currently commenting out as much as I can in my config to see if I can run Hass without the error. No luck so far

Just managed to fix it. Posting what worked for me in the hope it saves the sanity of others :smile:!

It was mentioned in the discord chat that a 5 second interval was likely to be AppDaemon. I’m totally unfamiliar with that so had no idea how to approach it.

Long story short, the below command fixed the issue I was having.

sudo hassbian-config upgrade appdaemon

Hope this helps someone!