Losing network connection after a few hours

Hi all

I’m not sure if this is a HASSIO issue or a Rapberry Pi 3 issue but I’ve noticed since maybe version 0.48.0 that I loose all connections to my HASSIO install on my raspberry pi 3 after maybe a few hours of being online. Rebooting (pulling the power) the device regains the connection but this is obviously not ideal.

Checking network with Fing I can’t see the IP address or HASSIO.local anywhere on the network. It’s either loosing network connection, locking up or wifi is failing. I’m running the latest version (0.49.1)

Has anyone else come across this issue?

2 Likes

I have met once.You can try “ssh [email protected]” into hassio and then execute the command “hassio homeassistant restart”.

Hi @apt, maybe your wifi goes to sleep?

1 Like

That sounds like a possibility, as it’s the HASSIO image it shouldn’t be doing that, how can I test/fix this cc: @balloob

I never had these kind of issues. Running for about 2 weeks without a dropout.

That is not possible that the network interface go down. I run multible pi3 on wlan without problem.

Can be that you have DHCP enable and your pi change the IP while your DHCP give him every time a new IP?

How would it do that? I’ve not customised any of the setting apart from adding the wifi details when first setting up HASSIO.

Can these be checked as changed after it’s all been setup?

Ok so my HASSIO install just appeared online without me doing anything. It looks like it’s got a different IP address (according to the home assistant iOS app) so it’s definately looking like it’s DHCP related error. Had a quick look at assigning static ip addresses on the forums but it’s looking like they are all for standard home assistant installs and not HASSIO (etc/network/interfaces not present), where would I set the static ip and DHCP on a HASSIO install?

1 Like

@pvizeli that’s for setting up an initial install, how would I do it for an existing setup that’s already running?

You can assign a static IP from the router.

You can change that file on SD partition every time (need shutdown your system). We have plane to support the network config in realtime over UI in future.

1 Like

I too have been having a similar issue. I set up a Pi3 with Hass.IO with an ethernet connection, and the IP address set in the router. Everything worked fine this morning at home and then a few hours ago remotely.

Now I cannot connect remotely to HassIO but I can still access my Zoneminder install on a different machine (same way to access remotely just a different port).

I will check once I make it home but I bet I cant reach it locally either.

I had this issue after adding an ffmpeg camera. I switched it to a still image camera, and now I’ve been running for several days without a failure. I’m not sure that’s actually useful in your situation, but give it a try.

Has there been a solution to this issue? I’m fairly new to Hassio/HA (but not new to home automation or networking, etc.) I find that after a day or so my Hassio/RPi drops its wired connection. I know that Home Assistant is still continues to run automation and I can turn on and off light that are controled via X10 (through an antenna via a USB input). As previous users have stated, the network router no longer lists the RPi as a connected device. I have the router assign a static address to the Pi MAC address.

Any ideas?

Thanks.

I have exactly the same issue. Was there any resolution for it? After some time HA RPi4 drops of the network.

Don’t know if this is linked or not but this morning at about 10 to 10 my HA instance became unreachable. I rebooted it via SSH (that works) and it was available again for a while but it’s gone again now.

Ah in my case there’s definitely some sort of (maybe memory leak?) problem going on. Restarting HA didn’t fix it but restarting the host seems to have.

I have this issue allot. My pi4 is plugged in via ethernet though it was the same with WiFi.

Randomly I can’t connect to it with my phone on my network. If I restart my router, it works. If I don’t restart but log in remotely (outside of my network) it works.

Not sure why it would work remotely but not locally.

Thanks for saying that, I have recently been having problems with my internet and Home Assistant and I didn’t know what else to do. I recently installed a ffmpeg camera and started having connection problems. I will remove the camera and see if it will be corrected.