Louvolite Roller Blinds/RFXtrx433E/HA Blue

I have Louvolite roller blinds, identified in HA as RollerTrol 002a6n:n (n is different for each blind).
I am controlling them from HA via an RFXtrx433E RF bridge.
The blinds respond to the three commands showing in HA dashboard (namely - UP, DOWN, STOP).
The blinds do NOT respond correctly to the the STOP command (the “My” button) when they are not moving - the correct response is to move to a pre-set position.
They do respond by moving a few centimetres at each press of the STOP command.
I have tried using the service ‘cover.set_cover_position’ - no response from blinds.
I thought the blinds responded to the logic - “if moving, then stop OR if not moving, go to set position”. This is how it works when using the manual remote control…
Can anyone shed any light on what is going on?
Many thanks.

I have reproduced the faulty operation on the remote control.
Pressing the ‘STOP/My’ button for 2 seconds causes the blind to move slightly then stop.
Seems like the RFXComm command is sending for too long a period of time?

2nd Update
I have got a sort of solution - send a ‘down’ command then a :stop: command.
This moves the blind a bit, then stops, then moves the blind to the MY position.
Not ideal, but it is sort of answer!

Mine do move to my position after 3 fast clicks :wink:

I suppose your 3 fast clicks are ‘STOP’ commands.
Do you know what the rfx device is actually doing with these Home Assistant commands?

Yes, exactly. 3x STOP. But it needs to be in speed, always the same. To fast does not work, to slow does not work too.

I don’t know, i since yesterday had not the time to find out, how to monitor it. Next weekend maybe… :wink:

OK. Thanks for the update.
I’ll play around with it.

I’ve tried 3 commands, with delays between them.
Best I could get was still a short movement down, stop, then continuous movement to the ‘My’ position.
I’ll stay with this, as it does achieve the desired end result.
Thanks for your input.

1 Like

Hi Paul. I have louvolite blinds as well. Can you send me a link with the bridge you are using to control via HA? Thanks in advance.

This may help you… :wink: