Lovelace: Mini Media Player

Try restarting HA.

I’ve restarted HA but I have the same issue again

Where exactly do you have this?

In your configuration.yaml file, lovelace.yaml file or dashboards/resources ?

I have it on my Lovelace page under Settings - Resources

try as type only module and then restart HA and make sure you reload resources of your lovelace page (hit the three dots and hit reload resources).

That’s not an option.

Oh ok, I’m using YAML mode (and there you need to use ‘module’ only). I was under the assumption that it was the same with GUI editor. Perhaps you need to reload resources like I mentioned.

Ok I’ve done :slight_smile: it’s working!

this is the code of the card:

artwork: cover
entity: media_player.spotify_stefano_trifance
type: 'custom:mini-media-player'
icon: 'mdi:spotify'
  power_state: false
  runtime: false
  source: false
  volume: false
  shuffle: false
  info: false

When I want to select the device to play Spotify, I can choose from HA, the 2 Echo that I have setted on my Spotify app.
But when I open my Spotify app, connected with my home wifi, I can choose other devices like my Denon AVR or my Google Home Mini or Sony TV (with Google Cast).

Is there a way I can choose my device media setted on HA, as the device where I can listen to Spotify? Can I set somewhere my “media_player.denon_avr_x2300w”, “media_player.sony_bravia_tv” or “media_player.salone” ?

I’m gonna redo my music players/speakers using the mini media player again.
However i have some questions.
I have 3 sonos devices and google home devices, which i use as speaker.
When i look at my sonos speaker, i have a dropdown for the source selection

However the sources there, is not from spotify… but directly from sonos app -> albums , titles and radio stations. I do not want that.

I would like to be able to define the sources there from spotify (for all my players) + for the sonos soundbar also the TV source.
How do i do this? I already added the spotify integration with succes, but that gave me an extra mediaplayer lol.

I will also add shortcuts to my radio stations (i need url for that right? from spotify?)
Is it also possible to put a shortcut to the search button of spotify itself? (in case i want to search for something new (artist, or title, …)

Thx for the help

No, unfortunately not possible from HACS, you’d need to build the source yourself according to the developer instructions in the readme.
Can probably do a new release tomorrow if not tonight.

1 Like

OK thanks @kalkih, I’ll keep an eye out for the release.

Try the shortcuts option in this card, I think that’s the closest you’ll get only using this card.
See this example but try list instead of buttons as it seems like that’s what you’re after.

could someone update the github repo, it took me some time to find the solution

  • url: /local/mini-media-player-bundle.js?v=1.10.2
    type: module

should be

  • url: /local/mini-media-player-bundle.js?v=1.10.2
    type: js

module didn’t work for me

That’s weird, module is actually correct. I have mine as module since I ever used the card (8 months ago),

  mode: yaml
    - type: module
      url: /hacsfiles/mini-media-player/mini-media-player-bundle.js

Never had any issues with mini media player cards…

that’s indeed weird, i was only able to get it working with JS as indicated in 3th post from Karl.

I dont need the spotify integration then? since that makes only an extra mediaplayer…

  • I dont need to use the source… ?
    I just use shortcuts (lists) to point to playlists from spotify…
    Any examples of those lists?

Module should work in most cases, unless your running a very old browser, then js might be the way to go.
It’s covered in the readme under Getting errors?

There are shortcut examples in the example I linked you.
If spotcast does what you want you could potentially skip the spotify integration, there’s an example of a spotcast shortcut in that example as well.

I’m using the latest chrome version

Awesome card! One question. How do I hide the “state” text. I can’t seem to find the proper name to put to true in the hide object. I.e. I want to hide the text “Idle” and “Unavailable” in following screenshot.


I can’t get this to install. I’ve followed the instruction exactly. Not sure what I’m doing wrong. I’ve tried adding the “resource:…” to the configuration.yaml but when checking config I keep getting an error of resource not found. I’ve moved the file to the www/ folder. I also tried loading the resource into the UI but still not getting any entity in the editor. Is there a video that shows this installation better? (I’ve got the latest builds of HA).