Lovelace: Multiple entity row

Thanks a lot, found this at last! Great help.

Hi, I’m curious about how you solved it. Please share it. Thanks in advance.

I have just tried to replicate “emteedubs” example by creating the quoted input select entities and used two dummy input boolen and managed to get his documented end result. I’m now in the process of replacing the dummy entity_id’s with the once for which I was looking for this combined ‘custom:multiple-entity-row’ and ‘custom:fold-entity-row’!

1 Like

Is there a way I can hide/delete the ‘On’ denotation from the main switch.study?
Screenshot_2020-11-15 Overview - Home Assistant

type: entities
entities:
  - type: 'custom:fold-entity-row'
    head:
      entity: switch.study
      type: 'custom:multiple-entity-row'
      name: Study
      icon: 'mdi:lightbulb'
      state_color: true
      toggle: false
      entities:
        - entity: sensor.study_light_auto_active
          name: Schedule
        - entity: sensor.study_light_on_after_sunset
        - entity: sensor.study_light_off
        - icon: 'mdi:lightbulb-outline'
          state_color: true
          tap_action:
            action: call-service
            service: switch.toggle
            service_data:
              entity_id: switch.study
    entities:
      - entity: input_boolean.study_light_auto
      - entities:
          - entity: sensor.sunset
        entity: sensor.study_light_on_after_sunset
        type: 'custom:multiple-entity-row'
      - entity: input_datetime.study_light_after_time
      - entity: input_datetime.study_light_not_after_time

Did you try?:
show_state: false

Bingo! :+1:

1 Like

Hi all,
i created a card to show some shelly information, is possible to change false or true of an attribute value to another text?

type: 'custom:auto-entities'
show_empty: false
card:
  type: entities
  title: Shelly
filter:
  exclude:
    - attributes:
        friendly_name: Shelly*
  include:
    - entity_id: '*shelly*'
      attributes:
        ip_address: '! none'
        has_firmware_update: '! none'
      options:
        type: 'custom:multiple-entity-row'
        show_state: true
        toggle: true
        entities:
          - attribute: ip_address
            name: IP
          - attribute: has_firmware_update
            name: FW

I tried with no luck

          - attribute: >-
               {% if state_attr(config.entity, 'has_firmware_update') %}
                 Latest
               {% else %}
                 Upgrade
               {% endif %}

hello friend,
i have some mistake in my card.
i think it is bad argument. can someone help me to understand.
(sorry i’m french)


card is very good and work perfectly .
i want understand why i have mistake (orange text)

cards: null
type: entities
entities:
  - entity: input_boolean.thermostats_horaire
  - type: section
  - entity: sensor.tranche_1
    type: 'custom:multiple-entity-row'
    state: true
    show_state: false
    entities:
      - entity: input_datetime.sejour_start_1
        name: départ
      - entity: input_datetime.sejour_stop_1
        name: fin 
  - type: section
  - entity: sensor.tranche_2
    state: true
    show_state: false
    entities:
      - entity: input_datetime.sejour_start_2
        name: départ
      - entity: input_datetime.sejour_stop_2
        name: fin
    type: 'custom:multiple-entity-row'
  - type: section
  - entity: sensor.tranche_3
    state: true
    show_state: false
    entities:
      - entity: input_datetime.sejour_start_3
        name: départ
      - entity: input_datetime.sejour_stop_3
        name: fin
    type: 'custom:multiple-entity-row'
  - type: section
state_color: true

sensor.tranche_1

- platform: template
  sensors:
    tranche_1:
      friendly_name: tranche 1
      value_template: >-
        {{ (states.sensor.time.state >= states.input_datetime.sejour_start_1.state) and  (states.sensor.time.state <= states.input_datetime.sejour_stop_1.state)}}
      icon_template: >-
        {% if is_state('sensor.tranche_1', 'True') %}
           mdi:lightning-bolt: mdi:radiator
        {% else %}
            mdi:sleep
          {% endif %}

input_datetime.sejour_start_1 and input_datetime.sejour_stop_1 are time custom to heater

Hi All,

I think last-changed shows ‘Never’ in the Multiple-entity-row secondary-info since update 2020-12 of HA, but I am not sure. When I remove the type: 'custom:multiple-entity-row', the last-changed shows just fine as you can see in the image below.

image

I updated from 3.3.0 to 4.1.1, hoping to solve the issue, but that wasn’t the case.
It’s probably something minor/simple that I am missing, but I guess it’s in my blind-spot somewhere. So ehhh Help :blush:?


EDIT
After days of looking at the ‘Never’ shown above, today there all of a sudden was a last changed value. So… Things mysteriously started working as designed again… Beats me, but happy that it works.

Is there a way to use this with another custom entity row?

I have some custom button entity row plugins and I would like to use those plugins and also add some other custom attributes to the same row.

here is a typical config for my plugin:

- type: custom:binary-control-button-row
  entity: light.computer_room_ceiling_light
  customTheme: true
  reverseButtons: true

I tried wrapping it in your custom plugin but it doesn’t end up as I’d like:

- type: custom:multiple-entity-row
  entity: light.computer_room_ceiling_light
  toggle: true
  state_color: true
  entities:
    - type: custom:binary-control-button-row
      entity: light.computer_room_ceiling_light
      customTheme: true
      reverseButtons: true
    - attribute: off_brightness
      name: Off Brightness

Here is how it looks with both of those:

ex

I’d like to keep the custom buttons from the second row and just add the secondary entity attribute to the same line as in the first row.

Is there anyway to correctly nest these two entity rows together to get the end result I want?

1 Like

Have I done something wrong here as each line is slightly off centre

Capture

type: entities
entities:
  - entity: sensor.ivy_s_room
    type: 'custom:multiple-entity-row'
    icon: 'mdi:thermometer'
    name: Ivy's Room
    secondary_info: last-changed
    entities:
      - attribute: min_value
        name: Min
      - attribute: max_value
        name: Max
  - entity: sensor.our_room
    type: 'custom:multiple-entity-row'
    icon: 'mdi:thermometer'
    name: Our Room
    secondary_info: last-changed
    entities:
      - entity: sensor.oregontemphygro_2dde_hum
        name: Humidity
      - attribute: min_value
        name: Min
      - attribute: max_value
        name: Max
  - entity: sensor.kitchen
    type: 'custom:multiple-entity-row'
    icon: 'mdi:thermometer'
    name: Kitchen
    secondary_info: last-changed
    entities:
      - entity: sensor.oregontemphygro_2dd4_hum
        name: Humidity
      - attribute: min_value
        name: Min
      - attribute: max_value
        name: Max
  - entity: sensor.hallway
    type: 'custom:multiple-entity-row'
    icon: 'mdi:thermometer'
    name: Hallway
    secondary_info: last-changed
    entities:
      - entity: sensor.oregontemphygro_2d60_hum
        name: Humidity
      - attribute: min_value
        name: Min
      - attribute: max_value
        name: Max
  - entity: sensor.garden
    icon: 'mdi:thermometer'
    type: 'custom:multiple-entity-row'
    name: Garden
    secondary_info: last-changed
    entities:
      - entity: sensor.oregontemphygro_2dcf_hum
        name: Humidity
      - attribute: min_value
        name: Min
      - attribute: max_value
        name: Max

I want to hide “Power” entity when “light.cabinet” is off.
How can I do it in my simple Entities card:

Screenshot

  - entity: light.cabinet
    toggle: true
    state_color: true
    type: 'custom:multiple-entity-row'
    entities:
      - entity: light.cabinet
        attribute: current_power_w
        unit: W
        name: Power

Hi All,

Can someone help me with follow:

entity: sensor.meek_hallway_wifi_info
type: 'custom:multiple-entity-row'
name: Hallway
show_state: false
entities:
  - attribute: RSSI
    name: RSSI
  - attribute: IP Address
    name: IP
  - attribute: Number Reconnects
    name: Reconnect
  - attribute: Connected msec
    name: Uptime

Connected msec value is 205665000 (msec)
How can I convert this back to hours in the card?

I don’t know what I am doing wrong, but the more-info/toggle/etc. action into double_tap_action/hold_action isn’t working for me. For example, when I hold the icon, it happens nothing. Neither on browser (firefox) or Androidphone (HA App).

In normal glance, the hold_action ist working with more-info.

        type: 'custom:multiple-entity-row'
        entities:
          - entity: light.kleiderschrank
            icon: 'mdi:wardrobe'
            name: false
            state_color: true
            tap_action:
              action: toggle
            hold_action:
              action: more-info
        entity: light.zimmer_licht
        name: Licht
        toggle: true
        state_color: true

And 2nd on my phone is something wrong with the layout, I think :sweat_smile:
grafik

Edit: Ok there is a Github Issue.

I don’t if that is working but try the format: option:

entity: sensor.meek_hallway_wifi_info
type: 'custom:multiple-entity-row'
name: Hallway
show_state: false
entities:
  - attribute: Connected msec
    name: Uptime
    format: time

How can I rotate a single icon on a multiple entity row?

  - type: 'custom:multiple-entity-row'
    entities:
      - entity: switch.sonoff_zzzzzz
        toggle: true
        icon: 'mdi:coach-lamp'
        name: false
        state_color: true
        tap_action:
          action: toggle
        styles:
          width: 40px
          text-align: center
      - entity: switch.sonoff_yyyyyyyyy
        toggle: true
        icon: 'mdi:globe-light'
        name: false
        state_color: true
        tap_action:
          action: toggle
        styles:
          rotate: 180
          width: 40px
          text-align: center
    entity: switch.sonoff_xxxxxxxx
    toggle: true
    icon: 'mdi:grass'
    name: Frente
    show_state: false

I think the feature is coming in a new version in Home Assistant: https://github.com/home-assistant/frontend/pull/4855

not really, Issue is closed.

check 🔹 Card-mod - Add css styles to any lovelace card

This is great,

I wanted to add a power indicator under my light switch, and this is what I used.

Is there any way to bring a brightness slider into the mix?

notice I have two Entry lights I want to put the slider up to the first one. this possible?

image

  - entity: light.entry_87
    type: 'custom:multiple-entity-row'
    icon: 'mdi:lightbulb-outline'
    secondary_info: 
       attribute: "current_power_w" 
       unit: W
    styles:
    toggle: true
  - entity: light.entry_87
    icon: 'mdi:lightbulb-outline'
    toggle: true
    type: 'custom:slider-entity-row'

Or somehow add a fold entity to drop down a slider.

1 Like