💵 Lovelace: Personal Capital Plugin/Card

I’ve created a custom component for Personal Capital (US only, sorry) that grabs account details into sensors with an accompanying custom card to show the data on the frontend.

You can pick which categories you want to monitor in the component and each category in the card is expandable to view details on balances and when data was last refreshed. I hope to add more features over time, primarily to the card, but wanted to share my current progress. Enjoy!


  platform: personalcapital
  email: [email protected]
  password: 12345
  unit_of_measurement: CAD
    - investment
    - cash


  - url: /local/pc-card.js?v=0
    type: module
      - type: custom:pc-card
        title: Money

So this could be used to simulate being on an electricity meter? When you run out of cash all the lights turn off?

I don’t know how that would work

I don’t know how that would work

It’s probably best that it doesn’t :wink:

I was wondering if this model could support the Open Banking API, but it seems the API is only for use by "registered third parties’ which seems to rule out open source implementations.

Ah, I see. Yes, you need to be able to connect it first via Personal Capital service which is far from a complete list of all institutions.

Used this for a bit, but awhile ago it broke so I removed it. I am now reenabling it and for some reason can not get this darn custom card to work.Keep getting custom element doesn’t exist. PC is configured and works.
For the Lovelace config I have the pc-card.js saved in my /www. I tried changing the url in my LL config to /pc-card.js?v0.0.3, didn’t work.

In my Lovelace:

  - url: /local/pc-card.js?v=0
    type: module
  - type: custom:pc-card
    title: Money

am I missing something here?
are package.yaml required now? my other custom cards/plugins work without it

If you go to /local/pc-card.js do you see the file?

yes it is in my /www folder. config/www/pc-card.js

I copy and pasted newest raw text from GitHub to see if that was the issue, still didnt work. Maybe I am missing a step?


http://hassio.local:8123/local/pc-card.js?v=0:3:24 TypeError: undefined is not an object (evaluating 'Object.getPrototypeOf(customElements.get("hui-error-entity-row"))')

That code was removed in February. You likely need to clear your cache

ahhhhhhg. so simple. thank you!

1 Like

Possible to have the sensor history display more than one day of history?

It grabs whatever is available, so no

I don’t understand… (this is when I start pulling up other sensors and see the few I check all only show one days worth of statuses (I think I was thinking of the frequent changes in the weather plugin and didn’t think past that) )…Oh. I see now…

I’m pretty new to this whole ecosystem… but would something like Grafana be a possible solution? …I imagine there has to be a parallel somewhere… ie: if you wanted to track your energy consumption over time… or your network usage… lots of things have data that would be better reviewed through a larger scope… having an easy chart to look at might make it easier… progress becomes easier when you see the effect of previous efforts?

I totally misunderstood your initial question. The history of a sensor is dictated by the recorder and is by default set to 10 days.
That being said, when you look at a sensor via more-info, only the last 24 hours is shown. If you want to see more, look at the history panel or add a history-graph to your frontend and extend the hours:

That makes sense… it also sounds like something better left until I move my install from SD-based to SSD or HDD-based.

Thank you very much. (Bonus points for the answer that points back to HA in the larger sense.)

Has no one had an issue with not receiving the verification required to set up the plug in?

Sorry to dig up this old topic, but I’ve been trying to get this going all day. I added the code to my configuration yaml, and it worked great! Then a few hours later, I had to reboot for an unrelated project, and now this integration isn’t working anymore. Every entity disappeared. Any advice? I’ve tried uninstalling and reinstalling via HACS.

Probably the session token. I don’t use this anymore and don’t have any plans to debug it unfortunately should there be an issue due to time constraints.

Is this project pretty much dead now? I know PC now uses 2FA which I don’t think will work with your setup but could be wrong. From your last statement if sounds like this plugin is done?

2FA is not recent for PC if you mean sending the text message to validate. If there is something beyond that, I will likely not fix it as my component is dependent on a python module that is not really maintained anymore, I believe: https://github.com/haochi/personalcapital