Lovelace -problems

After just getting everything working, I upgraded
the two TP link switches no longer function LR lamp , and no input from the sensors
on the HS110 and the switches dont appear on the GUI, Imanaged to fix the darksky stuff
but I also have a load of unwanted icons on the GUI from the router which I dont want
can someone please pont me in the right direction to get it all working again and get rid of the unwanted incons on the GUI please.
configuration.yaml, all worked in previous release, now only the mqtt and climate. & sun

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 52.662
  longitude: -2.45
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 195
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here:
  time_zone: Europe/London
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend

# Enables the frontend

# Enables configuration UI

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:
  api_password: !secret api_password

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time

# View all events in a logbook

# Enables a map showing the location of tracked devices
#Track the moon
# Track the sun
# Weather 
# - platform: metoffice
#   api_key: !secret met_office_api_key
  port: 1883
  client_id: home-assistant
  keepalive: 60
  username: None
  password: None
#IOT4SH01DS temperature MQTT topic
  - platform: moon
  - platform: mqtt
    state_topic: "/iot4/IOT4SH01DS_A03625/temperature"
    name: "Hot Water Temp"
    unit_of_measurement: "C"

  - platform: darksky
    api_key: !secret darksky_api_key
    units:  auto
#    update_interval: '00:15'
    scan_interval: '00:10'
      - summary
      - precip_type
      - precip_probability
      - temperature
      - humidity
      - precip_intensity
      - wind_speed
      - pressure
      - wind_bearing
      - cloud_cover
# Shack power TP Link HS110

  - platform: template
        value_template: '{{ states.switch.shack_power.attributes["current_power_w"] | replace(" W", "") | float }}'    
        unit_of_measurement: 'W'
        value_template: '{{ states.switch.shack_power.attributes["voltage"] | replace(" V", "") | float }}'
        unit_of_measurement: 'V'   

#    state_topic: "/iot4/IOT4SH01DS_A03625/temperature"
# Switches
  - platform: tplink
    name: LR Lamp
  - platform: tplink
    name: Shack_power
  - platform: mqtt
    name: Hot Water Boiler
    state_topic: "/iot4/IOT4SH01RELAY_D341DE/relay/0"
    command_topic: "/iot4/IOT4SH01RELAY_D341DE/relay/0/set"
    payload_on: "1"
    payload_off: "0"
  - platform: mqtt
    name: Evilbox1
    state_topic: "stat/evilbox1/POWER"
    command_topic: "cmnd/evilbox1/POWER"
    payload_on: "ON"
    payload_off: "OFF"
  - platform: mqtt
    name: Evilbox2
    state_topic: "stat/evilbox2/POWER"
    command_topic: "cmnd/evilbox2/POWER"
    payload_on: "ON"
    payload_off: "OFF"

#    optimistic: true
# Text to speech
  - platform: google

# Cloud
#http section

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

what version were you on before and what version are you on now?

I was on 0.73, I’m now on 0.92 udated at 1400 UTC today, if I knew where on the GUI I could find the exact release number, i’d let you know, but I’ve been reading all I can find and there was an update release yesterday
I’ve clean up the addition stuff on the gui , but none of the tplink devices are functional or show on the gui

I’ve just found this in the syslog

Apr  9 19:05:28 odroid hass[660]: TypeError: An asyncio.Future, a coroutine or an awaitable is required
Apr  9 19:05:28 odroid hass[660]: 2019-04-09 19:05:22 INFO (MainThread) [homeassistant.components.switch] Setting up switch.tplink
Apr  9 19:05:28 odroid hass[660]: 2019-04-09 19:05:22 WARNING (MainThread) [homeassistant.components.tplink.switch] Loading as a platform is no longer supported, convert
 to use the tplink component.
Apr  9 19:05:28 odroid hass[660]: 2019-04-09 19:05:22 ERROR (MainThread) [homeassistant.components.switch] Error while setting up platform tplink

so whats the tplink component ??


You should try reading the documentation. It changed sometime between your old version and the new version.

menu button, click the i in the circle icon, it gives you a info page.

Ouch that is a large version jump. You might need to read up on the changes as there have been many, but I really mean a lot. Especially version 0.89/0.90 which broke a lot.

If you have a light setup (with only a few devices) I’d maybe recommend starting from scratch. However if you have a large setup like I do, you will have to read up on the changes as many things don’t work the way they used to do. Many configurations have changed.

Not the most ideal choices but honestly I don’t think it is going to be easy. It took me 3 days to fix stuff going from 0.88 to 0.89 and that is only a single version jump.

have you read the release notes, specifically the “breaking changes” section, for every release between your old version and your new version? and then taken the steps to update your config to be in line with those changes?

I’m sure I know the answer to those questions so they are generally rhetorical but it will hopefully lead you to the answers you need and it might even help you help yourself in the future.

I’m as guilty as most when upgrading, like trusting an upgrade wont breake anything then reading release note and configs when I find it is
the /components/tplink/ page is NOT intuitive
I’ve ammended the tp link sectio so far to

  discovery: false
    - host:
      name: LR Lamp
    - host:
      name: Shack_power 

But the name is not accepted, and no hints where on that page
the error that gives is

Invalid config for [tplink]: [name] is an invalid option for [tplink]. Check: tplink->tplink->switch->0->name. (See /home/odroid/.homeassistant/configuration.yaml, line 109). Please check the docs at

I’m very aware I considered a damn nuisense at the moment, but we all have to start somewhere.
so as its NOT on the page listed how do you now set the name of the device , I can probably sort out the sensor data from the examples on that page

Remove the name, the TP link documentation doesn’t show “name” anywhere. If you want to give it a friendly name afterwards you can do this with customize.yaml

So “name” is probably not a supported line so removing it should fix it. Btw it might have worked in the past as Home Assistant was more forgiving on errors (or the component has changed overall). It is more strict on errors now so you will need to remove the unsupported lines. Good luck.

Aside from your issues with TP-Link, my guess is that the changes to your GUI are a result of Lovelace becoming the default UI as of 0.86. I’m assuming you were using the States UI before that. So you’ll need to rebuild your UI to work with Lovelace.

I’ll say as well that using configuration.yaml for TP-Link is totally optional now. You can remove that section of configuration.yaml completely and use the TP-Link integration from configuration instead.

This can take some getting used to, but upgrading Home Assistant is definitely not like upgrading most other software. I’d definitely recommend upgrading more frequently in the future, and reading through the release notes for any breaking changes that impact you. It can seem like an annoying but will save you a lot of headaches. Also, if you use, the Check Home Assistant configuration add-in is highly recommended pre-upgrade.

Thanks Jim
Thats now giving sensor data now from the HS110
but neither of the 2 TP link switches shown.

Apop , I’ve manage to clear up the mass of upnp devices that appeared when my router was seen.
i’ll hang on to the optional at the moment until I find my feet again. other points noted , it was only a gap of about 6 months.
It did take three attemps to get the odroid xu4 to upgrade, it wasn’t happty with one of the downloads, thats now fixed so it should upgrade without further problems.

that’s almost a lifetime in HA terms.

You have to consider that there is the very likely possibility that everything in HA is subject to breaking on every update. So you have to read the breaking changes.

and with recent changes to the way breaking changes are documented it’s way easier to figure out what needs changed in your config to fix those breaking changes.

By default in 0.86 release, Lovelace became the default. It migrated all the States UI over to Lovelace. There is nothing to “rebuild”

Thanks for clarifying. I was already using Lovelace prior to 0.86 and I forgot it attempted to auto-migrate. @richard-g8jvm I bet the extra icons from the router came from Upnp/IGD auto-discovery then, I think that integration was added around 0.80.

Totally. And since he hasn’t taken control of his Lovelace yet, I’m sure, it just defaults to adding everything to the frontend.

yes everything is dumped in the front end, but what is very important is access to the switches
both of which are the tp link ones , that gets used to switch on lights when we aren;t at home.
Or if we are out and just wanto make it look if someone is in. at the moment from the android app there is no access to those switches, only the mqtt switches.
I can switch them from the Ui after going to integrations, , no acess to integrations on the android app :frowning: ,where as before they where at the front end, I’ve tried as much as I can find in customisation to get them to the front end, but so far no success. I can use the Kasa app to switch then , but it seem daft to have one app for some switches and another for the remainder.
The problem I’m finding with the documentation is its written for those who already know whats in the documentation.
All I want on the front end is sensor and switch control, which will appear on the android app

When you refer to “the android app” are you referencing a third-party native app such as Ariela, or are you using Home Assistant with a home screen shortcut? If it’s the latter, you should have access to everything you have from the web view.

If your TP-Link switches are visible in the Integrations section, you should be able to bring them into the frontend if they’re not there already. Try clicking the three dots in the upper right corner and going to unused entities to see if they’re in there. If so, you should be able to add them to your Lovelace configuration to get them to show up where you want them.

Its the link to the desktop, and I’ll try what you suggested