🌻 Lovelace UI • Minimalist

I’m struggling with the same issue. I would like get a popup when holding a light entity on the Room card. I’ve tried use the custom popup as you did. I also tried to copy the Fire-dom-event from the popup template. Without any luck.

Any ideas?

iam trying to create card with this code:
service: google_assistant_sdk.send_text_command
data:
command: “message: turn on bedroom heater”

can someone help me how to just put it into Just on\off button card? I don’t succeed to make from it a card

heya! I’m not much of an expert but I think you need to remove the “message:” part and just leave the command “turn on bedrom heater”.

Also, check the Google Assistant SDK integration page: Google Assistant SDK - Home Assistant

Later edit, maybe give this a go:

type: button
name: Heater ON
show_state: true
tap_action:
  action: call-service
  service: google_assistant_sdk.send_text_command
  data:
    command: "turn on bedroom heater"

Figured it out.

The entities on the room card get the standard elements of tap_action passed. Implemented elements as per custom:button_card and the implementation in the room card are:

    action: "[[[ return variables?.tap_action?.action ? variables.tap_action.action : 'none'; ]]]"
    entity: "[[[ return variables.tap_action.entity; ]]]"
    navigation_path: "[[[ return variables.tap_action.navigation_path; ]]]"
    url_path: "[[[ return variables.tap_action.url_path; ]]]"
    service: "[[[ return variables.tap_action.service; ]]]"
    service_data: "[[[ return variables.tap_action.service_data; ]]]"

The browser_mod requires a few different elements, browser_mod and data.
As these are not implemented, the tap_action doesn’t do anything.

In card_room.yaml these lines need to be added under widget_icon_room tap_action and hold_action
End result is then like this:

  tap_action:
    action: "[[[ return variables?.tap_action?.action ? variables.tap_action.action : 'none'; ]]]"
    entity: "[[[ return variables.tap_action.entity; ]]]"
    navigation_path: "[[[ return variables.tap_action.navigation_path; ]]]"
    url_path: "[[[ return variables.tap_action.url_path; ]]]"
    browser_mod: "[[[ return variables.tap_action.browser_mod; ]]]"
    service: "[[[ return variables.tap_action.service; ]]]"
    service_data: "[[[ return variables.tap_action.service_data; ]]]"
    data: "[[[ return variables.tap_action.data; ]]]"
  hold_action:
    action: "[[[ return variables?.hold_action?.action ? variables.hold_action.action : 'none'; ]]]"
    entity: "[[[ return variables.hold_action.entity; ]]]"
    navigation_path: "[[[ return variables.hold_action.navigation_path; ]]]"
    url_path: "[[[ return variables.hold_action.url_path; ]]]"
    browser_mod: "[[[ return variables.hold_action.browser_mod; ]]]"
    service: "[[[ return variables.hold_action.service; ]]]"
    service_data: "[[[ return variables.hold_action.service_data; ]]]"
    data: "[[[ return variables.hold_action.data; ]]]"

It works for me, not sure if it works in all situations.
I’ll see if I can create a pull request for this.

1 Like

working thanks! :crown:
how can I change the picture?
how can I make get indication if its on or off like in google home?

I am getting a strange bug on ios (both app and browser) when using minimalist and slide-card.

It seems that all the cards on top of the main card are blocking the swipe. If you manage to swipe on the main card (by swiping the edges) it works. But not if you try to swipe from any other the other cards. I have added a screenshot below with the theme turned off so you know what mean by bottom card and top cards but it doesnt work even with the theme turned on.

It works fine on PC even with the browser set to mobile mode. Any idea what might be causing this or is it just an iOS bug I have to live with?

I’m sure someone will solve it in the future, but for now, there does not seem to be a way of creating “sticky” cards.

I found that buttons tend to block the swipe function. Hence, you have to swipe outside the clickable area

Hi guys, I have the following card which I’m trying to add to my Dashboard, but I’m getting an error Button-card template ‘card_room’ is missing!

type: custom:button-card
template:
  - card_room
  - red_no_state
name: Bathroom
entity: light.bathroom
icon: mdi:shower-head
tap_action:
  action: navigate
  navigation_path: /ui-lovelace-minimalist/bathroom
variables:
  label_use_temperature: false
  label_use_brightness: true
  entity_1:
    entity_id: light.bathroom
    templates:
      - yellow_on
    tap_action:
      action: toggle
  entity_2:
    entity_id: binary_sensor.badkamer_motion_sensor
    templates:
      - blue_on
    tap_action:
      action: none
  entity_3:
    entity_id: input_boolean.badkamer_motionsensor_enabled
    templates:
      - green_on
      - red_off
    tap_action:
      action: toggle
  entity_4:
    entity_id: input_boolean.bath_mode
    templates:
      - pink_on
    tap_action:
      action: toggle

I have the card room HACS fronted and I did a hard refresh with cache removal, still appears.

thanks, this work for me!

Hey, i am getting a strange bug with every Pop Up on my Phone (S22+). There is always a small gap on top, so some of the informations or buttons are not fully shown. On my wifes phone everything looks good (S21 Ultra).

Didn´t know if this has something to do with UI, Browser Mod, Phone or whatever. uninstalling, reinstall, clear cache and data of the HA Companion App didn´t work. Any Ideas?

Hey all,

I’m trying to get my room cards straight and need some help

This is the code:

type: custom:room-card
template:
  - card_room
  - red_no_state
name: Bathroom
entity: light.bathroom
icon: mdi:shower-head
show_icon: true
tap_action:
  action: navigate
  navigation_path: /ui-lovelace-minimalist/bathroom
variables:
  label_use_temperature: false
  label_use_brightness: true
  entity_1:
    entity_id: light.bathroom
    templates:
      - yellow_on
    tap_action:
      action: toggle
  entity_2:
    entity_id: binary_sensor.badkamer_motion_sensor
    templates:
      - blue_on
    tap_action:
      action: none
  entity_3:
    entity_id: input_boolean.badkamer_motionsensor_enabled
    templates:
      - green_on
      - red_off
    tap_action:
      action: toggle
  entity_4:
    entity_id: input_boolean.bath_mode
    templates:
      - pink_on
    tap_action:
      action: toggle

The card should look like this:
https://ui-lovelace-minimalist.github.io/UI/usage/cards/card_room/#usage

and the actual card I have created looks like that:
image

What am I missing here?

Do you have a minimalist theme selected?

Does anyone know how to switch the room card to just toggle when pressed? instead of navigating to a path?

I tried switching

            template:
              - card_room
              - blue_no_state
            name: Kitchen
            entity: light.kitchen_lights
            icon: mdi:countertop-outline
            entity_id: light.kitchen_lights
            tap_action:
              action: toggle
            variables:
              label_use_temperature: false
              label_use_brightness: true

to toggle but had no success.

how can i build the Chips, there give me Infos like “2 Window” open or “3 Lights” on?
You can see this is on the image from @Lucas23

hi @anon36468094 can you show the code, for the chip_state_icon? Counter for Lights. Thanks!

I do have it.

Hi,

I think you are confusing some stuff with each other.

You should have the Minimalist integration installed for the minimalist room card to get the correct button_card_template and all of its nested templates.

Now you are using a different HACS plugin based on the YAML you’ve shared.

The correct code is also available on the link you posted, that code includes:

type: "custom:button-card"

Where you have tried it with a non minimalist plugin:

Also as mentioned by another user there is no Minimalist theme selected on your device based on the screenshot. That can give you some nasty effects even when you have setup the card correctly according the accompanied documentation :wink:

Hi,

Could anybody help on creating a card that looks like this (with the progress indication around the icon) ?

Mushroom Reminder

I thought he meant Frontend on the HACS, Okay I just installed the Minimalist Integration
Is there a way to select a Minimalist theme for a specific dashboard? because my other dashboard requires notics theme to be selected.

  - type: 'custom:button-card'
    template:
      - card_room
      - red_no_state
    name: Bathroom
    entity: light.bathroom
    icon: mdi:shower-head
    tap_action:
      action: navigate
      navigation_path: '/ui-lovelace-minimalist/bathroom'
    variables:
      label_use_temperature: false
      label_use_brightness: true
      entity_1:
        entity_id: light.bathroom
        templates:
          - yellow_on
        tap_action:
          action: toggle
      entity_2:
        entity_id: binary_sensor.badkamer_motion_sensor
        templates:
          - blue_on
        tap_action:
          action: none
      entity_3:
        entity_id: input_boolean.badkamer_motionsensor_enabled
        templates:
          - green_on
          - red_off
        tap_action:
          action: toggle
      entity_4:
        entity_id: input_boolean.bath_mode
        templates:
          - pink_on
        tap_action:
          action: toggle

Getting this error now -

I am trying to create a card like this one basically -
https://ui-lovelace-minimalist.github.io/UI/usage/cards/card_room/#default-card-options