🌻 Lovelace UI • Minimalist

hi Guys, Is there a way to hide the tapbar when scrolling and can you customize the tapbar as you wish? regards

Glad it worked! :smiley:
As for the picture, I assume you are referring to the button icon.
If so, you can enable the icon for it.

As for the state, it’s a bit tricky to explain given that I don’t know your current set-up.
This heater that you are controlling via Google Assistant SDK, is it in any way accessible in Home Assistant? If it’s a state only entity and can’t control it just add it to this button so you can see its state:

type: button
icon: "mdi:heat-wave"   #or whatever icon you like
entity: switch.your_heater_entity   #entity of the device you'd like to know the state
name: Heater ON
show_state: true
tap_action:
  action: call-service
  service: google_assistant_sdk.send_text_command
  data:
    command: "turn on bedroom heater"

New to the UI Minimalist project but already loving it!

I am wondering if I can change the decimal point into a comma for all the cards. I think some cards did display it like that but every card that uses a temperature (room card, graph card etc) use a point.
I have my profile settings set accordingly grafik
My “normal” Lovelace dashboard displays all the values as shown.

I assume I can edit the Template Code of the cards to replace the decimal point but I am just wondering if there is a central place I can change this.

Thanks for any help!

I’m trying to call a script from the script card but can’t seem to pass a variable:

- type: 'custom:button-card'
  template: card_script
  variables:
    ulm_card_script_title: 'VRT Nieuws'
    ulm_card_script_icon: 'mdi:radio'
  tap_action:
    action: call-service
    service: script.turn_on
    service_data:
      entity_id: script.play_news_on_speaker
      radio_speaker: “robby”

Specifically the radio_speaker variable. I get the following error:
Failed to call service script/turn_on. extra keys not allowed @ data['radiospeaker']

What is the correct way to pass an extra variable with this card?

Have you tried this instead?

  tap_action:
    action: call-service
    service: script.turn_on
    data:
      entity_id: script.play_news_on_speaker
      radio_speaker: “robby”

Example: I’ve got a main script, that I use - and use the data to specify the variables

speech_engine_female:
  sequence:
    - condition: state
      entity_id: group.family
      state: home
    - service: tts.cloud_say
      data_template:
        entity_id: "{{ who }}"
        message: "{{ message }}"
        cache: true
        language: nb-NO
        options:
          gender: female
husk_ta_ut_av_vaskemaskin_tts:
  sequence:
    - condition: state
      entity_id: group.family
      state: home
    - service: script.speech_engine_female
      data:
        who: media_player.kjokken
        message: !include include/tts/husk_ta_ut_av_vaskemaskin_tts.yaml

Hello,

how can you change the images on the scene card in such a way that a full screen is taken over from the scenes?
I
would like to control hue scenes there and take over the images of the scenes. these should then be displayed there as a full circle.

Thanks

Hi all,
I am using room card but cannot activate icons for cover (opened /closed)
where did I wrong?

    - type: "horizontal-stack"
      cards:
      - type: 'custom:button-card'
        template:
          - card_room
          - red_no_state
        name: Bagno piccolo
        entity: climate.termostato_bagno_piccolo_p1
        icon: mdi:shower-head
        tap_action:
          action: navigate
          navigation_path: '/ui-lovelace-minimalist/BagnoPiccolo'
        variables:
          label_use_temperature: true
          label_use_brightness: true
          entity_1:
            icon: mdi:lightbulb
            entity_id: switch.luci_bagno_piccolo
            templates:
              - yellow_on
            tap_action:
              action: toggle
          entity_2:
            entity_id: cover.tapparelle_bagno_piccolo
            templates:
              - blue_on
            tap_action:
              action: toggle

thanks

Hey all,
I have followed up step by step the tuto to install and create the first buttons etc and it works nicely on my laptop. However when I visualize the outcome on my mobile (android) all icons are black… what am I missing ?

Merci !

Make sure you are using the correct theme on your device under your settings

Argh!!! Newbee in action!!! Merci this solved it.

1 Like

I’m trying to make some cards of my own but it is frustratingly bad explained, or i just cant find it… Anyone wanna help??

how can i use the card_room with popup_thermostat?

First try:

- type: horizontal-stack
        cards:
          - type: 'custom:button-card'
            template:
              - ulm_translation_engine
              - card_room
              - grey_no_state
              - grey_on
              - grey_off
            name: Schlafzimmer
            entity: climate.schlafzimmer_dect301_1
            icon: mdi:bed-king
            hold_action:
              action: none
            tap_action:
              action: "fire-dom-event"
              browser_mod:
                service: "browser_mod.popup"
                data:
                  large: true
                  hide_header: true
                  content:
                    type: "custom:button-card"
                    template: "popup_thermostat_temperature"
                    entity: "[[[ return entity.entity_id ]]]"

This card is empty, how can i give him the right “entity: climate.schlafzimmer_dect301_1” ?

what you need?

1 Like

I want to make a card with a time bar that count down, that i also can toggle an entity with… I’ve managed to piece a little bit together by the cards there already…

---
custom_card_eric_countdown2:
  template:
    - "ulm_actions_card_overlay"
  variables:
    ulm_card_weather_backdrop: false
    ulm_card_weather_primary_info: "extrema"
    ulm_card_weather_secondary_info: "precipitation"
  show_icon: false
  show_name: false
  show_label: false
  styles:
    grid:
      - grid-template-areas: "'item1'"
      - grid-template-columns: "1fr"
      - grid-template-rows: "min-content"
      - row-gap: "12px"
    card:
      - border-radius: "var(--border-radius)"
      - box-shadow: "var(--box-shadow)"
      - padding: "0px"
  custom_fields:
    item1:
      card:
        type: "custom:timer-bar-card"
        entity: "timer.kaffebryggaren_timer"
        name: Kaffebryggaren stängs av om
        invert: true
        bar_width: calc(70% - 7em)
        bar_height: 60px
        bar_radius: 20px
        layout: full_row
        bar_foreground: '#89b3d7'
        bar_background: '#3c4b64'
        unit: minutes
        tap_action:
          action: call-service
          service: switch.toggle
          service_data:
            entity_id: switch.kaffebryggaren
        style: |
          ha-card {
            border-radius: 14px;
            box-shadow: none;
          }

Red is what I’ve used but it take up unnecessary space. Green is what the card looks like now (code above).
Bottom is what i want it to look like (excuse my amazing paint skills :wink:)…
countdown

So, for example, how do I learn how layouts work? Where do all the template for different things come from? Actions?
These thing, how should i know?

  styles:
    card:
      - border-radius: "var(--border-radius)"
      - box-shadow: "var(--box-shadow)"

check this:

2 Likes

This code is for custom:button-card. It allows to manage css styles for elements inside the card.
Styling may be done by using card-mod too (see a link in the post above). Card-mod is a plug-in which allows access to css styles of a card.
Custom button-card in general does not need using card-mod - it has its own functionality (see a code you posted).
What are css styles in general - google about it, search for “css tutorial” etc.

2 Likes

Hey, I have updated to the latest version of the room-card, before that I had colors on the icons depending on the state of the entity.
After updating I can’t see those colors anymore.

Raw Configuration:
http://pastie.org/p/4V0r1KQr15lPoTzwl9BEvA
Card:

Any idea how can I fix that?
Thanks!

Can you be more specific on what update you have installed? The card’s latest update is from at least 3 months ago. It seems like you are using an unsupported installation method based on the raw-configuration.

I don’t have anything in mind that I changed something on the Raw Configruation.
but when I run Watchman report I get those two errors that might be related to my issue:

 number.match                   | missing | custom_components/ui_lovelace_minimalist/lovelace/translatio |
|                                |         | ns/default.yaml:18,28                                        |
| climate.hvac                   | missing | custom_components/ui_lovelace_minimalist/lovelace/ulm_templa |
|                                |         | tes/popup_templates/popup_buttons/popup_button_airconditionn |
|                                |         | er.yaml:22                

How can I fix this?
Thanks!