Lovelace wont show mdi icons on load

Whenever I use mdi icons (set in configuration.yaml) they wont load in Lovelace (lamp tile ive been testing with) It just shows blank, other parts of the control shows, such as the dimmer part.
That is until I click the three-dot-icon or navigate to another tab and back.
Same behaviour on android app, iphone and computer browser.
Anyone seen this behaviour before?
If I remove the custom icons the default icons show as expected.

Where are you setting the icon? Also, realize that newer icons have not been incorporated in HA yet.

I set it in Customize.yaml

customize: !include customize.yaml
  icon: mdi:stairs

Also. the icons DO show up, after switched tab or click of the the dots icon. so it’s not a matter of the icons not being present at all.

can you provide a better description with screenshots? I have no idea what you’re talking about. I use custom icons everywhere and have no issues, that means you’re in a specific spot in the UI with a potential issue. What 3 dots are you talking about?

Here are first a screenshot of my startscreen with three non customized icons. They show as expected. And one customized, the one in the lower right corner.

As soon as I click any of the three-dot icons (ellipsis), or other stuff in the UI, the icon apprears.

BTW running version 1.06

Try clearing cache in your browser. I have seen that fix issues w/ icons for me.

Alright, that’s a light card but your editing a switch.

Not all things are adding up here. Are you configuring the correct element?

Also are you restarting after you edit the customize.yaml file? The only way the changes are live is if you edit the customization through the UI. If you edit via a text editor, you may need to restart.

Changes are live. Restart between every change and it’s clear that it has effect since if I remove the customization the light is shown as default icon.
Bad example with the switch since it’s actually a underlying light that is the thing showing. (sorry about that)
I’ve also tried to set the icon on the light-card it selfe but no change.

Browser cache has no effect. (also tested on three different devices.)

Thanks for all the commitment!

To clarify about the light card:

      - type: light
        entity: light.qubino_goap_zmnhsdx_din_dimmer_level
        name: Fasadbelysning
        icon: mdi:outdoor-lamp

I did this. But no change.

Yes, with that configuration, you’re only changing the icon for that individual card. The entity in this instance will always have the default icon.

Try changing the customization through the UI in the customization section. Override the icon there and it should behave the way you expect.

  1. Go to Configuration->Customizations
  2. Select light.qubino_goap_zmnhsdx_din_dimmer_level from the entity list. It will most likely display the Friendly name only in this list, not your entity_id.
  3. Click “Pick an attribute to override” and select icon
  4. Type the icon name you want to use, make sure it appears in the preview.
  5. Select Save when done.

Ok, Thanks.

I removed any remanence of icons in my current lovelace or customization file and restarted. Then I did the customization through the UI as you suggested.
Unfortunately the exact same behaviour occured. All non-customized icons show up and the one I customize are blank and then when I reload the UI.
As soon as i click another tab or simiiar the icon appears.

Must be an issue with 106. Works perfectly fine for me with the light card in 107.

Ill update and get back to this thread.
It has worked well before. But I did not react when it first occured so I dont know what change made the difference.
Thanks a lot!

1 Like

No problemo

Unfortunately updating to 107.7 did nothing to help the situation.
I guess Ill have to live without the customized icons.

You must be doing something wrong for this to work for me and not you. Have you cleared your cache as indicated by @mdezzi?

Yes, cleaned cache
And yes, something is obv wrong :slight_smile:

Removed manual lovelace file and started with a clean lovelace setting.
Managing through the webinterface this time.
Seems to do the trick.

weird. Not sure what was wrong then.