Lumi.switch.n0agl1 not working in ZHA

This Aqara Switch T1 should be supported, but only reveals a temperature sensor of 0.3°C.


Is there anything I can do to make it work?

Post logs for a start.

I have the Aqara Smart Plug (EU) that does exactly the same.
Shifts between 0.2 and 0.3 degrees.

When I check in Clusters, the value I get is “29”.

Could there perhaps be an error in (not) converting between Fahrenheit and Celsius?
0.3 degrees Celsius = 32.5 degress Fahrenheit.
29 is pretty close to 32.5.

Do you have an actual switch? Mine is missing. I only have this sensor available.

I have two of these

Both still work, but still with incorrect temperature.


I just bought this device and had the exact same problem: no switch found in HA, and only a weird temperature sensor.
Then I removed the device and paired it again, while pressing the button every second like explained here, and finally the switch entity appeared :slight_smile:


I ended up migrating to Zigbee2MQTT, which I like a lot.

Yes I am also back in Z2M, but good that it worked finally in ZHA.

Same issue here, with n0agl1 and ZHA.
Just strange temperature. No power meter and switch.

How is Zigbee2MQTT better? (I never tried, but would like to know if it’s worth migrating from ZHA)

I don’t know if it is the MQTT part or what, but compatibility just seems better with the devices I’ve tested.

I like the UI better too.

For me migrating was pretty easy (with around 20 devices), and worth it.

I have finaly found solution here:

  • downgrading Conbee II firmware from 26720700 to 26680700,
  • removing T1 device
  • restart HAS OS (not sure if this is necessary after fw downgrade)
  • add T1

… and have fully functional relay (except device temperature. Still 0.2) :smiley:

Hey guys

In using a sonoff zigbee 3.0 usb stick with the latest firmware and zha, latest home assistant firmware.

I keep getting the same issues as you guys trying to add a t1 switch with neutral (ssm-u01). Gets detected as a lumi without any functions but the broken 0.2 temp sensor.

Tried resetting and adding several times… but now I’m stuck with a useless switch

Can anyone help? Stuck in finding a solution to get my lights working as I only see a conbee solution and pressing the button while adding it to the ZigBee network doesn’t work aswell

Latest is not a version, nor is it easy to diagnose with no logs.


I am also using the Sonoff zigbee 3.0 usb stick and the lumi.switch.n0agl1 (two alternatives) and it is not fully operational.
I was able to manage to be able to switch off/on from HA, but when I turn on/off the phisical switch, then it is not triggering anything in HA. I guess it is using wrong cluster, I tried to debug in zha, but seemingly I have no idea how it is really working :slight_smile:
The device temperature seemingly working if you check the raw data.
Also if I ready the attribute after the physical switching, it is reading and updating the correct data in HA

Device temp:
Showing 0.2/0.3

I used this quirk for it:

Home Assistant 2022.11.3
Supervisor 2022.10.2
Operating System 9.3

Happy to provide any log.


I had the same problem initially. Your solution solved it for me too.
(Then I removed the device and paired it again, while pressing the button every second)
I am using ZHA with Home Assistant 2023.3.1

Update: the switch is working now but powermeter still does not :(.

You dont generally need to re-pair the device when you add a quirk. I’ve found that just restarting HA, or indeed, just restarting the ZHA integration is enough.

I came across this thread because I’m having the same problem, using a skyconnect and ZHA. I was hoping someone could help me get this working. I’m probably doing something wrong…

I have this in my configuration.yaml

  database_path: /config/zigbee.db
  enable_quirks: true
  custom_quirks_path: /config/custom_zha_quirks

I have a configuration file in the directory called and I copied the quirk from here and put it in the file.

I restarted HA and added the relay but I still just get a temperature sensor and an identify button.

What am I missing/doing wrong?