Lutron Caseta (non-pro) - Invalid Config

Not sure what happened, but Lutron Caseta (non-pro) is not loading anymore.

Any help?

2017-10-05 17:56:44 ERROR (MainThread) [homeassistant.setup] Error during setup of component lutron_caseta
Traceback (most recent call last):
  File "/usr/src/app/homeassistant/", line 194, in _async_setup_component
    component.setup, hass, processed_config)
  File "/usr/local/lib/python3.6/asyncio/", line 332, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/local/lib/python3.6/asyncio/", line 250, in _wakeup
  File "/usr/local/lib/python3.6/asyncio/", line 245, in result
    raise self._exception
  File "/usr/local/lib/python3.6/concurrent/futures/", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/app/homeassistant/components/", line 42, in setup
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 32, in __init__
  File "/usr/local/lib/python3.6/site-packages/pylutron_caseta/", line 274, in _login_ssh
    username=ssh_user, pkey=ssh_key)
  File "/usr/local/lib/python3.6/site-packages/paramiko/", line 416, in connect
    look_for_keys, gss_auth, gss_kex, gss_deleg_creds, t.gss_host,
  File "/usr/local/lib/python3.6/site-packages/paramiko/", line 701, in _auth
    raise saved_exception
  File "/usr/local/lib/python3.6/site-packages/paramiko/", line 603, in _auth
    self._transport.auth_publickey(username, pkey))
  File "/usr/local/lib/python3.6/site-packages/paramiko/", line 1447, in auth_publickey
    return self.auth_handler.wait_for_response(my_event)
  File "/usr/local/lib/python3.6/site-packages/paramiko/", line 223, in wait_for_response
    raise e
paramiko.ssh_exception.AuthenticationException: Authentication failed.

Likewise - reboot of my hassio box tonight shows the same, my guess is lutron did an update to their box. the ios app is totally different now, and i can confirm that it and homekit are working on my end, just not HASS

Same here, suddenly Caseta stops working today. Following is some other logs just before @a_ndy 's stack trace:

2017-10-06 03:08:51 INFO (MainThread) [homeassistant.setup] Setting up lutron_caseta
2017-10-06 03:08:58 INFO (Thread-3) [paramiko.transport] Connected (version 2.0, client OpenSSH_6.4)
2017-10-06 03:08:58 INFO (Thread-3) [paramiko.transport] Authentication (publickey) failed.

Restarted home assistant and Caseta bridge didn’t fix the issue.

Same here!

Is this happening to everyone or just a non Pro users? Mine messed up too

I have a pro hub and it’s not loading. I tried restarting home assistant and my pi, but no luck.

From what I can tell, its seems like there’s an issue with the SSH key? Not sure how to go about figuring that out.

Same problem here – actually just bought the non-pro hub and dimmers and was trying to set it up on hassio and got the same error.

As almost every light in my house is connected to a Caseta switch, my house lighting just became dumb overnight. I didn’t see any bug reports open for this yet, so I got one opened up.

1 Like

Thanks man! I should probably get a git account to file bug reports.

Just did a bit more digging on the problem.

Other platforms are running into the same issue:,35577.225.html

Yeah when looking at the OpenHab Platform they only allow the pro version for this very reason. With the pro version they are using the documented Telnet protocol.

im assuming anyone using the version from @jhn still has their lights working correctly.

Apr 104
First, for openHAB, you need a Smart Bridge Pro and not the Smart Bridge that you can pick up at your local big box store. The Pro model is an “installer” version that you’ll need to obtain elsewhere. They are available through other sellers.

There are three protocols that the Smart Bridge Pro “talks”:

Lutron Integration Protocol3 (LIP) over telnet
LEAP over ssh
Secure MQTT
The first is the only one available without a reverse-engineered or NDA-encumbered “secure” key as well as with a Lutron-published, public protocol spec. I don’t think anyone would sign-off on allowing that into openHAB.

Only LIP over telnet is fast enough to be considered “real time”. If you have a Smart Bridge Pro, you will need to enable it using the Advanced settings in your smart-phone app."

Hey guy’s. I have started a new topic under third part integrations. Basically I do not believe that it is safe to use the LEAP integration with HASS as this issues could always arise going forward. I really enjoyed working on this integration and am disappointed that the non-pro hubs will not work.

I recommend depreciating this component from hass here: Lutron Caseta - Leap SSH integration

Please share your thoughts on how to proceed. There is already a lot of other work in place to support lutron caseta. We just need it supported officially.

Found something on,35577.210.html :

The latest firmware and Mobile App update (October 5, 2017) for the Lutron Caseta SmartBridge controllers is more than just a key change.

This “upgrade” is a redesign to allow the mobile app to work with the “RadioRa2 Select” main repeater. The Caseta firmware update changes the operation of the Caseta SmartBridge to be more like the RadioRa2 hardware.

To summarize the changes:

  1. The Leap SSH server (which allows use of the non-pro SmartBridge devices) has been given a new RSA key. The new mobile app no longer uses the leap server, so a working RSA key is not embedded in the Mobile App, and the server is effectively unusable.

  2. A new LEAP server has been implemented as an HTTP over TLS server using a custom self-signed RSA keypair. The mechanism that has been implemented is such that each individual device running the Mobile App obtains its own individual unique RSA Keypair.

  3. The LIP telnet server is unchanged, so use of a pro model SmartBridge is still possible.