Lutron Radio RA2 integration not working

Hi Home Assistant Community!
I am not new to home automation, but new to Home Assistant.
I installed HA Supervised on my proxmox server using a script from whiskerz007
Everything seems to work fine, I am able to add integrations for devices I have, such as my ELK M1
HA also located two AV receivers I have that have chromecast built in and a canon printer.
It did not locate my Radio RA2 system, and after I manually added the lutron integration to the configuration.yaml file I am getting a notification about invalid configuration:

The following integrations and platforms could not be set up:
* [lutron](
Please check your config.

I tried the configuration both with the default username:lutron/password:integration as well as with a dedicated username/password to no avail.
I can access the RA2 main repeater via telnet without a problem using the previously mentioned credentials.
The HA configuration check states that my config file is valid.
Any suggestions how to troubleshoot this integration?

I am sorry to reply to my own post, but here is what I found in the home-assistant.log:
My RA2 install works find, not sure why HA finds duplicate integration IDs…
Perhaps it helps someone to suggest how to further troubleshoot

2020-06-18 22:24:48 WARNING (MainThread) [homeassistant.setup] Setup of lutron is taking over 10 seconds.
2020-06-18 22:25:06 INFO (SyncWorker_4) [pylutron] Loaded xml db from repeater
2020-06-18 22:25:06 ERROR (MainThread) [homeassistant.setup] Error during setup of component lutron
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 190, in _async_setup_component
    result = await asyncio.wait_for(task, SLOW_SETUP_MAX_WAIT)
  File "/usr/local/lib/python3.7/asyncio/", line 442, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/lutron/", line 56, in setup[LUTRON_CONTROLLER].load_xml_db()
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 461, in load_xml_db
    assert(parser.parse())     # throw our own exception
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 223, in parse
    area = self._parse_area(area_xml)
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 261, in _parse_area
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 1140, in add_sensor
    self._occupancy_group = OccupancyGroup(self._lutron, self)
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 1060, in __init__
    self._lutron.register_id(OccupancyGroup._CMD_TYPE, self)
  File "/usr/local/lib/python3.7/site-packages/pylutron/", line 393, in register_id
    raise IntegrationIdExistsError

So this thread did not get a lot of feedback, but recently was able to solve the issue. Replying again to wrap it up and mark it solved.
Also think that found a bug in the lutron library, which I will file later.

My RA2 system is rather large (150+ device/entities) and is integrated with my ELK M1. Given that in RA2 rooms and zones also get an integration ID, in the configuration software one can uncheck certain rooms, zones or even devices to be excluded from integrations to reduce the overall number of integration IDs. This helps also with ELK to not exceed the number of lighting devices that can be handled by ELK.

Rooms, zones and devices that are unchecked from integration show up for HA with ID “0” and appear to be more than one device with ID “0” This confuses HA which expects that RA2 integration IDs are unique and the autoconfig stops.

For me to solution was to mark all my devices for integration in RA2 software after which HA configuration work as expected.
The bug in the HA lutron library is probably that integration id “0” should be ignored.

1 Like

Hey there Ileo. I’m having a similar issue as you did. A bit of background:

House 1: RadioRa2 w/ 150+ devices. HA configured w/ main repeater IP and lutron/integration and works fine. All devices show up and can be controlled from HA.

House 2: RadioRa2 w/ 150+ devices. HA configured identically as in House 1. However, my logs are full of trash like this:
Logger: pylutron
Source: /usr/local/lib/python3.8/site-packages/pylutron/
First occurred: 2:39:41 PM (3988 occurrences)
Last logged: 2:42:06 PM

The ONLY difference between House 1 and House 2 is that house 1 uses the URC platform for television/media control through 2 onkyo type receivers and house 2 uses the Control 4 system.

Do you think that my A/V guys set it up similar to your ELK instance where some Lutron devices get the “0” ID? Where did you change that ID, in the RadioRa2 software? Do you have a copy w/ login creds you can share as typically you need to take a class to get the RR2 software (and I’m not an employee of an A/V integrator!)

thanks in advance for your reply!

Edit: I’m able to mess around w/ my config.yaml to get HA to SEE all the Lutron devices and display them via the native lovelace interface, but when I activate a switch (to turn on a light) the switch flips to ‘on’ and then a few seconds later, switches back to ‘off’ in the HA interface. The command is never executed by the RR2 system (the light doesn’t turn on)

@Debo did you ever fix this? Im having the same issue

Did you ever fix this?

I am also having the same issue. All the switches and scenes have been populated in HA but when you try to turn on/off nothing occurs.

I did. Turns out the integration username and password changed from
Defaults. I’d check that

Hey, I just finally resolved my issue thanks to this thread based on what @lleo explained:
> For me to solution was to mark all my devices for integration in RA2 software after which HA configuration work as expected.

I just wanted to respond and restate it for anyone else perhaps having this same niche issue because I read it several times before it sank in was able to apply the information to fix my problem. There is definitely a bug here.

So to be as explicit as possible, I’m using RadioRA 2 Inclusive Version 12.10.0 desktop software. In the Settings menu, choose Integration (or press Ctrl+I). That pulls up an Integration Settings window with two tabs. One for Telnet Logins, and one for IDs. Switch to the IDs tab, and check the box at the top of the list of all your devices :ballot_box_with_check: Enable For Integration. This would otherwise seem like a bad idea because I didn’t really want EVERY-thing, including the rooms and a bunch of devices which I haven’t setup yet to be brought over to Home Assistant via the integration. But, this allows the integration to connect.

After enabling 100% of all your Lutron devices to be included in the integration. Do another transfer to the repeater and you should be able to connect.

BTW, you need to specify a home assistant user and password on that Telnet Logins tab, it seems like the default u/p of u: lutron / p: integration doesn’t work either.