Make a dumb doorbell smart with Shelly 1

@time, @Troon thanks for the pictures and comments :+1:
I have updated the picture in the OP to make the connection to the transformer more clear.

I also noticed the same issue that the automation was not triggered on a very short press when the trigger in the automation is set on the entity for the shelly switch. This is solved by using MQTT, I use the automation below.

It will only trigger if the previous trigger was more than 5 seconds ago.

alias: Doorbell push notifcation
description: ''
trigger:
  - platform: mqtt
    topic: shellies/doorbell/input/0
    payload: '1'
condition:
  - condition: template
    value_template: >-
      {{ (as_timestamp(now()) -
      as_timestamp(states.automation.doorbell_notification.attributes.last_triggered
      | default(0)) | int > 5)}}
action:
  - choose:
      - conditions:
          - condition: state
            entity_id: switch.doorbell_chime
            state: 'off'
        sequence:
          - service: notify.notify
            data:
              message: Someone at the door (chime off)
              title: Doorbell
              data:
                ttl: 0
                priority: high
                color: red
    default:
      - service: notify.notify
        data:
          message: Someone at the door (chime on)
          title: Doorbell
          data:
            ttl: 0
            priority: high
            color: green
3 Likes

Hey guys! I have an Bticino Linea 2000 + Bticino Pivot Video.

I have found this two guides on how to install them:


Sadly, I can’t figure out how to install a shelly on them.

I’ve came up with the following, but have no idea if this is okay… My transfo is 12v, so I think that’s okay to power the shelly?

Thanks for sharing this. If you have MQTT enabled than this is an easier solution than the one I use with an external PHP page which calls the HA API. So I have switched to the MQTT solution :slight_smile: I have added your post to the OP.

The connection is bad. Take a look at the pictures I inserted above.
1 - transformer 230V AC / 12V AC will not work (Shelly 12V DC or 24-60V DC)
You must use a 230V AC / 12V DC power supply for Shelly
2 - Shelly (0 - I)is only a switch and in your connection you have brought one transformer wire to the bell and the same wire to the bell via the Shelly contact

Thanks for your answer! With your comment in mind and reading more, I have come to this setup:

Do not attempt to connect without electrical knowledge as this can never work.
You are trying to connect an intercom and this thread is about connecting a normal doorbell that rings when voltage is applied.
What do you want your home phone to do?

Thank you for inspiring me to do this… I had on my hand 14V AC powered doorbell, that made it more easy for me.
Here is my outtake:

Hi,

How exactly do i silent the chime at a certain time? Or in my case, when my kids bedroom door is closed.
I can’t figure it out in automations…

Thanks

See first post

switch:
  - platform: rest
    name: shelly_doorbell_chime_status
    resource: http://192.168.1.187/settings/relay/0
    body_on: 'btn_type=toggle'
    body_off: 'btn_type=detached'
    is_on_template: '{{ value_json.btn_type == "toggle" }}'

And then switch.turn_off or on this switch

I don’t see this “switch” in my entities after adding it to my config.yaml

Restarted HA? Error in the log? IP adjusted to yours? Shelly PW protected?

Got it working, my Shelly interface was protected with a password.

switch:
  - platform: rest
    name: shelly_doorbell_chime_status
    resource: http://192.168.1.187/settings/relay/0
    body_on: 'btn_type=toggle'
    body_off: 'btn_type=detached'
    is_on_template: '{{ value_json.btn_type == "toggle" }}'
    username:
    password:

@gerard33

Okay. I Sorted it out. I was using the standard Shelly integration. I have now changed all the “time essential” shellies over to MQTT, and there is now very little latency. I’m a happy man!

1 Like

Hi all,

I’ve been trying to replicate this with my home doorbell but I’m not having much luck.

A couple of questions:

I’m using a 12v DC light supply I got from Screwfix The shelly seems to come up fine with and I can access the web UI, but I don’t seem to be receiving any power at the button when I test with my multi meter.

I’m wondering if this is an issue with the power supply or my existing door bell button?

My current doorbell button is an old style illuminated one with a bulb the shape of a fuse (something like this with a bulb similar to this).

Would you expect this button/bulb combo to work with 12v DC?

Finally, I can ring the chime from the shelly web ui but I need to turn it on for the ding then off for the dong - is that to be expected?

Below is how I’ve got it wired

Many thanks!

Got it sorted in the end. The problem was the bulb in the switch. After removing it, everything works as expected!

@gerard33: how did you manage to make it open up an external php page?

That can be set in the webpage of the Shelly device.

Thanks for your reply. I’m hosting a PHP server externally which uses https, that might be the issue. In the meantime tried a different approach and installed HA on my raspberry. There I created an automation setup that makes HA send me a push notification when the doorbell is triggered.

Hi all,
Thanks for this great article!
Installed shelly1 successfully in HA 5.3.3. I am struggling making the doorbell mutable. I get the following error: “No route to resource/endpoint: http://MY_IP/settings/relay/0”. The switch button / entitiy is not visible in HA.

My switch button:
switch:

  • platform: rest
    name: doorbell_muteable
    resource: http://MY_IP/settings/relay/0
    body_on: ‘btn_type=toggle’
    body_off: ‘btn_type=detached’
    is_on_template: ‘{{value_json.btn_type==“toggle”}}’
    username: “MY_USERNAME”
    password: “MY_PASSWORD”

Could someone please assist? Thanks a lot!