Marthoc Deconz addon can't connect lights

I can’t get deconz to pair with any of my (freshly reset) devices. I’ve tried hue bulbs, Ikea bulbs, sengled bulbs, a lutron remote, and an ikea remote less than an inch from my pi without success. I’m using stock on a raspberry pi 3 with the deconz addon from and a newly purchased raspbee. I’ve tried both the PWA interface as well as the “older” dark web interface The raspbee is lit solid red (which is supposed to indicate connected). ‘hassio hardware info’ reports:

    "result": "ok",
    "data": {
        "serial": [
        "input": [],
        "disk": [],
        "gpio": [
        "audio": {
            "0": {
                "name": "bcm2835 - bcm2835 ALSA",
                "type": "ALSA",
                "devices": {
                    "0": "digital audio playback",
                    "1": "digital audio playback"

At this point, all I can think of is that I missed some step in setting up the addon and deconz isn’t seeing my raspbee but I have no clue how to tell. I do see log entries like this every 10 minutes though so maybe it is connecting to the raspbee:

22:51:54:359 dev /dev/ttyAMA0

@marthocoo Im seeing a lot of people having issues lately, are there issues with the new deconz version?

I’m also having trouble, see

1 Like

@teachingbirds I saw your post and almost commented on it but didn’t want to derail your question if the solutions were different. The symptoms that I’m seeing are pretty much identical though.

Just wanted to let you know you weren’t alone! :slight_smile: I found that an extension USB cable did the trick for me, as you can see in my post

@teachingbirds There isn’t a lot I can do on that front as I’m using a raspbee instead of a conbee.

Oh, that’s true. Do you have wifi turned on and/or do you have the router close to your pi? I think it’s the wifi that is causing disturbance for me.

I do have wifi on as it’s how I connect to my pi. I’ll try changing the wifi channel when I get home tonight. Do you know what zigbee channel your conbee is on? In the admin settings towards the bottom mine shows channel 0 which isn’t a valid channel so my issue may be more than just network interference.

Have you disabled bt on your pi?

Mine is 15. You can also change Zigbee channel via the api I think.

Ding ding ding! @Robban is the winner. It turns out that in resinos (which hassio is currently based off of) bluetooth and the raspbee both use the same /dev/ttyAMA0 device. Disabling bluetooth did the trick. I’m betting that this will be resolved with the new hassio os.

@marthocoo this should probably be noted in the readme for the hassio addon.

Seems like deCONZ Docker issues have been cropping up lately! Definitely a sign that I need to update the FAQ on the main repo and the add-on because as far as I can tell, there haven’t been any changes to deCONZ that would cause any issue that’s been raised.

To be clear for anyone else reading this topic:

  1. If your Conbee/RaspBee hardware isn’t getting assigned a channel (you can see this in the container logs very soon after the container/add-on starts up) then deCONZ can’t find the hardware. This means that adding lights, etc. just won’t work. This problem shouldn’t happen with Conbee on any hardware, but will happen with RaspBee if you’ve not disabled Bluetooth on your Pi. This happens because the Pi assigns the BT hardware /dev/ttyAMA0, which is the same device name deCONZ expects to find RaspBee at; RaspBee instead gets assigned /dev/ttyS0. To enable the serial port and disable Bluetooth, add the following lines to the bottom of your config.txt found on the boot partition of your SD card:

And as one user has reported, you must include a blank line at the end of that config.txt file or BT may not disable properly.

  1. As @teachingbirds experienced, it appears that the Conbee can be sensitive to interference. An interference problem can manifest as deCONZ appearing to find the Conbee hardware but being unable to find or control ZigBee devices. Either a usb extension cable to put some distance between the PC and Conbee or changing the Conbee’s ZigBee channel (or both) can help.

  2. Due to some Docker limitations, you cannot update the Conbee or RaspBee firmware from the deCONZ web interfaces (Wireless Light Control and Phoscon). The web ui will notify you that an update is available, but clicking the update button will have no effect (the firmware update will fail and the hardware will stay at the same firmware level). To update the Conbee or RaspBee firmware, you can instead use a firmware flashing script that I wrote and included in the Docker images, though the instructions vary slightly depending on if you’re using or not.

docker run -it --rm --device=/dev/ttyUSB0 --privileged --cap-add=ALL -v /lib/modules:/lib/modules --entrypoint "/" marthoc/hassio-addon-deconz-armhf

/dev/ttyUSB0 is the name your device has been assigned (/dev/ttyAMA0 for RaspBee).

marthoc/hassio-addon-deconz-armhf or marthoc/hassio-addon-deconz-amd64 to match the platform you’re running on (Raspberry Pi = armhf; other platforms = amd64).

  • Not
    You will need to log into your PC over SSH. Then, run the following commands (same for Conbee or RaspBee):
docker pull marthoc/deconz
docker run -it --rm --entrypoint "/" --privileged --cap-add=ALL -v /dev:/dev -v /lib/modules:/lib/modules -v /sys:/sys marthoc/deconz

I think that should cover all of the recent issues people seem to have been having. I’ll update the FAQ’s on GitHub and for the add-on soon. As an aside, I just pushed 2.05.30 and the Docker images are currently building. They (and the update to the addon) should be available in 5 minutes or so!


Great summation @marthocoo

Hello. I tried to use Docker image and faced with same problem, but described solution doesn’t help. Even more, after I revent everything as it was (Raspbee on separated RPi3, with official deCONZ raspbian image and no Docker), Raspbee stoped working… I’m able to scan lights and reset them but none of them (and none of sensors) are able to connect to it. I’ve tried re-flash firmware, tried different deCONZ images, tried different channels, nothing helps.
And there is nothing criminal in logs… really don’t know what’s going on.

Have you disabled bluetooth?

Yes, I tried both dtoverlay=pi3-disable-bt and dtoverlay=pi3-miniuart-bt-overlay (this remaps bluetooth to /dev/ttyS0, so-called “software serial” and brings UART back to /dev/ttyAMA0, such option is a default in official deCONZ image).

I think something happend with Raspbee itself, because after failure with Docker I made my setup exactly the same as it was (no Docker, clean official deCONZ image), but it doesn’t work now.

Could you please tell me your version of deCONZ and version of firmware?

Latest docker and fw available

Well ‘latest’ is very relative when we talking about deCONZ, because latest firmware, available on their website is 260b0500, but Phoscon app updates my Raspbee to 261f0500. Situation with deCONZ itself is the same: v. 2.05.24, but inside app I can upgrade to 2.05.31.

Well sure, it depends on what you’re talking about. But since I stated docker, that inherently gives fw as well :wink:

Regardless, the homepage only lists stable releases. In order to get most of the integrations that are interesting we need to run the beta. Which is what the docker holds. And the fw with it