Meater thermometer

Would really like to see this happen as well! (and a Traeger integration too :slight_smile: )

for suresies

I have done some work on the udp packet and now have my probes in Home Assistant. This does not use the Meater Cloud, but does still require wifi and setting up cooks on a phone.

Does it only work with block? or it would also work with a single probe?

Care to share the steps / components used to get it setup in HASS ?

I have added the hass setup in the repository now. The python code is currently written for a block, but could easily be modified for a Meater+. The packets from a Meater+ and the block for the probe parts will be the same I believe. I only have a block so I can’t test for a Meater+. This python code does not work for just bluetooth probes it needs the UDP packets over wifi.

Here is a new screenshot:

The badges:

1 Like

This is awesome!!! I am going to try to install it tomorrow in my HA!

what is needed to add this into HACS or HA Core?

Can someone point me to figuring out the next step of getting my Meater Block to communicate with my MQTT? I thought I saw instructions around here to set it up but I can’t find it now! @floyduww I am trying to follow your GitHub, but I don’t see how you have them linked, just the info for the sensors and the card.

Set MQTT.HOSTNAME to your mqtt server hostname or IP, then once running you will see the mqtt topics listed in the Readme showing up. I used the mqtt integration to get it into home asssistanat .

I’m sorry, I am probably not explaining this correctly. I have my MQTT setup for HA, but in order to get it to talk to the Meater Block don’t I need to do something? I copied your sensor file into the config and have MQTT setup to talk with HA - but don’t I need to tell MQTT where to get data from for the Meater Block or tell the app to connect to the MQTT broker? Or add a custom-component that tells HA that info? I feel like there’s a step missing between the sensor file and Lovelace card that comes right before all that to start reading the info- I’m just not sure what it is. Sorry

In my code there is a spot that says MQTT.HOSTNAME, change that to your mqtt server/borker. It’s in the mqtt.connect line. This is one of the things I need to get out of the middle of the code and into a config file.

OH- are you saying you setup a new MQTT in the Config file and have it be the IP of the Meater Block?

Or are you saying you add this code somewhere in HA?

I’m sorry if I’m misunderstanding. I found the line you are talking about in this file but just not sure where these files go.

Do you have an MQTT server/broker setup? The MQTT integration is HA only subscribes to a server/broker, it is not one itself. Both my code and HA need to communicate through a common MQTT server. I personally run mosquito for this: .

Yes I run a broker already off the same Pi that I run HA on. I guess I’m confused where this file would go and how the Meater app or block knows how to talk to my current MQTT broker. Wouldn’t I need to set that up in the Meater app or somewhere? Plus add a custom-component or integration more than just the sensor file you shared?

The meater block broadcasts data over your network via UDP port 7878 whenever it is on. My code takes that and publishes it to mqtt. So just point my code to your mqtt server and your done. My python code does not go anywhere whithin HA, it is a standalone program that just interprets what the meater block is sending and resends it over mqtt.

Ah okay I am tracking now. What do you use to run the script or do you leave it running all the time? I guess you could trigger an ssh command from HA to run it?

at the moment I just run it when I am doing a cook. So I just run it from a console. I run it on a separate machine from my HA since my HA is run in a docker container.

1 Like

Hi Matchmee;
I have ssh commands been executed on remote machines from HA. You could change the command from bash to python and launch the script.

Here’s my config for a command executed remotely;


  monitor_15: ssh -o StrictHostKeyChecking=no -i /config/.ssh/serverpc [email protected] 'bash /media/maindrive/dir/'

2 very key things, I have ssh keys setup on the client (HA machine) and host (target machine) so I can log into the target machine from HA machine via SSH without password. That allows the shell commands to work.
Secondly, the publis ssh keys are located on the HA machine under /config/.ssh/serverpc (in my case). You have to manually put them there.
Let me know if you need more description