Media Player not working in 0.96.1 and 0.96.2?


Since the update to 0.96.1 and also 0.96.2 my Media Players no longer works and in fact they do not get installed.

I’m running on the Intel NUC image taken from:

I get this error in my log after I reboot:

Setup failed for media_player: No setup function defined.

I don’t know how I can fetch other logs beside the above.

My Media Player config looks as below (nothing has changed between the updates):

  - platform: samsungtv
    name: '[Living Room] Samsung TV'
    host: 192.168.x.x
    port: 8001
    timeout: 30
    mac: xx:xx:xx:xx:xx:xx
  - platform: denonavr
    host: 192.168.x.x
    name: Denon AVR-X4000
    show_all_sources: True
      - zone: Zone2
        name: Bath
      - zone: Zone3
        name: Kitchen

  - platform: spotify
    client_id: xxxxxxxxxxxxxxxxxxxx
    client_secret: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Beside my above configuration I do also have Google Home Mini’s plus a few Chromecasts. Those has always been autodetected under the Integrations under Google Cast. Those have also stopped working and states that they are unavailable.

Finally I noticed that under Services, that I can’t even find the service call when trying to search for the media_player.turn_on and others, they simply don’t show up.

Did I miss something or have anyone else the same error?

I’ve had the same issue - just created a post before seeing yours

If you follow the merged pull requests - you see it’s not just braviatv platforms

1 Like

I think you mean 0.96.1.

But your post is useless, no logs, no details of which platform. No details of your config.

Hi Nick,

I’m sorry, but I am running 0.96.2 right now.
Tried to update my post as well with the information my level of skills can provide.

Please help me optain with anything else that can help.

Could it be related to the built-in media player engine then?


I’m kinda embarrased and feel sorry, but at least it got solved.
Some time ago after another update I had issues with my Samsung TV, so I tried the custom component of Samsung TV, which had a file. For some reason I had it saved under a library that didn’t make sense, so that was why I didn’t notice it in the first place.
So I went ahead and removed the custom component library, rebooted the Hassio and viola - I’m up and running again!

Thanks… :blush: