MELCLOUD not working?

Since yesterday evening I can’t get MELCLOUD to work. HASS thinks it is working, but nothing happens with neither of my two units when issuing commands. Temperature data has also flatlined at the latest measurement since yesterday.

Anyone else experiencing this?

Addition: Checking the wifi traffic, there was a surge on both my units at around 19:30 CET yesterday, which makes me suspect that Mitsubishi have automatically upgraded the software in the units.

Edit: I put up a webpage (in Swedish - you can autotranslate), with some graphics on the outage Mitsubishis MELCLOUD nere – kontrollera fritidshusets värmepump – Cornucopia?


Same here, about the same time yesterday. Heating should have been stopped by an automation at 10pm, and actually didn’t. Still doesn’t work this morning.
Anyway, Melcloud app doesn’t work anymore either, so I guess there is nothing we can do.

1 Like

Yes, checked the app. Does not work.

For me it was the other way around, the heating didn’t start. Didn’t realize until this morning, so now the slippers are on.

1 Like

Same here. Temperature is flat since last night (about 19:50 CET). This is both from HA and the MelCloud App. I was worried that the internet connection had tied for my summer house, but reading these posts, seems that the problem is with Mitsubishi…

Same thing happening here in Croatia on two separate locations controlling one multisplit with two indoors, and five single split aircon units.

I noticed it yesterday when I wanted to turn on the heating on my multi unit.
At one point i managed to turn off one indoor unit (after powering it up with a remote)

WiFi module is connected to the router, but the orange led blinks every 5 sec two times. Unit, and mode led blink green. So its something with MelCloud. I am currently in the process of buying 2 multisplits with 3 indoors each, but this (and the complete Melcloud outdated app) is making me search for other brands.

Same here. The endpoint the devices connect to is giving 503 errors:

$ curl -v
* Host was resolved.
* IPv6: (none)
* IPv4:,,,,,
*   Trying
* Connected to ( port 80
> GET / HTTP/1.1
> Host:
> User-Agent: curl/8.6.0
> Accept: */*
< HTTP/1.1 503 Service Unavailable: Back-end server is at capacity
< Content-Length: 0
< Connection: keep-alive
* Connection #0 to host left intact

The same from Italy, the problem started yesterday, with the Alexa routine doesn’t work,
but the Melcloud app worked.
Today even melcloud doesn’t work.

1 Like

Same here. Our heating did not properly ramp up during the night and woke up to a cold cold house :cold_face: . Had to find the remote control for the first time in a year.

For me, my own API calls do not work, and also Melcloud calls do not properly update the heat pumps status.


I have exactly same problem.
Made support ticket to MelCloud with plenty of details.
From point of view that MelCloud doesnt work ofcourse :grin:


Same issue in denmark.
I saw the wifi module shows an error. So it can’t connect to the server

So we also had a cold morning :stuck_out_tongue_winking_eye:

Same Problem. Dose some one knows if Mecloud have a status page? I can not find any information about this.
And dose some one have tried to flash this thing to work Local?
And how do I get access to the (IP AC)/network
they always ask for password.

Someone tried to reverse engineer to make it work locally but didn’t succeed. They made some progress though: Long-term Memory – Reverse engineering the Mitsubishi heat-pump WiFi adapter


You can supposedly replace the Mitsubishi wifi-module with an ESP8266 or an ESP32 and a pigtal. I have the parts, but haven’t tried it yet. Maybe I will now.

Same issue here in France. My first unit lost connection 2 days ago, and my second one yesterday.


Same issue till yesterday in Midi Pyrénées

1 Like

Just adding my name to this list.

Excellent :wink:

Same here in Finland. Both of my RW35’s down. Woke up cold in the middle of the night. FFS.

Same here in UK connection dropped at 19:52 on 18/04/2024
Does anyone have a solution yet ?

The same problem since yesterday (18 April 2024, local time 20:54, UK time: 19:54) evening. Poland.

Just got this response after contacting the technical support

As you may have noticed, we are currently facing a communication problem regarding our WiFi interfaces. I would like to assure you that our technical team is fully committed to resolving this issue.

We implement all necessary resources to ensure that these inconveniences are resolved as quickly as possible. Our goal is to ensure the reliability and performance of our services, and rest assured that we are working diligently to restore the situation to normal.

Nothing to do but wait I guess.