Mi Smart LED Bulb XMBGDP01YLK - Developer/LAN?

Is there any option how to set developer/LAN on this bulb?
I can install it on Xiaomi Home app but not on Yeelight.
Tried all according to this:
But not helped me. I can not see the bulb in Yeelighjt to switch to LAN.
Thanks for help in advance.



I have the same model and here is what I did to make it work- at least with the latest version of Home Assistant (0.118.3)

  1. Obtain the device token after setting up the bulb using Mi Home app

  2. Install python-miio as shown here

  3. Use the command below to enable developer mode
    % miiocli yeelight --ip 192.168.x.x --token <token> set_developer_mode 1

That’s it, enjoy :wink:


I had to reset bulb and then I connected to bulb wifi with my pc. After that I was able to execute
mirobo discover --handshake 1

in which output I got token.

In case that I first add my bulb to my wifi network with Mi Home and then execute that command I always got only f-s for token which is not correct.

1 Like

So how are you able to connect the bulb to your home wifi after that?

I used the Mi Home app to obtain the token. I used an old version of the app, 5.4.54 I think. It’s what worked for me as described here.

After I got token I used
miiocli yeelight --ip 192.168.x.x --token <token> set_developer_mode 1
to set developer mode on. After that I just used latest Mi Home app to add bulb to my wifi. Developer mode was still set to on and finally I could add it to Home Assistant

1 Like

Did you use android or ios for mi home app?

Android. Mi home from play store.

Looks like dev mode is reset after adding to wifi by Home app. I have denied access to internet for bulb on router. And it is no reacting on app after that
Home Assistent cant find a bulb any way

Could you show a Home Assistant config for this bulb?

Did you try to turn on dev mode again? I think that token should be the same after you pair device with Mi Home app. Token is auth for api and it should be the same. Just you have to change IP to new IP which the bulb will get after you pair it to your home network.

I add it to HA via gui. Integrations, add integration and select Yeelight. In popup I added ip address of my bulb and that was that. Ha connected to my bulb.

Yes, I’ve tried. But it’s not response via router wifi

miiocli yeelight --ip --token 4874a0c1dd9812759ba73e2baef6d44b set_developer_mode 1
/home/parallels/.local/lib/python3.6/site-packages/miio/click_common.py:242: UserWarning: Please consider using python-yeelight for more complete support.
  ctx.obj = self.device_class(*args, **kwargs)
Setting developer mode to True
ERROR:miio.miioprotocol:Got error when receiving: timed out

Hm yes.
While you are on bulb wifi and you set dev mode on. Did you get something like:

Setting developer mode to True

Also I updated my bulb to the latest FM via Mi Home app. Dont know if that helped.

Based on your instructions here, I added this guide which shows exactly what I did to get these bulbs working (I was also getting the timed out error mentioned above before I figured out Step 10):

Thanks for your help!

1 Like

Thanks. I followed your instructions. It works fine.

I just followed all the instructions and read the documentation, but I can’t run the set_developer_mode 1 Setting :frowning:

What I did, I installed:
pip install python-miio

checked the token:
miiocli device --ip ((MYIP) --token ((MYTOKEN) info

Model: yeelink.light.ceiling22
Hardware version: esp32
Firmware version: 2.1.7_0041

Checked the Status and can control the lamp via CLI.
But if I want to change the developer Mode, i run into this Error:
miiocli yeelight --ip ((MYIP)) --token ((MYTOKEN)) set_developer_mode 1

Setting developer mode to True
Error: {‘code’: -5001, ‘message’: ‘invalid params’}

Can you help me?

I was using this command. It is almost same as yours.

miiocli yeelight --ip --token <my_token> set_developer_mode 1`

WARNING:miio.device:Found an unsupported model 'yeelink.light.mono6' for class 'Yeelight'. If this is working for you, please open an issue at https://github.com/rytilahti/python-miio/

WARNING:miio.integrations.light.yeelight.spec_helper:Unknown model yeelink.light.mono6, please open an issue and supply features for this light. Returning generic information.

Setting developer mode to True